summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVlastimil Babka <caster@gentoo.org>2009-09-25 13:17:47 +0000
committerVlastimil Babka <caster@gentoo.org>2009-09-25 13:17:47 +0000
commit1f879f6f00d46efd3727907da039dae5cd4049cb (patch)
tree12bf6de0c976a7f11d84d57b227865756bb2b499 /app-office/taskcoach
parentStable on amd64 (bug #281606) (diff)
downloadgentoo-2-1f879f6f00d46efd3727907da039dae5cd4049cb.tar.gz
gentoo-2-1f879f6f00d46efd3727907da039dae5cd4049cb.tar.bz2
gentoo-2-1f879f6f00d46efd3727907da039dae5cd4049cb.zip
Version bump.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'app-office/taskcoach')
-rw-r--r--app-office/taskcoach/ChangeLog7
-rw-r--r--app-office/taskcoach/taskcoach-0.74.1.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/app-office/taskcoach/ChangeLog b/app-office/taskcoach/ChangeLog
index 8c0019cb78b0..b11aafd85bbd 100644
--- a/app-office/taskcoach/ChangeLog
+++ b/app-office/taskcoach/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/taskcoach
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.30 2009/07/10 07:42:08 caster Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/ChangeLog,v 1.31 2009/09/25 13:17:47 caster Exp $
+
+*taskcoach-0.74.1 (25 Sep 2009)
+
+ 25 Sep 2009; Vlastimil Babka <caster@gentoo.org> +taskcoach-0.74.1.ebuild:
+ Version bump.
*taskcoach-0.73.2 (10 Jul 2009)
diff --git a/app-office/taskcoach/taskcoach-0.74.1.ebuild b/app-office/taskcoach/taskcoach-0.74.1.ebuild
new file mode 100644
index 000000000000..3db313bb259f
--- /dev/null
+++ b/app-office/taskcoach/taskcoach-0.74.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/taskcoach/taskcoach-0.74.1.ebuild,v 1.1 2009/09/25 13:17:47 caster Exp $
+
+EAPI=1
+
+inherit distutils eutils
+
+MY_PN="TaskCoach"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple personal tasks and todo lists manager"
+HOMEPAGE="http://www.taskcoach.org"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=">=dev-lang/python-2.4
+ >=dev-python/wxpython-2.8.9.2:2.8"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+# disappeared in 0.73.2, maybe will appear again?
+#DOCS="CHANGES.txt"
+
+src_unpack() {
+ distutils_src_unpack
+
+ cd "${S}"
+ if ! use x86; then
+ elog "Removing Funambol support, works only on x86."
+ rm -fv taskcoachlib/bin.in/linux/*.so || die
+ fi
+}
+
+src_compile() {
+ # upstream now sets executable to /usr/bin/python2.5
+ distutils_src_compile --executable=/usr/bin/python
+}
+
+src_install() {
+ distutils_src_install
+
+ mv "${D}/usr/bin/taskcoach.py" "${D}/usr/bin/taskcoach" || die
+ rm "${D}/usr/bin/taskcoach.pyw" || die
+
+ doicon "icons.in/${PN}.png" || die
+ make_desktop_entry ${PN} "Task Coach" ${PN} Office || die
+}