summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Heinlein <keytoaster@gentoo.org>2008-05-26 19:56:44 +0000
committerTobias Heinlein <keytoaster@gentoo.org>2008-05-26 19:56:44 +0000
commitad6ae5aa879d87cc5625127cd3f571bd75906075 (patch)
tree4b466279571842a3df156bb341e47a2e1078c7e6 /app-misc
parentppc stable, bug #215705 (diff)
downloadgentoo-2-ad6ae5aa879d87cc5625127cd3f571bd75906075.tar.gz
gentoo-2-ad6ae5aa879d87cc5625127cd3f571bd75906075.tar.bz2
gentoo-2-ad6ae5aa879d87cc5625127cd3f571bd75906075.zip
Version bump and additional patch for security bug #223657
(Portage version: 2.1.5.2)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/cbrpager/ChangeLog8
-rw-r--r--app-misc/cbrpager/cbrpager-0.9.17.ebuild32
-rw-r--r--app-misc/cbrpager/files/cbrpager-0.9.17-zip-filen-escape.patch23
3 files changed, 62 insertions, 1 deletions
diff --git a/app-misc/cbrpager/ChangeLog b/app-misc/cbrpager/ChangeLog
index ea10f9a9c05b..f553a7fb7f11 100644
--- a/app-misc/cbrpager/ChangeLog
+++ b/app-misc/cbrpager/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/cbrpager
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/cbrpager/ChangeLog,v 1.7 2008/01/16 11:04:23 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cbrpager/ChangeLog,v 1.8 2008/05/26 19:56:44 keytoaster Exp $
+
+*cbrpager-0.9.17 (26 May 2008)
+
+ 26 May 2008; Tobias Heinlein <keytoaster@gentoo.org>
+ +files/cbrpager-0.9.17-zip-filen-escape.patch, +cbrpager-0.9.17.ebuild:
+ Version bump and additional patch for security bug #223657
*cbrpager-0.9.15 (16 Jan 2008)
diff --git a/app-misc/cbrpager/cbrpager-0.9.17.ebuild b/app-misc/cbrpager/cbrpager-0.9.17.ebuild
new file mode 100644
index 000000000000..df72d77359ea
--- /dev/null
+++ b/app-misc/cbrpager/cbrpager-0.9.17.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/cbrpager/cbrpager-0.9.17.ebuild,v 1.1 2008/05/26 19:56:44 keytoaster Exp $
+
+inherit eutils
+
+DESCRIPTION="a simple comic book pager."
+HOMEPAGE="http://cbrpager.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="|| ( app-arch/unrar app-arch/unrar-gpl app-arch/rar )
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/libgnomecanvas-2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-zip-filen-escape.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed."
+ dodoc AUTHORS ChangeLog CONTRIBUTORS NEWS README TODO
+ make_desktop_entry ${PN} "CBR Pager" ${PN} "Graphics;Viewer;Amusement;GTK"
+}
diff --git a/app-misc/cbrpager/files/cbrpager-0.9.17-zip-filen-escape.patch b/app-misc/cbrpager/files/cbrpager-0.9.17-zip-filen-escape.patch
new file mode 100644
index 000000000000..b191114df918
--- /dev/null
+++ b/app-misc/cbrpager/files/cbrpager-0.9.17-zip-filen-escape.patch
@@ -0,0 +1,23 @@
+--- cbrpager-0.9.17/src/global.c.debug 2008-05-24 05:46:57.000000000 +0900
++++ cbrpager-0.9.17/src/global.c 2008-05-26 04:11:08.000000000 +0900
+@@ -324,7 +324,7 @@
+ esc[idx] = '\0';
+
+ printf(_("Requesting page %d/%d (%s)\n"), nr+1,
+- g_list_length(pagelist), esc);
++ g_list_length(pagelist), p);
+
+ /* The following patch was received from Mamoru Tasaka, 2008/05/22
+ to solve potential security problems with the system() call */
+@@ -354,9 +354,10 @@
+ pref.lastbook, p, (char *)NULL);
+ return; /* should not reach here */
+ case ZIP_FILE:
++ /* for zip file, esc must be passed instead of p */
+ execlp("unzip",
+ "unzip", "-p", "-C",
+- pref.lastbook, p, (char *)NULL);
++ pref.lastbook, esc, (char *)NULL);
+ return; /* should not reach here */
+ }
+ return; /* should not reach here */