summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-14 12:31:07 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-14 12:31:07 +0000
commit88a39baef03d0428bfaec7a88fda9a5e0e4ccbe8 (patch)
treedffacc7c83cd56a6252e01d89d65d12eb1d0fc21 /app-misc
parentVersion bump (diff)
downloadgentoo-2-88a39baef03d0428bfaec7a88fda9a5e0e4ccbe8.tar.gz
gentoo-2-88a39baef03d0428bfaec7a88fda9a5e0e4ccbe8.tar.bz2
gentoo-2-88a39baef03d0428bfaec7a88fda9a5e0e4ccbe8.zip
Add new strigi 0.6.3
(Portage version: 2.2_rc21/cvs/Linux 2.6.28-gentoo x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/strigi/ChangeLog9
-rw-r--r--app-misc/strigi/strigi-0.6.3.ebuild93
2 files changed, 100 insertions, 2 deletions
diff --git a/app-misc/strigi/ChangeLog b/app-misc/strigi/ChangeLog
index b4e9569cbc6b..1763d227a562 100644
--- a/app-misc/strigi/ChangeLog
+++ b/app-misc/strigi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/strigi
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.19 2008/12/14 23:15:38 jmbsvicetto Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/ChangeLog,v 1.20 2009/01/14 12:31:07 alexxy Exp $
+
+*strigi-0.6.3 (14 Jan 2009)
+
+ 14 Jan 2009; Alexey Shvetsov <alexxy@gentoo.org> +strigi-0.6.3.ebuild:
+ Import Bump new strigi to 0.6.3
14 Dec 2008; Jorge Manuel B. S. Vicetto <jmbsvicetto@gentoo.org>
strigi-0.5.8.ebuild, strigi-0.5.9.ebuild, strigi-0.5.10.ebuild,
diff --git a/app-misc/strigi/strigi-0.6.3.ebuild b/app-misc/strigi/strigi-0.6.3.ebuild
new file mode 100644
index 000000000000..de458e5541da
--- /dev/null
+++ b/app-misc/strigi/strigi-0.6.3.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/strigi/strigi-0.6.3.ebuild,v 1.1 2009/01/14 12:31:07 alexxy Exp $
+
+EAPI="2"
+
+inherit cmake-utils eutils
+
+DESCRIPTION="Fast crawling desktop search engine with Qt4 GUI"
+HOMEPAGE="http://www.vandenoever.info/software/strigi"
+SRC_URI="http://www.vandenoever.info/software/strigi/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+clucene +dbus debug exif fam hyperestraier inotify log +qt4 test"
+
+COMMONDEPEND="
+ dev-libs/libxml2
+ virtual/libiconv
+ clucene? ( >=dev-cpp/clucene-0.9.19 )
+ dbus? ( sys-apps/dbus
+ || ( ( x11-libs/qt-dbus:4
+ x11-libs/qt-gui:4 )
+ =x11-libs/qt-4.3*:4[dbus] )
+ )
+ exif? ( media-gfx/exiv2 )
+ fam? ( virtual/fam )
+ hyperestraier? ( app-text/hyperestraier )
+ log? ( >=dev-libs/log4cxx-0.9.7 )
+ qt4? (
+ || ( ( x11-libs/qt-core:4
+ x11-libs/qt-gui:4
+ x11-libs/qt-dbus:4 )
+ =x11-libs/qt-4.3*:4[dbus] )
+ )
+ !clucene? (
+ !hyperestraier? (
+ >=dev-cpp/clucene-0.9.19
+ )
+ )
+"
+# sqlite? ( dev-db/sqlite:3 )"
+DEPEND="${COMMONDEPEND}
+ test? ( dev-util/cppunit )"
+RDEPEND="${COMMONDEPEND}"
+
+src_compile() {
+ # Strigi needs either expat or libxml2.
+ # However libxml2 seems to be required in both cases, linking to 2 xml parsers
+ # is just silly, so we forcefully disable linking to expat.
+ # Enabled: POLLING (only reliable way to check for files changed.)
+
+ mycmakeargs="${mycmakeargs}
+ -DENABLE_EXPAT=OFF -DENABLE_POLLING=ON
+ -DFORCE_DEPS=ON -DENABLE_CPPUNIT=OFF
+ -DENABLE_REGENERATEXSD=OFF
+ $(cmake-utils_use_enable clucene CLUCENE)
+ $(cmake-utils_use_enable dbus DBUS)
+ $(cmake-utils_use_enable exif EXIV2)
+ $(cmake-utils_use_enable fam FAM)
+ $(cmake-utils_use_enable hyperestraier HYPERESTRAIER)
+ $(cmake-utils_use_enable inotify INOTIFY)
+ $(cmake-utils_use_enable log LOG4CXX)
+ $(cmake-utils_use_enable qt4 DBUS)
+ $(cmake-utils_use_enable qt4 QT4)"
+# $(cmake-utils_use_enable sqlite SQLITE)"
+
+ if ! use clucene && ! use hyperestraier; then # && ! use sqlite; then
+ mycmakeargs="${mycmakeargs} -DENABLE_CLUCENE=ON"
+ fi
+
+ cmake-utils_src_compile
+}
+
+src_test() {
+ mycmakeargs="${mycmakeargs} -DENABLE_CPPUNIT=ON"
+ cmake-utils_src_compile
+
+ pushd "${WORKDIR}/${PN}_build"
+ ctest --extra-verbose || die "Tests failed."
+ popd
+}
+
+pkg_postinst() {
+ if ! use clucene && ! use hyperestraier; then # && ! use sqlite; then
+ elog "Because you didn't enable any of the supported backends:"
+ elog "clucene, hyperestraier and sqlite"
+ elog "clucene support was silently installed."
+ elog "If you prefer another backend, be sure to reinstall strigi"
+ elog "and to enable that backend use flag"
+ fi
+}