summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-08-30 23:37:30 +0000
committerMichael Weber <xmw@gentoo.org>2010-08-30 23:37:30 +0000
commit6d2a4b0ea6b878ce332d1dbf70d1b9d098e22adb (patch)
treedfadf537cd3c8425b53bda616c205d89b76ecbad /app-misc
parentVersion bump for bug #333121. Remove old, broken version; closes bugs #321203... (diff)
downloadgentoo-2-6d2a4b0ea6b878ce332d1dbf70d1b9d098e22adb.tar.gz
gentoo-2-6d2a4b0ea6b878ce332d1dbf70d1b9d098e22adb.tar.bz2
gentoo-2-6d2a4b0ea6b878ce332d1dbf70d1b9d098e22adb.zip
Version bump, fixes 332041
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/flasm/ChangeLog8
-rw-r--r--app-misc/flasm/files/flasm-1.63-makefile.patch27
-rw-r--r--app-misc/flasm/flasm-1.62.ebuild4
-rw-r--r--app-misc/flasm/flasm-1.63.ebuild41
4 files changed, 77 insertions, 3 deletions
diff --git a/app-misc/flasm/ChangeLog b/app-misc/flasm/ChangeLog
index c2ed132c900c..85475f6908e8 100644
--- a/app-misc/flasm/ChangeLog
+++ b/app-misc/flasm/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-misc/flasm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/flasm/ChangeLog,v 1.9 2010/02/23 10:17:54 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/flasm/ChangeLog,v 1.10 2010/08/30 23:37:30 xmw Exp $
+
+*flasm-1.63 (30 Aug 2010)
+
+ 30 Aug 2010; Michael Weber (xmw) <xmw@gentoo.org> +flasm-1.63.ebuild,
+ +files/flasm-1.63-makefile.patch:
+ Version bump, fixes bug #332041. -bison-2.patch included by upstream.
23 Feb 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
files/flasm-1.62-makefile.patch:
diff --git a/app-misc/flasm/files/flasm-1.63-makefile.patch b/app-misc/flasm/files/flasm-1.63-makefile.patch
new file mode 100644
index 000000000000..32ea2bc00181
--- /dev/null
+++ b/app-misc/flasm/files/flasm-1.63-makefile.patch
@@ -0,0 +1,27 @@
+--- Makefile.o 2010-08-31 01:17:46.505000089 +0200
++++ Makefile 2010-08-31 01:19:11.841000098 +0200
+@@ -1,6 +1,4 @@
+ UNAME = $(shell uname)
+-CC = gcc
+-CFLAGS = -g -Wall -O2
+ LIBS = -lz
+ OFILES = util.o keywords.o flasm.o unflasm.o lex.yy.o assembler.tab.o
+ GARBAGE = assembler.tab.* lex.yy.c memwatch.o gmon.out memwatch.log core
+@@ -9,8 +7,6 @@
+ ifneq (,$(findstring debug,$(MAKECMDGOALS)))
+ CFLAGS += -DMEMWATCH -pg -p -pedantic -W -Wcast-align -Wcast-qual -Wshadow -Wnested-externs -Wstrict-prototypes -Waggregate-return -Wmissing-prototypes -Wpointer-arith
+ OFILES += memwatch.o
+-else
+- CFLAGS += -s
+ endif
+
+ # executable should not depend on cygwin.dll
+@@ -26,7 +22,7 @@
+ -rm -f ${OFILES} ${GARBAGE}
+
+ flasm: ${OFILES}
+- ${CC} $(CFLAGS) -o flasm ${OFILES} ${LIBS}
++ ${CC} $(CFLAGS) $(LDFLAGS) -o flasm ${OFILES} ${LIBS}
+
+ assembler.tab.c assembler.tab.h: assembler.y
+ bison --defines --debug assembler.y
diff --git a/app-misc/flasm/flasm-1.62.ebuild b/app-misc/flasm/flasm-1.62.ebuild
index d4f213ca55d1..87e1f4fe122a 100644
--- a/app-misc/flasm/flasm-1.62.ebuild
+++ b/app-misc/flasm/flasm-1.62.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/flasm/flasm-1.62.ebuild,v 1.1 2009/10/26 16:26:21 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/flasm/flasm-1.62.ebuild,v 1.2 2010/08/30 23:37:30 xmw Exp $
inherit eutils versionator toolchain-funcs
diff --git a/app-misc/flasm/flasm-1.63.ebuild b/app-misc/flasm/flasm-1.63.ebuild
new file mode 100644
index 000000000000..e6322f622a00
--- /dev/null
+++ b/app-misc/flasm/flasm-1.63.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/flasm/flasm-1.63.ebuild,v 1.1 2010/08/30 23:37:30 xmw Exp $
+
+EAPI=2
+
+inherit eutils versionator toolchain-funcs
+
+MY_PV=$(delete_all_version_separators $(get_version_component_range 1-2))
+DESCRIPTION="Command line assembler/disassembler of Flash ActionScript bytecode"
+HOMEPAGE="http://www.nowrap.de/flasm.html"
+SRC_URI="http://www.nowrap.de/download/flasm${MY_PV}src.zip -> ${P}.zip"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ sys-devel/flex
+ sys-devel/bison
+ dev-util/gperf"
+
+S=${WORKDIR}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin flasm || die
+ dodoc CHANGES.TXT || die
+ dohtml flasm.html classic.css || die
+}