summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHeinrich Wendel <lanius@gentoo.org>2005-01-26 17:21:44 +0000
committerHeinrich Wendel <lanius@gentoo.org>2005-01-26 17:21:44 +0000
commit3167c762cc92cb0b4fa8fa78700256af520291de (patch)
treec6e1246042c8c5c0fde2ac16f91175c3d53b71b2 /app-misc
parentfixed memory overwrite in bio patch (Manifest recommit) (diff)
downloadgentoo-2-3167c762cc92cb0b4fa8fa78700256af520291de.tar.gz
gentoo-2-3167c762cc92cb0b4fa8fa78700256af520291de.tar.bz2
gentoo-2-3167c762cc92cb0b4fa8fa78700256af520291de.zip
stable on amd64; filter some flags
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/lirc/ChangeLog5
-rw-r--r--app-misc/lirc/lirc-0.7.0-r1.ebuild16
2 files changed, 16 insertions, 5 deletions
diff --git a/app-misc/lirc/ChangeLog b/app-misc/lirc/ChangeLog
index 4fe962b94c85..ed1c924815e6 100644
--- a/app-misc/lirc/ChangeLog
+++ b/app-misc/lirc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-misc/lirc
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.59 2005/01/20 21:33:51 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/ChangeLog,v 1.60 2005/01/26 17:21:44 lanius Exp $
+
+ 26 Jan 2005; lanius@gentoo.org lirc-0.7.0-r1.ebuild:
+ filter some flags; stable on amd64
20 Jan 2005; lanius@gentoo.org lirc-0.7.0-r1.ebuild:
stable on x86
diff --git a/app-misc/lirc/lirc-0.7.0-r1.ebuild b/app-misc/lirc/lirc-0.7.0-r1.ebuild
index a1a6eea0ae25..d80415234839 100644
--- a/app-misc/lirc/lirc-0.7.0-r1.ebuild
+++ b/app-misc/lirc/lirc-0.7.0-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.7.0-r1.ebuild,v 1.6 2005/01/20 21:33:51 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/lirc/lirc-0.7.0-r1.ebuild,v 1.7 2005/01/26 17:21:44 lanius Exp $
-inherit eutils linux-mod
+inherit eutils linux-mod flag-o-matic
DESCRIPTION="LIRC is a package that allows you to decode and send infra-red \
signals of many (but not all) commonly used remote controls."
@@ -43,7 +43,7 @@ HOMEPAGE="http://www.lirc.org"
SLOT="0"
LICENSE="GPL-2"
IUSE="debug doc streamzap"
-KEYWORDS="x86 ~ppc ~alpha ~ia64 ~amd64 ~ppc64"
+KEYWORDS="x86 ~ppc ~alpha ~ia64 amd64 ~ppc64"
RDEPEND="virtual/libc
X11? ( virtual/x11 )"
@@ -57,10 +57,18 @@ SRC_URI="mirror://sourceforge/lirc/${P}.tar.bz2"
src_unpack() {
unpack ${A}
cd ${S}
- use streamzap && epatch ${FILESDIR}/lirc-0.7.0-streamzap.patch.bz2
+ if use streamzap; then
+ if kernel_is 2 6; then
+ ewarn "Streamzap is not Kernel 2.6 ready and will not be compiled"
+ else
+ epatch ${FILESDIR}/lirc-0.7.0-streamzap.patch.bz2
+ fi
+ fi
if [ "${PROFILE_ARCH}" == "xbox" ]; then
epatch ${FILESDIR}/lirc-0.7.0-xbox.patch.bz2
fi
+
+ filter-flags -Wl,-O1
sed -i -e "s:-O2 -g:${CFLAGS}:" configure configure.in
}