summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-12-17 19:16:07 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-12-17 19:16:07 +0000
commit1d7f37eb35f68de700539d9acccbcb6ca700b0b7 (patch)
treed9a33d3ff5888f2f23e788ff0fa75d9982d7a9d4 /app-misc
parentamd64 stable, nice, this version doesn't fail on DiskUsage test inside chroot... (diff)
downloadgentoo-2-1d7f37eb35f68de700539d9acccbcb6ca700b0b7.tar.gz
gentoo-2-1d7f37eb35f68de700539d9acccbcb6ca700b0b7.tar.bz2
gentoo-2-1d7f37eb35f68de700539d9acccbcb6ca700b0b7.zip
Don't strip files, fix man install, respect CFLAGS, bug #152257, version bump, bug #194296
(Portage version: 2.1.4_rc10)
Diffstat (limited to 'app-misc')
-rw-r--r--app-misc/birthday/ChangeLog9
-rw-r--r--app-misc/birthday/birthday-1.5.ebuild21
-rw-r--r--app-misc/birthday/birthday-1.6.2.ebuild31
-rw-r--r--app-misc/birthday/files/digest-birthday-1.6.23
4 files changed, 57 insertions, 7 deletions
diff --git a/app-misc/birthday/ChangeLog b/app-misc/birthday/ChangeLog
index 119d11d2d7a7..a33602c940e4 100644
--- a/app-misc/birthday/ChangeLog
+++ b/app-misc/birthday/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-misc/birthday
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/birthday/ChangeLog,v 1.13 2007/02/08 22:25:58 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/birthday/ChangeLog,v 1.14 2007/12/17 19:16:06 armin76 Exp $
+
+*birthday-1.6.2 (17 Dec 2007)
+
+ 17 Dec 2007; Raúl Porcel <armin76@gentoo.org> birthday-1.5.ebuild,
+ +birthday-1.6.2.ebuild:
+ Don't strip files, fix man install, respect CFLAGS, bug #152257, version
+ bump, bug #194296
08 Feb 2007; Diego Pettenò <flameeyes@gentoo.org> ChangeLog:
Regenerate digest in Manifest2 format.
diff --git a/app-misc/birthday/birthday-1.5.ebuild b/app-misc/birthday/birthday-1.5.ebuild
index c6d7ae8526db..b9f0c86bd76f 100644
--- a/app-misc/birthday/birthday-1.5.ebuild
+++ b/app-misc/birthday/birthday-1.5.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/birthday/birthday-1.5.ebuild,v 1.14 2005/04/21 19:02:37 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/birthday/birthday-1.5.ebuild,v 1.15 2007/12/17 19:16:06 armin76 Exp $
+
+inherit toolchain-funcs
DESCRIPTION="Displays a list of events happening in the near future"
HOMEPAGE="http://users.zetnet.co.uk/mortia/source/"
@@ -8,15 +10,22 @@ SRC_URI="http://users.zetnet.co.uk/mortia/source/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 ppc sparc amd64 ppc64"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
IUSE=""
-DEPEND="virtual/libc"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ Makefile.in
+}
src_compile() {
- emake || die
+ emake CC=$(tc-getCC) birthday || die "emake failed"
}
src_install() {
- make DESTDIR=${D} install || die
+ emake DESTDIR="${D}" install || die "emake install failed"
}
diff --git a/app-misc/birthday/birthday-1.6.2.ebuild b/app-misc/birthday/birthday-1.6.2.ebuild
new file mode 100644
index 000000000000..bfd2051f929a
--- /dev/null
+++ b/app-misc/birthday/birthday-1.6.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/birthday/birthday-1.6.2.ebuild,v 1.1 2007/12/17 19:16:06 armin76 Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="Displays a list of events happening in the near future"
+HOMEPAGE="http://sourceforge.net/projects/birthday/"
+SRC_URI="mirror://sourceforge/birthday/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Don't strip, install in correct share dir and respect CFLAGS
+ sed -i -e "s:install -s:install:g" -e "s:#SHARE:SHARE:g" -e "s:-O2:${CFLAGS}:g" \
+ Makefile
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+}
diff --git a/app-misc/birthday/files/digest-birthday-1.6.2 b/app-misc/birthday/files/digest-birthday-1.6.2
new file mode 100644
index 000000000000..e2803dac99e8
--- /dev/null
+++ b/app-misc/birthday/files/digest-birthday-1.6.2
@@ -0,0 +1,3 @@
+MD5 bf9c4a1d5ace445b8fcf2f0f5f6a82db birthday-1.6.2.tar.bz2 85617
+RMD160 88454187e6f532f5687b89ff5c50ad3724b30b1f birthday-1.6.2.tar.bz2 85617
+SHA256 355ad07ad3312d8f5c5b54c71596ac3a0e706c539167900d73cb65df30c8e2f4 birthday-1.6.2.tar.bz2 85617