summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-08-14 23:23:45 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-08-14 23:23:45 +0000
commit3abc0bc2ad466600d3fcdf0c9201dd929823517f (patch)
tree020ade31232b630d763eb62a2ee3d7456ebb5d25 /app-misc/cwiid/files
parentBackporting test fixes from meep-1.2, hopefully fixing bug #423247 (diff)
downloadgentoo-2-3abc0bc2ad466600d3fcdf0c9201dd929823517f.tar.gz
gentoo-2-3abc0bc2ad466600d3fcdf0c9201dd929823517f.tar.bz2
gentoo-2-3abc0bc2ad466600d3fcdf0c9201dd929823517f.zip
fix underlinking wrt #367349
(Portage version: 2.2.0_alpha121/cvs/Linux x86_64)
Diffstat (limited to 'app-misc/cwiid/files')
-rw-r--r--app-misc/cwiid/files/cwiid-20110107-underlinking.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-misc/cwiid/files/cwiid-20110107-underlinking.patch b/app-misc/cwiid/files/cwiid-20110107-underlinking.patch
new file mode 100644
index 000000000000..b60f379fc9cc
--- /dev/null
+++ b/app-misc/cwiid/files/cwiid-20110107-underlinking.patch
@@ -0,0 +1,31 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Tue Aug 14 23:04:03 UTC 2012
+Subject: build system
+
+fix build for linkers that don't permit underlinking
+
+--- configure.ac
++++ configure.ac
+@@ -69,6 +69,8 @@
+ AC_MSG_ERROR([linux/uinput.h]),
+ [#include <linux/input.h>])
+
++PKG_CHECK_MODULES([BLUETOOTH], [bluez])
++
+ AC_ISC_POSIX
+
+ AC_ARG_WITH(cwiid-config-dir,AC_HELP_STRING([--with-cwiid-config-dir],
+--- wmdemo/Makefile.in
++++ wmdemo/Makefile.in
+@@ -6,9 +6,9 @@
+
+ SOURCES = wmdemo.c
+
+-CFLAGS += -I@top_builddir@/libcwiid
++CFLAGS += -I@top_builddir@/libcwiid @BLUETOOTH_CFLAGS@
+ LDFLAGS += -L@top_builddir@/libcwiid
+-LDLIBS += -lcwiid
++LDLIBS += -lcwiid @BLUETOOTH_LIBS@
+ INST_DIR = @bindir@
+
+ include $(COMMON)/include/app.mak