summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-05-01 13:43:23 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-05-01 13:43:23 +0000
commitb286cd8f131b72d676f44d1ff5c1040568bda4d2 (patch)
treecf0777650bcb8affe0b116a5bb8a8a199e763254 /app-laptop/hdapsd
parentConvert from built_with_use to has_version and clean up (diff)
downloadgentoo-2-b286cd8f131b72d676f44d1ff5c1040568bda4d2.tar.gz
gentoo-2-b286cd8f131b72d676f44d1ff5c1040568bda4d2.tar.bz2
gentoo-2-b286cd8f131b72d676f44d1ff5c1040568bda4d2.zip
old
(Portage version: 2.2.0_alpha30/cvs/Linux x86_64)
Diffstat (limited to 'app-laptop/hdapsd')
-rw-r--r--app-laptop/hdapsd/files/hdaps-Z60m.patch10
-rw-r--r--app-laptop/hdapsd/hdapsd-20060409-r1.ebuild91
-rw-r--r--app-laptop/hdapsd/hdapsd-20060409-r3.ebuild100
-rw-r--r--app-laptop/hdapsd/hdapsd-20060409.ebuild91
4 files changed, 0 insertions, 292 deletions
diff --git a/app-laptop/hdapsd/files/hdaps-Z60m.patch b/app-laptop/hdapsd/files/hdaps-Z60m.patch
deleted file mode 100644
index 57c723c01b6a..000000000000
--- a/app-laptop/hdapsd/files/hdaps-Z60m.patch
+++ /dev/null
@@ -1,10 +0,0 @@
---- drivers/hwmon/hdaps.c 2006-06-26 09:37:31.131424200 +0100
-+++ drivers/hwmon/hdaps.c 2006-06-26 09:39:49.000000000 +0100
-@@ -539,6 +539,7 @@
- HDAPS_DMI_MATCH_NORMAL("ThinkPad X41 Tablet"),
- HDAPS_DMI_MATCH_NORMAL("ThinkPad X41"),
- HDAPS_DMI_MATCH_LENOVO("ThinkPad X60"),
-+ HDAPS_DMI_MATCH_NORMAL("ThinkPad Z60m"),
- { .ident = NULL }
- };
-
diff --git a/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild b/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild
deleted file mode 100644
index a29f25a07ae2..000000000000
--- a/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20060409-r1.ebuild,v 1.4 2009/08/31 22:02:20 ikelos Exp $
-
-inherit eutils linux-info
-
-PROTECT_VER="2"
-
-DESCRIPTION="IBM ThinkPad Harddrive Active Protection disk head parking daemon"
-HOMEPAGE="http://hdaps.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.c.bz2
- mirror://gentoo/hdaps_protect-patches-${PROTECT_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-CONFIG_CHECK="~SENSORS_HDAPS"
-ERROR_SENSORS_HDAPS="${P} requires support for HDAPS (CONFIG_SENSORS_HDAPS)"
-
-src_compile() {
- cd "${WORKDIR}"
- gcc ${CFLAGS} "${P}".c -o hdapsd || die "failed to compile"
-}
-
-src_install() {
- dosbin "${WORKDIR}"/hdapsd
- newconfd "${FILESDIR}"/hdapsd.conf hdapsd
- newinitd "${FILESDIR}"/hdapsd.init hdapsd
-
- # Install our kernel patches
- dodoc *.patch "${FILESDIR}"/hdaps-Z60m.patch
-}
-
-# Yes, this sucks as the source location may change, kernel sources may not be
-# installed, but we try our best anyway
-kernel_patched() {
- get_version
-
- if grep -qs "blk_protect_register" "${KERNEL_DIR}"/block/ll_rw_blk.c ; then
- einfo "Your kernel has already been patched for blk_freeze"
- return 0
- fi
-
- return 1
-}
-
-pkg_config() {
- kernel_patched && return 0
-
- local docdir="${ROOT}/usr/share/doc/${PF}/"
- local p="hdaps_protect-${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}.patch.gz"
-
- # We need to find our FILESDIR as it's now lost
- if [[ ! -e ${docdir}/${p} ]] ; then
- eerror "We don't have a patch for kernel ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} yet"
- return 1
- fi
-
- if [[ ! -d ${KERNEL_DIR} ]] ; then
- eerror "Kernel sources not found!"
- return 1
- fi
-
- cd "${KERNEL_DIR}"
- epatch "${docdir}/${p}"
-
- # This is just a nice to have for me as I use a Z60m myself
- if ! grep -q "Z60m" "${KERNEL_DIR}"/drivers/hwmon/hdaps.c ; then
- epatch "${docdir}"/hdaps-Z60m.patch.gz
- fi
-
- echo
- einfo "Now you should rebuild your kernel, its modules"
- einfo "and then install them."
-}
-
-pkg_postinst(){
- [[ -n $(ls "${ROOT}"/sys/block/*/queue/protect 2>/dev/null) ]] && return 0
-
- if ! kernel_patched ; then
- ewarn "Your kernel has NOT been patched for blk_freeze"
- elog "The ebuild can attempt to patch your kernel like so"
- elog " emerge --config =${PF}"
- fi
-}
diff --git a/app-laptop/hdapsd/hdapsd-20060409-r3.ebuild b/app-laptop/hdapsd/hdapsd-20060409-r3.ebuild
deleted file mode 100644
index 65f309aefa04..000000000000
--- a/app-laptop/hdapsd/hdapsd-20060409-r3.ebuild
+++ /dev/null
@@ -1,100 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20060409-r3.ebuild,v 1.2 2009/08/31 22:02:20 ikelos Exp $
-
-inherit eutils linux-info
-
-PROTECT_VER="2"
-
-DESCRIPTION="IBM ThinkPad Harddrive Active Protection disk head parking daemon"
-HOMEPAGE="http://hdaps.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.c.bz2
- mirror://gentoo/hdaps_protect-patches-${PROTECT_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-src_compile() {
- # We require the hdaps module; problem is that it can come from either
- # kernel sources or from the tp_smapi package. This hack is required because
- # the linux-info eclass doesn't export any more suitable config checkers.
- # Here we just skip calling its pkg_setup() in case the module is provided
- # by the package.
-
- if ! has_version app-laptop/tp_smapi || ! built_with_use app-laptop/tp_smapi hdaps; then
- CONFIG_CHECK="~SENSORS_HDAPS"
- ERROR_SENSORS_HDAPS="${P} requires support for HDAPS (CONFIG_SENSORS_HDAPS)"
- linux-info_pkg_setup
- fi
-
- cd "${WORKDIR}"
- gcc ${CFLAGS} "${P}".c -o hdapsd || die "failed to compile"
-}
-
-src_install() {
- dosbin "${WORKDIR}"/hdapsd
- newconfd "${FILESDIR}"/hdapsd.conf hdapsd
- newinitd "${FILESDIR}"/hdapsd.init hdapsd
-
- # Install our kernel patches
- dodoc *.patch "${FILESDIR}"/hdaps-Z60m.patch
-}
-
-# Yes, this sucks as the source location may change, kernel sources may not be
-# installed, but we try our best anyway
-kernel_patched() {
- get_version
-
- if grep -qs "blk_protect_register" "${KERNEL_DIR}"/block/ll_rw_blk.c ; then
- einfo "Your kernel has already been patched for blk_freeze"
- return 0
- fi
-
- return 1
-}
-
-pkg_config() {
- kernel_patched && return 0
-
- local docdir="${ROOT}/usr/share/doc/${PF}/"
- local p="hdaps_protect-${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}.patch.gz"
-
- # We need to find our FILESDIR as it's now lost
- if [[ ! -e ${docdir}/${p} ]] ; then
- eerror "We don't have a patch for kernel ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} yet"
- return 1
- fi
-
- if [[ ! -d ${KERNEL_DIR} ]] ; then
- eerror "Kernel sources not found!"
- return 1
- fi
-
- cd "${KERNEL_DIR}"
- epatch "${docdir}/${p}"
-
- # This is just a nice to have for me as I use a Z60m myself
- if ! grep -q "Z60m" "${KERNEL_DIR}"/drivers/hwmon/hdaps.c ; then
- epatch "${docdir}"/hdaps-Z60m.patch.gz
- fi
-
- echo
- einfo "Now you should rebuild your kernel, its modules"
- einfo "and then install them."
-}
-
-pkg_postinst(){
- [[ -n $(ls "${ROOT}"/sys/block/*/queue/protect 2>/dev/null) ]] && return 0
-
- if ! kernel_patched ; then
- ewarn "Your kernel has NOT been patched for blk_freeze"
- elog "The ebuild can attempt to patch your kernel like so"
- elog " emerge --config =${PF}"
- fi
-}
diff --git a/app-laptop/hdapsd/hdapsd-20060409.ebuild b/app-laptop/hdapsd/hdapsd-20060409.ebuild
deleted file mode 100644
index d4961594218b..000000000000
--- a/app-laptop/hdapsd/hdapsd-20060409.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-laptop/hdapsd/hdapsd-20060409.ebuild,v 1.6 2009/08/31 22:02:20 ikelos Exp $
-
-inherit eutils linux-info
-
-PROTECT_VER="1"
-
-DESCRIPTION="IBM ThinkPad Harddrive Active Protection disk head parking daemon"
-HOMEPAGE="http://hdaps.sourceforge.net/"
-SRC_URI="mirror://gentoo/${P}.c.bz2
- mirror://gentoo/hdaps_protect-patches-${PROTECT_VER}.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86"
-
-IUSE=""
-RDEPEND=""
-
-S="${WORKDIR}"
-
-CONFIG_CHECK="~SENSORS_HDAPS"
-ERROR_SENSORS_HDAPS="${P} requires support for HDAPS (CONFIG_SENSORS_HDAPS)"
-
-src_compile() {
- cd "${WORKDIR}"
- gcc ${CFLAGS} "${P}".c -o hdapsd || die "failed to compile"
-}
-
-src_install() {
- dosbin "${WORKDIR}"/hdapsd
- newconfd "${FILESDIR}"/hdapsd.conf hdapsd
- newinitd "${FILESDIR}"/hdapsd.init hdapsd
-
- # Install our kernel patches
- dodoc *.patch "${FILESDIR}"/hdaps-Z60m.patch
-}
-
-# Yes, this sucks as the source location may change, kernel sources may not be
-# installed, but we try our best anyway
-kernel_patched() {
- get_version
-
- if grep -qs "blk_protect_register" "${KERNEL_DIR}"/block/ll_rw_blk.c ; then
- einfo "Your kernel has already been patched for blk_freeze"
- return 0
- fi
-
- return 1
-}
-
-pkg_config() {
- kernel_patched && return 0
-
- local docdir="${ROOT}/usr/share/doc/${PF}/"
- local p="hdaps_protect-${KV_MAJOR}.${KV_MINOR}.${KV_PATCH}.patch.gz"
-
- # We need to find our FILESDIR as it's now lost
- if [[ ! -e ${docdir}/${p} ]] ; then
- eerror "We don't have a patch for kernel ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} yet"
- return 1
- fi
-
- if [[ ! -d ${KERNEL_DIR} ]] ; then
- eerror "Kernel sources not found!"
- return 1
- fi
-
- cd "${KERNEL_DIR}"
- epatch "${docdir}/${p}"
-
- # This is just a nice to have for me as I use a Z60m myself
- if ! grep "Z60m" "${KERNEL_DIR}"/drivers/hwmon/hdaps.c ; then
- epatch "${docdir}"/hdaps-Z60m.patch.gz
- fi
-
- echo
- einfo "Now you should rebuild your kernel, its modules"
- einfo "and then install them."
-}
-
-pkg_postinst(){
- [[ -n $(ls "${ROOT}"/sys/block/*/queue/protect 2>/dev/null) ]] && return 0
-
- if ! kernel_patched ; then
- ewarn "Your kernel has NOT been patched for blk_freeze"
- elog "The ebuild can attempt to patch your kernel like so"
- elog " emerge --config =${PF}"
- fi
-}