summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2005-02-10 11:27:08 +0000
committerMamoru Komachi <usata@gentoo.org>2005-02-10 11:27:08 +0000
commit0f78f6640104a070e0a55bc28e478e82dc586713 (patch)
tree5191edb996a2eff05400fa6f21b7ec9b308e0016 /app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild
parentBump to RSBAC v1.2.4 (diff)
downloadgentoo-2-0f78f6640104a070e0a55bc28e478e82dc586713.tar.gz
gentoo-2-0f78f6640104a070e0a55bc28e478e82dc586713.tar.bz2
gentoo-2-0f78f6640104a070e0a55bc28e478e82dc586713.zip
Changed xcin library path. (to not install files under X11 distribution's directory)
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild')
-rw-r--r--app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild b/app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild
new file mode 100644
index 000000000000..b10fd4d9e6b2
--- /dev/null
+++ b/app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-i18n/xcin/xcin-2.5.3_pre3-r1.ebuild,v 1.1 2005/02/10 11:27:08 usata Exp $
+
+inherit rpm eutils
+
+XCINRPMSRC="${P/_/.}-20.10.firefly.src.rpm"
+
+DESCRIPTION="Chinese X Input Method"
+HOMEPAGE="http://xcin.linux.org.tw/
+ http://firefly.idv.tw/test/Forum.php?Board=1"
+SRC_URI="http://firefly.idv.tw/setfont-xft/Fedora/Core_1/SRPMS/${XCINRPMSRC}"
+
+LICENSE="XCIN"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="nls unicode"
+
+DEPEND="dev-libs/libchewing
+ nls? ( sys-devel/gettext )
+ >=app-i18n/libtabe-0.2.5
+ unicode? ( media-fonts/hkscs-ming )"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd ${S}
+ epatch ${FILESDIR}/xcin-chewing.diff
+
+ # gcc3.2 changed the way we deal with -I. So until the configure script
+ # is updated we need this hack as a work around.
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${P/pre3/pre2}-gentoo.patch
+ EPATCH_OPTS="-d ${S}" epatch ${FILESDIR}/${PN}-db3.patch
+
+ # begin firefly unicode patches
+ cd ${S}
+ for I in ${WORKDIR}/*.patch;do
+ epatch ${I}
+ done
+
+ # paar's fix
+ mv ${S}/xcin/cin/big5/* ${S}/cin/big5/
+}
+
+src_compile() {
+ econf \
+ --with-xcin-rcdir=/etc \
+ --with-xcin-dir=/usr/lib/xcin25 \
+ --with-db-lib=/usr/lib \
+ --with-tabe-inc=/usr/include/tabe \
+ --with-tabe-lib=/usr/lib || die "./configure failed"
+ emake -j1 || die
+}
+
+src_install() {
+ make \
+ prefix=${D}/usr \
+ program_prefix=${D} \
+ install || die
+ dodir /etc
+
+ insinto /etc
+ doins ${FILESDIR}/xcinrc
+ dodoc doc/*
+
+ for docdir in doc/En doc/En/internal doc/history doc/internal doc/modules; do
+ docinto ${docdir#doc/}
+ dodoc ${docdir}/*
+ done
+}