summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2010-02-19 15:06:32 +0000
committerPatrick Lauer <patrick@gentoo.org>2010-02-19 15:06:32 +0000
commitd1c6bf101cf7906a1e39b634b7e0c87da4c50ad8 (patch)
tree22088384fd8f099b54b4c242eb313aac2f8718b6 /app-forensics
parentBump for #305089 (diff)
downloadgentoo-2-d1c6bf101cf7906a1e39b634b7e0c87da4c50ad8.tar.gz
gentoo-2-d1c6bf101cf7906a1e39b634b7e0c87da4c50ad8.tar.bz2
gentoo-2-d1c6bf101cf7906a1e39b634b7e0c87da4c50ad8.zip
Bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'app-forensics')
-rw-r--r--app-forensics/sleuthkit/ChangeLog9
-rw-r--r--app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index 49f3b36ee17c..dfc202ba0570 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-forensics/sleuthkit
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.43 2009/05/01 19:08:42 armin76 Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.44 2010/02/19 15:06:32 patrick Exp $
+
+*sleuthkit-3.1.0 (19 Feb 2010)
+
+ 19 Feb 2010; Patrick Lauer <patrick@gentoo.org> +sleuthkit-3.1.0.ebuild:
+ Bump
01 May 2009; Raúl Porcel <armin76@gentoo.org> sleuthkit-3.0.0-r1.ebuild,
sleuthkit-3.0.1.ebuild:
diff --git a/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild b/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild
new file mode 100644
index 000000000000..66df505ea593
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-3.1.0.ebuild,v 1.1 2010/02/19 15:06:32 patrick Exp $
+
+inherit eutils flag-o-matic autotools
+
+SLOT=0
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz"
+
+LICENSE="GPL-2 IBM"
+KEYWORDS="~amd64 ~arm ~hppa ~s390 ~sparc ~x86"
+
+DEPEND="ewf? ( app-forensics/libewf )
+ aff? ( app-forensics/afflib )"
+RDEPEND="${DEPEND}
+ dev-perl/DateManip"
+
+IUSE="aff ewf"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # AC_FUNC_REALLOC in configure.ac that hasn't been propagated
+ eautoreconf
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc docs/*.txt README.txt CHANGES.txt TODO.txt
+}