summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaphaël Marichez <falco@gentoo.org>2007-04-11 22:20:06 +0000
committerRaphaël Marichez <falco@gentoo.org>2007-04-11 22:20:06 +0000
commit6afc27536a344933baa401e5684bdc57b26c4ee7 (patch)
treedcbbb752287c02350d13c8708ccbf09ccb830482 /app-forensics/sleuthkit
parentadd dbtool USEflag for app-forensics/sleuthkit-2.08 (diff)
downloadgentoo-2-6afc27536a344933baa401e5684bdc57b26c4ee7.tar.gz
gentoo-2-6afc27536a344933baa401e5684bdc57b26c4ee7.tar.bz2
gentoo-2-6afc27536a344933baa401e5684bdc57b26c4ee7.zip
Version bump
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-forensics/sleuthkit')
-rw-r--r--app-forensics/sleuthkit/ChangeLog10
-rw-r--r--app-forensics/sleuthkit/files/digest-sleuthkit-2.086
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch105
-rw-r--r--app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch92
-rw-r--r--app-forensics/sleuthkit/sleuthkit-2.08.ebuild48
5 files changed, 260 insertions, 1 deletions
diff --git a/app-forensics/sleuthkit/ChangeLog b/app-forensics/sleuthkit/ChangeLog
index 9ca2a36997a4..7e75fbad87ba 100644
--- a/app-forensics/sleuthkit/ChangeLog
+++ b/app-forensics/sleuthkit/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-forensics/sleuthkit
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.25 2007/02/21 21:55:01 peper Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/ChangeLog,v 1.26 2007/04/11 22:20:06 falco Exp $
+
+*sleuthkit-2.08 (11 Apr 2007)
+
+ 11 Apr 2007; Raphael Marichez <falco@gentoo.org>
+ +files/sleuthkit-fscheck.c_fix.patch,
+ +files/sleuthkit-makefiles_fix.patch, +sleuthkit-2.08.ebuild:
+ Version bump, with thanks to Jerome Poggi <jerome.poggi@hsc.fr> for his
+ notification.
21 Feb 2007; Piotr Jaroszyński <peper@gentoo.org> ChangeLog:
Transition to Manifest2.
diff --git a/app-forensics/sleuthkit/files/digest-sleuthkit-2.08 b/app-forensics/sleuthkit/files/digest-sleuthkit-2.08
new file mode 100644
index 000000000000..1ed7bd0484d2
--- /dev/null
+++ b/app-forensics/sleuthkit/files/digest-sleuthkit-2.08
@@ -0,0 +1,6 @@
+MD5 35cfea5a26a52a9ad871ee5551cb1526 sleuthkit-2.08.tar.gz 1723828
+RMD160 6a8847bc8835c6d435276147591b806f5a706b8c sleuthkit-2.08.tar.gz 1723828
+SHA256 18d9ded8236fe8bd29d06fab0f0d7b5e9e73f680b1c1024311deaac5ed9ffb24 sleuthkit-2.08.tar.gz 1723828
+MD5 6476d326f6d458fd3993e35e42c56a42 sleuthkit-2.08_dbtool.patch.bz2 9049
+RMD160 e88c225929a2286d223e44d4ecf26abf2d6456ff sleuthkit-2.08_dbtool.patch.bz2 9049
+SHA256 7cdf4611634c318731b686059e2114f5b418d45ed5eefdcea90847ce0386d6e3 sleuthkit-2.08_dbtool.patch.bz2 9049
diff --git a/app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch b/app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch
new file mode 100644
index 000000000000..d0d65b594584
--- /dev/null
+++ b/app-forensics/sleuthkit/files/sleuthkit-fscheck.c_fix.patch
@@ -0,0 +1,105 @@
+diff -uNr -r sleuthkit-2.08-orig/src/fstools/fscheck.c sleuthkit-2.08/src/fstools/fscheck.c
+--- sleuthkit-2.08-orig/src/fstools/fscheck.c 2007-03-13 21:05:37.000000000 +0100
++++ sleuthkit-2.08/src/fstools/fscheck.c 2007-04-11 18:03:00.000000000 +0200
+@@ -11,8 +11,10 @@
+ ** This software is distributed under the Common Public License 1.0
+ **
+ */
++#include <locale.h>
+ #include "fs_tools.h"
+
++static TSK_TCHAR *progname;
+
+ static void
+ usage()
+@@ -36,58 +38,71 @@
+ int
+ main(int argc, char **argv)
+ {
+- char *fstype = NULL;
++ TSK_TCHAR *fstype = NULL;
+ int ch;
+- FS_INFO *fs;
+- char *imgtype = NULL, *imgoff = NULL;
+- IMG_INFO *img;
++ TSK_FS_INFO *fs;
++ TSK_TCHAR *imgtype = NULL;
++ SSIZE_T imgoff = 0;
++ TSK_IMG_INFO *img;
+
+ progname = argv[0];
++ setlocale(LC_ALL, "");
+
+- while ((ch = getopt(argc, argv, "f:i:o:vV")) > 0) {
++ while ((ch = getopt(argc, argv, _TSK_T("f:i:o:vV"))) > 0) {
+ switch (ch) {
+- case '?':
++ case _TSK_T('?'):
+ default:
+- fprintf(stderr, "Invalid argument: %s\n", argv[optind]);
++ fprintf(stderr, _TSK_T("Invalid argument: %s\n"), argv[optind]);
+ usage();
+
+- case 'f':
++ case _TSK_T('f'):
+ fstype = optarg;
++ if (TSTRCMP(fstype, _TSK_T("list")) == 0) {
++ tsk_fs_print_types(stderr);
++ exit(1);
++ }
+ break;
+
+- case 'i':
++ case _TSK_T('i'):
+ imgtype = optarg;
++ if (TSTRCMP(imgtype, _TSK_T("list")) == 0) {
++ tsk_img_print_types(stderr);
++ exit(1);
++ }
+ break;
+
+- case 'o':
+- imgoff = optarg;
++ case _TSK_T('o'):
++ if ((imgoff = tsk_parse_offset(optarg)) == -1) {
++ tsk_error_print(stderr);
++ exit(1);
++ }
+ break;
+
+- case 'v':
+- verbose++;
++ case _TSK_T('v'):
++ tsk_verbose++;
+ break;
+
+- case 'V':
+- print_version(stdout);
++ case _TSK_T('V'):
++ tsk_print_version(stdout);
+ exit(0);
+ }
+ }
+
+ /* We need at least one more argument */
+ if (optind >= argc) {
+- fprintf(stderr, "Missing image name\n");
++ tsk_fprintf(stderr, "Missing image name\n");
+ usage();
+ }
+
+ img =
+- img_open(imgtype, imgoff, argc - optind,
+- (const char **) &argv[optind]);
++ tsk_img_open(imgtype, argc - optind,
++ (const TSK_TCHAR **) &argv[optind]);
+ if (img == NULL) {
+ tsk_error_print(stderr);
+ exit(1);
+ }
+
+- if (fs = fs_open(img, fstype)) {
++ if (fs = tsk_fs_open(img, imgoff, fstype)) {
+ if (tsk_errno == TSK_ERR_FS_UNSUPTYPE)
+ tsk_print_types(stderr);
+
diff --git a/app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch b/app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch
new file mode 100644
index 000000000000..5aa8a834133c
--- /dev/null
+++ b/app-forensics/sleuthkit/files/sleuthkit-makefiles_fix.patch
@@ -0,0 +1,92 @@
+diff -uNr -r sleuthkit-2.08-orig/src/disktools/Makefile sleuthkit-2.08/src/disktools/Makefile
+--- sleuthkit-2.08-orig/src/disktools/Makefile 2006-07-20 23:06:18.000000000 +0200
++++ sleuthkit-2.08/src/disktools/Makefile 2007-04-11 17:07:09.982355393 +0200
+@@ -6,12 +6,19 @@
+ BIN = ../../bin
+ PROGS = $(BIN)/disk_stat $(BIN)/disk_sreset
+ CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. -I ../auxtools/ $(XFLAGS)
++
++LIBOBJ = disk_stat.o disk_sreset.o ide.o
+ LIBS = -L../../lib -ltsk
++LIB = ../../lib/libtsk.a
+
+ defs:
+ @CC="$(CC)" sh ../makedefs $(MAKE)
+
+-all: $(PROGS)
++all: lib $(PROGS)
++
++lib: $(LIBOBJ)
++ $(AR) $(LIB) $?
++ $(RANLIB) $(LIB)
+
+ $(BIN)/disk_stat: disk_stat.o ide.o
+ $(CC) $(CFLAGS) -o $@ disk_stat.o ide.o $(LIBS)
+diff -uNr -r sleuthkit-2.08-orig/src/fstools/Makefile sleuthkit-2.08/src/fstools/Makefile
+--- sleuthkit-2.08-orig/src/fstools/Makefile 2007-02-22 06:47:12.000000000 +0100
++++ sleuthkit-2.08/src/fstools/Makefile 2007-04-11 17:16:39.145986814 +0200
+@@ -9,12 +9,12 @@
+ INCL = -I../auxtools -I../imgtools
+ CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
+ LIBOBJ = fs_inode.o fs_io.o fs_open.o \
+- fs_dent.o fs_types.o fs_data.o fs_load.o \
++ fs_dent.o fs_types.o fs_data.o fs_load.o fsstat.o fscheck.o \
+ ffs.o ffs_dent.o ext2fs.o ext2fs_dent.o ext2fs_journal.o \
+ fatfs.o fatfs_dent.o ntfs.o ntfs_dent.o swapfs.o rawfs.o \
+- dcalc_lib.o dcat_lib.o dls_lib.o dstat_lib.o ffind_lib.o \
+- fls_lib.o icat_lib.o ifind_lib.o ils_lib.o \
+- iso9660.o iso9660_dent.o \
++ dcalc.o dcalc_lib.o dcat.o dcat_lib.o dls.o dls_lib.o dstat.o dstat_lib.o ffind_lib.o \
++ fls.o fls_lib.o icat.o icat_lib.o ifind.o ifind_lib.o ils.o ils_lib.o istat.o \
++ iso9660.o iso9660_dent.o jls.o jcat.o \
+ hfs.o hfs_dent.o hfs_journal.o
+ LIBS = -L../../lib -ltsk -lz -lcrypto
+
+diff -uNr -r sleuthkit-2.08-orig/src/hashtools/Makefile sleuthkit-2.08/src/hashtools/Makefile
+--- sleuthkit-2.08-orig/src/hashtools/Makefile 2007-03-27 20:49:46.000000000 +0200
++++ sleuthkit-2.08/src/hashtools/Makefile 2007-04-11 17:10:10.286508943 +0200
+@@ -7,7 +7,7 @@
+ PROGS = $(BIN)/hfind
+ CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. -I../auxtools $(XFLAGS)
+
+-LIBOBJ = tm_lookup.o nsrl_index.o md5sum_index.o hk_index.o idxonly_index.o
++LIBOBJ = tm_lookup.o nsrl_index.o md5sum_index.o hk_index.o idxonly_index.o hfind.o
+ LIB = ../../lib/libtsk.a
+
+ defs:
+diff -uNr -r sleuthkit-2.08-orig/src/imgtools/Makefile sleuthkit-2.08/src/imgtools/Makefile
+--- sleuthkit-2.08-orig/src/imgtools/Makefile 2006-08-23 16:17:53.000000000 +0200
++++ sleuthkit-2.08/src/imgtools/Makefile 2007-04-11 17:09:22.977220557 +0200
+@@ -7,7 +7,7 @@
+ DEBUG = -g
+ INCL = -I../auxtools -I../afflib/lib -I../libewf/src/
+ CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
+-LIBOBJ = img_open.o img_types.o raw.o split.o aff.o ewf.o
++LIBOBJ = img_open.o img_types.o raw.o split.o aff.o ewf.o img_stat.o img_cat.o
+ LIBS = -L../../lib -ltsk -lz -lcrypto
+ LIB = ../../lib/libtsk.a
+ BIN_DIR = ../../bin
+diff -uNr -r sleuthkit-2.08-orig/src/mmtools/Makefile sleuthkit-2.08/src/mmtools/Makefile
+--- sleuthkit-2.08-orig/src/mmtools/Makefile 2007-04-04 20:48:46.000000000 +0200
++++ sleuthkit-2.08/src/mmtools/Makefile 2007-04-11 17:08:56.842299225 +0200
+@@ -7,7 +7,7 @@
+ DEBUG = -g
+ INCL = -I../auxtools -I../imgtools
+ CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG)
+-LIBOBJ = mm_part.o mm_open.o mm_io.o mm_types.o dos.o mac.o bsd.o sun.o gpt.o
++LIBOBJ = mm_part.o mm_open.o mm_io.o mm_types.o dos.o mac.o bsd.o sun.o gpt.o mmls.o mmstat.o
+ LIBS = -L../../lib -ltsk -lz -lcrypto
+ LIB = ../../lib/libtsk.a
+ BIN_DIR = ../../bin
+diff -uNr -r sleuthkit-2.08-orig/src/srchtools/Makefile sleuthkit-2.08/src/srchtools/Makefile
+--- sleuthkit-2.08-orig/src/srchtools/Makefile 2006-07-20 23:06:18.000000000 +0200
++++ sleuthkit-2.08/src/srchtools/Makefile 2007-04-11 17:07:09.986355838 +0200
+@@ -7,7 +7,7 @@
+ PROGS = $(BIN)/srch_strings $(BIN)/sigfind
+ CFLAGS = $(DEFS) $(INCL) $(OPT) $(DEBUG) -I. -I ../auxtools $(XFLAGS)
+
+-LIBOBJ = srch_strings.o
++LIBOBJ = srch_strings.o sigfind.o
+ LIBS = -L../../lib -ltsk
+ LIB = ../../lib/libtsk.a
+
diff --git a/app-forensics/sleuthkit/sleuthkit-2.08.ebuild b/app-forensics/sleuthkit/sleuthkit-2.08.ebuild
new file mode 100644
index 000000000000..d972671582df
--- /dev/null
+++ b/app-forensics/sleuthkit/sleuthkit-2.08.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-forensics/sleuthkit/sleuthkit-2.08.ebuild,v 1.1 2007/04/11 22:20:06 falco Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="A collection of file system and media management forensic analysis tools"
+HOMEPAGE="http://www.sleuthkit.org/sleuthkit/"
+SRC_URI="mirror://sourceforge/sleuthkit/${P}.tar.gz
+ dbtool? ( mirror://gentoo/${P}_dbtool.patch.bz2 ) "
+
+LICENSE="GPL-2 IBM"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~s390 ~sparc ~x86"
+IUSE="dbtool"
+
+RDEPEND="dev-perl/DateManip
+ !sys-apps/dstat"
+
+src_unpack() {
+ unpack ${A}
+ use dbtool && epatch "${P}_dbtool.patch"
+ epatch "${FILESDIR}/${PN}-makefiles_fix.patch"
+ epatch "${FILESDIR}/${PN}-fscheck.c_fix.patch"
+ cd ${S}
+ sed -i '63,69d' src/timeline/config-perl || die "sed config-perl failed"
+ sed -i 's:`cd ../..; pwd`:/usr:' src/sorter/install \
+ || die "sed install failed"
+}
+
+src_compile() {
+ export CC="$(tc-getCC)" OPT="${CFLAGS}"
+ # Targets: this is so it doesn't remake sys-apps/file
+ # -j1: it really doesn't compile well with -j2 or more,
+ # even after having fixed the Makefiles... :(
+ env -u CFLAGS \
+ emake -j1 -e bin no-perl sorter mactime || die "make failed"
+}
+
+src_install() {
+ dobin bin/* || die "dobin failed"
+ dodoc docs/*
+ docinto api-doc
+ dohtml docs/api-doc/*
+ insinto /usr/share/sorter
+ doins share/sorter/*
+ doman man/man1/*
+}