summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-08-17 18:25:03 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-08-17 18:25:03 +0000
commitd0202491b314344f1b73a9324a320b277f69b222 (patch)
tree232760f58bcf43f6b24fe2dcb69aae4018ca4350 /app-emulation
parentFix wrong service dependency (Bug 431704). Thanks Andrea (diff)
downloadgentoo-2-d0202491b314344f1b73a9324a320b277f69b222.tar.gz
gentoo-2-d0202491b314344f1b73a9324a320b277f69b222.tar.bz2
gentoo-2-d0202491b314344f1b73a9324a320b277f69b222.zip
install init script only if virtualbox{-bin} is present. Reword elog message. Bug #420991
(Portage version: 2.1.11.10/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/phpvirtualbox/ChangeLog8
-rw-r--r--app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild13
2 files changed, 15 insertions, 6 deletions
diff --git a/app-emulation/phpvirtualbox/ChangeLog b/app-emulation/phpvirtualbox/ChangeLog
index 2667ef3886e6..779a0c0a9f49 100644
--- a/app-emulation/phpvirtualbox/ChangeLog
+++ b/app-emulation/phpvirtualbox/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/phpvirtualbox
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.3 2012/06/18 17:28:40 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/ChangeLog,v 1.4 2012/08/17 18:25:03 hwoarang Exp $
+
+ 17 Aug 2012; Markos Chandras <hwoarang@gentoo.org>
+ phpvirtualbox-4.1.7-r2.ebuild:
+ install init script only if virtualbox{-bin} is present. Reword elog message.
+ Bug #420991
*phpvirtualbox-4.1.7-r2 (18 Jun 2012)
@@ -22,4 +27,3 @@
+phpvirtualbox-4.1.7.ebuild:
Moved from my overlay. Bug #338804. Thanks to Florian Knodt
<f.knodt@yotaweb.de> for the original ebuild
-
diff --git a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild
index ad9e30413207..ec6326862021 100644
--- a/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild
+++ b/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild,v 1.1 2012/06/18 17:28:40 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/phpvirtualbox/phpvirtualbox-4.1.7-r2.ebuild,v 1.2 2012/08/17 18:25:03 hwoarang Exp $
EAPI="2"
@@ -39,8 +39,11 @@ src_install() {
webapp_serverowned "${MY_HTDOCSDIR}"/config.php-example
webapp_src_install
-
- newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ if has_version app-emulation/virtualbox[vboxwebsrv] || \
+ has_version app-emulation/virtualbox-bin[vboxwebsrv]
+ then
+ newinitd "${FILESDIR}"/vboxinit-initd vboxinit
+ fi
}
pkg_postinst() {
@@ -58,5 +61,7 @@ pkg_postinst() {
elog "default runlevel on the virtualbox host:"
elog "\`rc-update add vboxinit default\`"
elog "If the server is on a remote host, than the script must be"
- elog "copied manually."
+ elog "copied manually from"
+ elog "${FILESDIR}/vboxinit to /etc/init.d/vboxinit"
+ elog "on the remote host."
}