summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2008-09-07 07:54:51 +0000
committerMichael Januszewski <spock@gentoo.org>2008-09-07 07:54:51 +0000
commitac10cf73252b1504c8780c0c5c99e08b54062e20 (patch)
tree80592e1bb528505bf5e229b7b27e5cd8ef31227a /app-emulation
parentInitial commit. (diff)
downloadgentoo-2-ac10cf73252b1504c8780c0c5c99e08b54062e20.tar.gz
gentoo-2-ac10cf73252b1504c8780c0c5c99e08b54062e20.tar.bz2
gentoo-2-ac10cf73252b1504c8780c0c5c99e08b54062e20.zip
Version bump.
(Portage version: 2.2_rc8/cvs/Linux 2.6.27-rc5 x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/uade/ChangeLog7
-rw-r--r--app-emulation/uade/uade-2.12.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-emulation/uade/ChangeLog b/app-emulation/uade/ChangeLog
index 488e185677ca..f42db1af570c 100644
--- a/app-emulation/uade/ChangeLog
+++ b/app-emulation/uade/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/uade
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.49 2008/07/28 19:40:36 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/ChangeLog,v 1.50 2008/09/07 07:54:51 spock Exp $
+
+*uade-2.12 (07 Sep 2008)
+
+ 07 Sep 2008; Michał Januszewski <spock@gentoo.org> +uade-2.12.ebuild:
+ Version bump.
28 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-emulation/uade/uade-2.12.ebuild b/app-emulation/uade/uade-2.12.ebuild
new file mode 100644
index 000000000000..79c34ec5f4f4
--- /dev/null
+++ b/app-emulation/uade/uade-2.12.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/uade/uade-2.12.ebuild,v 1.1 2008/09/07 07:54:51 spock Exp $
+
+inherit eutils
+
+DESCRIPTION="Unix Amiga Delitracker Emulator - plays old Amiga tunes through UAE emulation"
+HOMEPAGE="http://zakalwe.fi/uade"
+SRC_URI="http://zakalwe.fi/uade/uade2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="audacious"
+
+RDEPEND="media-libs/libao
+ audacious? ( >=media-sound/audacious-0.2 )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --package-prefix="${D}" \
+ $(use_with audacious) \
+ --with-uade123 \
+ --with-text-scope \
+ --without-xmms \
+ || die "configure failed"
+ emake || die 'emake failed'
+}
+
+src_install() {
+ make install || die 'make install failed'
+ dodoc AUTHORS ChangeLog doc/BUGS doc/PLANS
+ doman doc/uade123.1
+}