summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2012-01-21 12:57:30 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2012-01-21 12:57:30 +0000
commita3ebdc0d038491ffba4e450ebd8be7bfd268deff (patch)
tree06814e19330840f7f14fa70374bbdba5b218aadc /app-emulation
parentAdded more upstream targets to QEMU_USER_TARGETS and QEMU_SOFTMMU_TARGETS. (diff)
downloadgentoo-2-a3ebdc0d038491ffba4e450ebd8be7bfd268deff.tar.gz
gentoo-2-a3ebdc0d038491ffba4e450ebd8be7bfd268deff.tar.bz2
gentoo-2-a3ebdc0d038491ffba4e450ebd8be7bfd268deff.zip
Fixed configure failure (follow upstream in renaming --enablble-user-pic to --enable-pic).
Added all missing linux targets except lm32 (needs proper deps and a fix against --as-needed). Made ./configure params to be shown. (Portage version: 2.2.0_alpha84_p18/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/qemu/ChangeLog9
-rw-r--r--app-emulation/qemu/qemu-9999.ebuild20
2 files changed, 18 insertions, 11 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 5bd39a7ed352..f7cd2af72023 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/qemu
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.87 2011/09/20 22:34:01 mgorny Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.88 2012/01/21 12:57:30 slyfox Exp $
+
+ 21 Jan 2012; Sergei Trofimovich <slyfox@gentoo.org> qemu-9999.ebuild:
+ Fixed configure failure (follow upstream in renaming --enablble-user-pic to
+ --enable-pic). Added all missing linux targets except lm32 (needs proper deps
+ and a fix against --as-needed). Made ./configure params to be shown.
20 Sep 2011; Michał Górny <mgorny@gentoo.org> qemu-9999.ebuild:
Migrate to git-2.
diff --git a/app-emulation/qemu/qemu-9999.ebuild b/app-emulation/qemu/qemu-9999.ebuild
index 40743bc5c08d..40c1df3a9f54 100644
--- a/app-emulation/qemu/qemu-9999.ebuild
+++ b/app-emulation/qemu/qemu-9999.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.2 2011/09/20 22:34:01 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-9999.ebuild,v 1.3 2012/01/21 12:57:30 slyfox Exp $
EAPI="2"
@@ -29,9 +29,9 @@ SLOT="0"
IUSE="+aio alsa bluetooth brltty curl esd fdt hardened jpeg ncurses \
png pulseaudio qemu-ifup sasl sdl ssl static vde"
-COMMON_TARGETS="i386 x86_64 arm cris m68k microblaze mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64"
-IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} mips64 mips64el ppcemb"
-IUSE_USER_TARGETS="${COMMON_TARGETS} alpha armeb ppc64abi32 sparc32plus"
+COMMON_TARGETS="i386 x86_64 alpha arm cris m68k microblaze microblazeel mips mipsel ppc ppc64 sh4 sh4eb sparc sparc64 s390x"
+IUSE_SOFTMMU_TARGETS="${COMMON_TARGETS} mips64 mips64el ppcemb xtensa xtensaeb" # dropped lm32
+IUSE_USER_TARGETS="${COMMON_TARGETS} armeb ppc64abi32 sparc32plus unicore32"
for target in ${IUSE_SOFTMMU_TARGETS}; do
IUSE="${IUSE} +qemu_softmmu_targets_${target}"
@@ -130,7 +130,7 @@ src_configure() {
conf_opts="${conf_opts} $(use_enable brltty brlapi)"
conf_opts="${conf_opts} $(use_enable curl)"
conf_opts="${conf_opts} $(use_enable fdt)"
- conf_opts="${conf_opts} $(use_enable hardened user-pie)"
+ conf_opts="${conf_opts} $(use_enable hardened pie)"
conf_opts="${conf_opts} $(use_enable jpeg vnc-jpeg)"
conf_opts="${conf_opts} $(use_enable ncurses curses)"
conf_opts="${conf_opts} $(use_enable png vnc-png)"
@@ -147,7 +147,8 @@ src_configure() {
use esd && audio_opts="esd ${audio_opts}"
use pulseaudio && audio_opts="pa ${audio_opts}"
use sdl && audio_opts="sdl ${audio_opts}"
- ./configure --prefix=/usr \
+
+ set -- --prefix=/usr \
--disable-strip \
--disable-werror \
--disable-kvm \
@@ -157,9 +158,10 @@ src_configure() {
--audio-drv-list="${audio_opts}" \
--target-list="${softmmu_targets} ${user_targets}" \
--cc="$(tc-getCC)" \
- --host-cc="$(tc-getBUILD_CC)" \
- || die "configure failed"
+ --host-cc="$(tc-getBUILD_CC)"
+ echo ./configure "$@" # show actual options
+ ./configure "$@" || die "configure failed"
# this is for qemu upstream's threaded support which is
# in development and broken
# the kvm project has its own support for threaded IO