summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-05-11 16:46:25 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-05-11 16:46:25 +0000
commit6d5a74b87a54a45fe11fefe86ac346427264283f (patch)
treec388d0d720bb0e15d9a5d410d736a691d63d71f8 /app-emulation
parentDrop musicbrainz dependency once and for all. As per upstream bug #63 by Rafa... (diff)
downloadgentoo-2-6d5a74b87a54a45fe11fefe86ac346427264283f.tar.gz
gentoo-2-6d5a74b87a54a45fe11fefe86ac346427264283f.tar.bz2
gentoo-2-6d5a74b87a54a45fe11fefe86ac346427264283f.zip
Fix compile with GCC 4.4 wrt #269311, thanks to Martin Väth.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/vice/ChangeLog6
-rw-r--r--app-emulation/vice/files/vice-2.1-gcc44.patch11
-rw-r--r--app-emulation/vice/vice-2.1.ebuild6
3 files changed, 21 insertions, 2 deletions
diff --git a/app-emulation/vice/ChangeLog b/app-emulation/vice/ChangeLog
index b7976c6ffe8d..600690c10d7b 100644
--- a/app-emulation/vice/ChangeLog
+++ b/app-emulation/vice/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/vice
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.61 2009/01/25 03:59:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/ChangeLog,v 1.62 2009/05/11 16:46:24 ssuominen Exp $
+
+ 11 May 2009; Samuli Suominen <ssuominen@gentoo.org> vice-2.1.ebuild,
+ +files/vice-2.1-gcc44.patch:
+ Fix compile with GCC 4.4 wrt #269311, thanks to Martin Väth.
*vice-2.1 (25 Jan 2009)
diff --git a/app-emulation/vice/files/vice-2.1-gcc44.patch b/app-emulation/vice/files/vice-2.1-gcc44.patch
new file mode 100644
index 000000000000..505d73694385
--- /dev/null
+++ b/app-emulation/vice/files/vice-2.1-gcc44.patch
@@ -0,0 +1,11 @@
+--- src/arch/unix/joy.c
++++ src/arch/unix/joy.c
+@@ -124,7 +124,7 @@
+ #define JS_DATA_TYPE joystick
+ #define JS_RETURN sizeof(struct joystick)
+ int use_old_api=1;
+-#elif
++#else
+ #error Unknown Joystick
+ #endif
+
diff --git a/app-emulation/vice/vice-2.1.ebuild b/app-emulation/vice/vice-2.1.ebuild
index 93b2cb625aea..922fcf54f4c2 100644
--- a/app-emulation/vice/vice-2.1.ebuild
+++ b/app-emulation/vice/vice-2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.1.ebuild,v 1.1 2009/01/25 03:59:02 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/vice/vice-2.1.ebuild,v 1.2 2009/05/11 16:46:24 ssuominen Exp $
EAPI=2
inherit eutils games
@@ -53,6 +53,10 @@ DEPEND="${RDEPEND}
xv? ( x11-proto/videoproto )
nls? ( sys-devel/gettext )"
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+}
+
src_configure() {
egamesconf \
--disable-dependency-tracking \