summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLance Albertson <ramereth@gentoo.org>2011-02-10 20:54:09 +0000
committerLance Albertson <ramereth@gentoo.org>2011-02-10 20:54:09 +0000
commit13ec07b17293c518e1b4ec544e4af6debd4d742d (patch)
treec5494484ad7e60ddc0feea211f1794bfff3ebe0b /app-emulation
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-13ec07b17293c518e1b4ec544e4af6debd4d742d.tar.gz
gentoo-2-13ec07b17293c518e1b4ec544e4af6debd4d742d.tar.bz2
gentoo-2-13ec07b17293c518e1b4ec544e4af6debd4d742d.zip
Version bump, add blocker to older ganeti versions
(Portage version: 2.1.9.25/cvs/Linux x86_64)
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/ganeti-htools/ChangeLog10
-rw-r--r--app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild46
2 files changed, 54 insertions, 2 deletions
diff --git a/app-emulation/ganeti-htools/ChangeLog b/app-emulation/ganeti-htools/ChangeLog
index ffbc850a2be1..d9f6a57e5039 100644
--- a/app-emulation/ganeti-htools/ChangeLog
+++ b/app-emulation/ganeti-htools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/ganeti-htools
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.5 2010/12/23 16:52:40 ramereth Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ChangeLog,v 1.6 2011/02/10 20:54:09 ramereth Exp $
+
+*ganeti-htools-0.3.0 (10 Feb 2011)
+
+ 10 Feb 2011; Lance Albertson <ramereth@gentoo.org>
+ +ganeti-htools-0.3.0.ebuild:
+ Version bump, add blocker to older ganeti versions
*ganeti-htools-0.2.8 (23 Dec 2010)
diff --git a/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild b/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild
new file mode 100644
index 000000000000..1842b0430b77
--- /dev/null
+++ b/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/ganeti-htools/ganeti-htools-0.3.0.ebuild,v 1.1 2011/02/10 20:54:09 ramereth Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Cluster tools for fixing common allocation problems on Ganeti 2.0
+clusters."
+HOMEPAGE="http://code.google.com/p/ganeti/"
+SRC_URI="http://ganeti.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+DEPEND="dev-lang/ghc
+ dev-haskell/json
+ dev-haskell/curl
+ dev-haskell/network
+ dev-haskell/parallel"
+RDEPEND="${DEPEND}
+ !<app-emulation/ganeti-2.4"
+
+src_prepare() {
+ # htools does not currently compile cleanly with ghc-6.12+, so remove this
+ # for now
+ sed -i -e "s:-Werror ::" Makefile
+ # Workaround to skip pandoc
+ sed -i -e "s:) man:):" Makefile
+}
+
+src_compile() {
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ dosbin hspace hscan hbal
+ exeinto /usr/$(get_libdir)/ganeti/iallocators
+ doexe hail
+ doman man/*.1
+ dodoc README NEWS AUTHORS
+ use doc && dohtml -r apidoc/*
+}