summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-03-07 17:47:19 +0000
committerIan Delaney <idella4@gentoo.org>2013-03-07 17:47:19 +0000
commit489f9c77408c6c7e02f01002e917894ef14b3503 (patch)
tree97edebf6eaf2f549a246cf58ed61b0365255ab9a /app-emulation/xen
parentadd static-libs useflag wrt #460706 (diff)
downloadgentoo-2-489f9c77408c6c7e02f01002e917894ef14b3503.tar.gz
gentoo-2-489f9c77408c6c7e02f01002e917894ef14b3503.tar.bz2
gentoo-2-489f9c77408c6c7e02f01002e917894ef14b3503.zip
Deps corrected in 4.2.1-r2, patch addressing efi upgraded for newly made efi build, fixes Bug #458926 by Carlos Silva, patched prepared, tested by Paul Freeman
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'app-emulation/xen')
-rw-r--r--app-emulation/xen/ChangeLog8
-rw-r--r--app-emulation/xen/files/xen-4.2-efi.patch22
-rw-r--r--app-emulation/xen/xen-4.2.1-r2.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/app-emulation/xen/ChangeLog b/app-emulation/xen/ChangeLog
index fdd1033d4765..df7fe0540c81 100644
--- a/app-emulation/xen/ChangeLog
+++ b/app-emulation/xen/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/xen
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.112 2013/02/27 08:03:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/ChangeLog,v 1.113 2013/03/07 17:47:19 idella4 Exp $
+
+ 07 Mar 2013; Ian Delaney <idella4@gentoo.org> files/xen-4.2-efi.patch,
+ xen-4.2.1-r2.ebuild:
+ Deps corrected in 4.2.1-r2, patch addressing efi upgraded for newly made efi
+ build, fixes Bug #458926 by Carlos Silva, patched prepared, tested by Paul
+ Freeman
27 Feb 2013; Ian Delaney <idella4@gentoo.org> xen-4.2.0-r2.ebuild,
xen-4.2.1-r2.ebuild:
diff --git a/app-emulation/xen/files/xen-4.2-efi.patch b/app-emulation/xen/files/xen-4.2-efi.patch
index 2d0b7d7d143a..6e38aaa985df 100644
--- a/app-emulation/xen/files/xen-4.2-efi.patch
+++ b/app-emulation/xen/files/xen-4.2-efi.patch
@@ -10,4 +10,24 @@ diff -ur xen-4.2.0.orig/xen/arch/x86/Makefile xen-4.2.0/xen/arch/x86/Makefile
EFI_LDFLAGS += --image-base=$(1) --stack=0,0 --heap=0,0 --strip-debug
EFI_LDFLAGS += --section-alignment=0x200000 --file-alignment=0x20
EFI_LDFLAGS += --major-image-version=$(XEN_VERSION)
-
+--- xen/Makefile 2013-03-07 14:34:01.819453278 +0000
++++ xen/Makefile 2013-03-07 15:56:44.753044655 +0000
+@@ -31,9 +31,15 @@
+ _install: $(TARGET).gz
+ [ -d $(DESTDIR)/boot ] || $(INSTALL_DIR) $(DESTDIR)/boot
+ $(INSTALL_DATA) $(TARGET).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_FULLVERSION).gz
+- ln -f -s $(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_VERSION).$(XEN_SUBVERSION).gz
+- ln -f -s $(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_VERSION).gz
+- ln -f -s $(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET)).gz
++ if [ 'x$(EFI_VENDOR)' == 'x' ]; then \
++ ln -f -s $(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_VERSION).$(XEN_SUBVERSION).gz; \
++ ln -f -s $(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_VERSION).gz; \
++ ln -f -s $(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET)).gz; \
++ else \
++ cp $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_VERSION).$(XEN_SUBVERSION).gz; \
++ cp $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_VERSION).gz; \
++ cp $(DESTDIR)/boot/$(notdir $(TARGET))-$(XEN_FULLVERSION).gz $(DESTDIR)/boot/$(notdir $(TARGET)).gz; \
++ fi; \
+ $(INSTALL_DATA) $(TARGET)-syms $(DESTDIR)/boot/$(notdir $(TARGET))-syms-$(XEN_FULLVERSION)
+ if [ -r $(TARGET).efi -a -n '$(EFI_DIR)' ]; then \
+ [ -d $(DESTDIR)$(EFI_DIR) ] || $(INSTALL_DIR) $(DESTDIR)$(EFI_DIR); \
diff --git a/app-emulation/xen/xen-4.2.1-r2.ebuild b/app-emulation/xen/xen-4.2.1-r2.ebuild
index 545f9a68724d..597f44be8266 100644
--- a/app-emulation/xen/xen-4.2.1-r2.ebuild
+++ b/app-emulation/xen/xen-4.2.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.2.1-r2.ebuild,v 1.2 2013/02/27 08:03:21 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/xen/xen-4.2.1-r2.ebuild,v 1.3 2013/03/07 17:47:19 idella4 Exp $
EAPI=5
@@ -26,7 +26,8 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="custom-cflags debug efi flask pae xsm"
-RDEPEND="efi? ( >=sys-devel/binutils-2.22[multitarget] )"
+DEPEND="efi? ( >=sys-devel/binutils-2.22[multitarget] )"
+RDEPEND=""
PDEPEND="~app-emulation/xen-tools-${PV}"
RESTRICT="test"
@@ -114,7 +115,7 @@ src_install() {
use debug && myopt="${myopt} debug=y"
use pae && myopt="${myopt} pae=y"
- #The 'make install' doesn't 'mkdir -p' the subdirs
+ # The 'make install' doesn't 'mkdir -p' the subdirs
if use efi; then
mkdir -p "${D}"${EFI_MOUNTPOINT}/efi/${EFI_VENDOR} || die
fi