summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-09-22 17:56:44 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-09-22 17:56:44 +0000
commit58141199638f5c8666d2b7b36a4303f7665ed8b3 (patch)
treeb235864b3a514207cf74f3d4a7e13ac8d4ff445a /app-emulation/x48
parentvmnet patch for 2.6.31 kernel. Bug 274173, comment 15. (diff)
downloadgentoo-2-58141199638f5c8666d2b7b36a4303f7665ed8b3.tar.gz
gentoo-2-58141199638f5c8666d2b7b36a4303f7665ed8b3.tar.bz2
gentoo-2-58141199638f5c8666d2b7b36a4303f7665ed8b3.zip
Version bump to 0.6.1 , ebuild thanks to po.valles <nibheis@gmail.com> bug 285926
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-emulation/x48')
-rw-r--r--app-emulation/x48/ChangeLog10
-rw-r--r--app-emulation/x48/x48-0.6.1.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/app-emulation/x48/ChangeLog b/app-emulation/x48/ChangeLog
index 4674bd4ee261..29ae5ebae206 100644
--- a/app-emulation/x48/ChangeLog
+++ b/app-emulation/x48/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-emulation/x48
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.16 2008/10/13 18:51:39 bangert Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.17 2009/09/22 17:56:44 vostorga Exp $
+
+*x48-0.6.1 (22 Sep 2009)
+
+ 22 Sep 2009; Víctor Ostorga <vostorga@gentoo.org> +x48-0.6.1.ebuild:
+ Version bump to 0.6.1 , ebuild thanks to po.valles <nibheis@gmail.com>
+ bug 285926
13 Oct 2008; Thilo Bangert <bangert@gentoo.org> x48-0.4.3.ebuild,
x48-0.4.3-r1.ebuild:
diff --git a/app-emulation/x48/x48-0.6.1.ebuild b/app-emulation/x48/x48-0.6.1.ebuild
new file mode 100644
index 000000000000..26a3ad2ebe62
--- /dev/null
+++ b/app-emulation/x48/x48-0.6.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.6.1.ebuild,v 1.1 2009/09/22 17:56:44 vostorga Exp $
+
+inherit eutils
+
+DESCRIPTION="HP48 Calculator Emulator"
+HOMEPAGE="http://x48.berlios.de/"
+SRC_URI="mirror://berlios/x48/${P}.tar.gz
+ http://www.hpcalc.org/hp48/pc/emulators/sxrom-j.zip
+ http://www.hpcalc.org/hp48/pc/emulators/gxrom-r.zip"
+LICENSE="|| ( ( GPL-2 free-noncomm ) GPL-2 )"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xextproto
+ app-text/rman
+ sys-libs/readline
+ sys-libs/ncurses
+ app-arch/unzip
+ sys-libs/gpm"
+
+src_compile() {
+ econf
+ emake CCOPTIONS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin src/checkrom src/dump2rom src/mkcard src/x48 || die "dobin failed"
+
+ newman src/x48.man x48.1 || die "newman failed"
+
+ dodir /usr/lib/X11/app-defaults || die "dodir failed"
+ insinto /usr/lib/X11/app-defaults/
+
+ dodir /usr/share/hp48 || die "dodir failed"
+ insinto /usr/share/hp48
+ doins "${WORKDIR}"/gxrom-r "${WORKDIR}"/sxrom-j || die "doins failed"
+
+}
+
+pkg_postinst() {
+ elog "The X48 emulator requires an HP48 ROM Image to run."
+ elog
+ elog "If you own an HP-48 calculator, you can use the ROMDump utility"
+ elog "included with this package to obtain this from your calculator."
+ elog
+ elog "Alternatively, HP has provided two ROM images for non-commercial"
+ elog "use only."
+ elog
+ elog "For an HP-48SX type: x48 -rom /usr/share/hp48/sxrom-j"
+ elog "For an HP-48GX type: x48 -rom /usr/share/hp48/gxrom-r"
+ elog
+ elog "(If you're not sure which one you want, go with HP-48GX)"
+ elog
+ elog "Note: you only need to use the '-rom' argument once"
+}