summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTavis Ormandy <taviso@gentoo.org>2006-01-26 22:25:22 +0000
committerTavis Ormandy <taviso@gentoo.org>2006-01-26 22:25:22 +0000
commit4a83433aa646f28f957e3fb4e6ca758af0ba8b79 (patch)
treed20efa8d5cbed79c29f70a9607a241e8d59dbc85 /app-emulation/x48
parentAdded modular X dependencies and closing bug #120463. (diff)
downloadgentoo-2-4a83433aa646f28f957e3fb4e6ca758af0ba8b79.tar.gz
gentoo-2-4a83433aa646f28f957e3fb4e6ca758af0ba8b79.tar.bz2
gentoo-2-4a83433aa646f28f957e3fb4e6ca758af0ba8b79.zip
bump with roms
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'app-emulation/x48')
-rw-r--r--app-emulation/x48/ChangeLog7
-rw-r--r--app-emulation/x48/Manifest3
-rw-r--r--app-emulation/x48/files/digest-x48-0.4.3-r13
-rw-r--r--app-emulation/x48/x48-0.4.3-r1.ebuild65
-rw-r--r--app-emulation/x48/x48-0.4.3.ebuild6
5 files changed, 79 insertions, 5 deletions
diff --git a/app-emulation/x48/ChangeLog b/app-emulation/x48/ChangeLog
index d7adbdbf5343..35ea201a880a 100644
--- a/app-emulation/x48/ChangeLog
+++ b/app-emulation/x48/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/x48
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.1 2006/01/26 20:18:30 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/ChangeLog,v 1.2 2006/01/26 22:25:22 taviso Exp $
+
+*x48-0.4.3-r1 (26 Jan 2006)
+
+ 26 Jan 2006; Tavis Ormandy <taviso@gentoo.org> +x48-0.4.3-r1.ebuild:
+ add version tha tincludes free-noncomm rom images
*x48-0.4.3 (26 Jan 2006)
diff --git a/app-emulation/x48/Manifest b/app-emulation/x48/Manifest
index 5586975447b9..76703a996662 100644
--- a/app-emulation/x48/Manifest
+++ b/app-emulation/x48/Manifest
@@ -1,5 +1,6 @@
-MD5 09d31dc231df4f64bd87f3551bf6e19b .x48-0.4.3.ebuild.swp 4096
+MD5 b5ee83d570fd7ea4ff7bb046233ce283 x48-0.4.3-r1.ebuild 1888
MD5 3cc8256f3a57f4acd0e30961abd2e93d x48-0.4.3.ebuild 1285
MD5 e52ae6e67bc2c8d60bbd39fce34bbc7d ChangeLog 336
MD5 8fc22f08ecb2e292e60ce7553c58d0c2 metadata.xml 222
+MD5 ee6c89f49403174656b10e45d633cc2a files/digest-x48-0.4.3-r1 173
MD5 a829031735c371ae3740c87f9d1a40be files/digest-x48-0.4.3 61
diff --git a/app-emulation/x48/files/digest-x48-0.4.3-r1 b/app-emulation/x48/files/digest-x48-0.4.3-r1
new file mode 100644
index 000000000000..dc7fe2ddd4fb
--- /dev/null
+++ b/app-emulation/x48/files/digest-x48-0.4.3-r1
@@ -0,0 +1,3 @@
+MD5 b365c8957057bbc60badb412ef6fb44f x48-0.4.3.tar.gz 128263
+MD5 8f61e9ee00562e94c485028eac311cf8 sxrom-j.zip 190826
+MD5 e4ec80ac325313b006b8c94d9be8db5a gxrom-r.zip 330144
diff --git a/app-emulation/x48/x48-0.4.3-r1.ebuild b/app-emulation/x48/x48-0.4.3-r1.ebuild
new file mode 100644
index 000000000000..3520e97159c7
--- /dev/null
+++ b/app-emulation/x48/x48-0.4.3-r1.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.4.3-r1.ebuild,v 1.1 2006/01/26 22:25:22 taviso Exp $
+
+inherit eutils
+
+DESCRIPTION="HP48 Calculator Emulator"
+HOMEPAGE="http://x48.berlios.de/"
+SRC_URI="http://download.berlios.de/x48/${P}.tar.gz
+ http://www.hpcalc.org/hp48/pc/emulators/sxrom-j.zip
+ http://www.hpcalc.org/hp48/pc/emulators/gxrom-r.zip"
+LICENSE="GPL-2 free-noncomm"
+
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="|| ( ( x11-proto/xextproto app-text/rman ) virtual/x11 )"
+DEPEND="${RDEPEND}
+ || ( ( x11-libs/libXext x11-libs/libX11 x11-misc/imake app-text/rman )
+ virtual/x11
+ )
+ sys-libs/readline
+ sys-libs/ncurses
+ app-arch/unzip
+ sys-libs/gpm"
+
+src_compile() {
+ xmkmf || die
+ emake CCOPTIONS="${CFLAGS}" LOCAL_LDFLAGS="${LDFLAGS}" || die
+}
+
+src_install() {
+ dobin ${S}/src/checkrom ${S}/src/dump2rom ${S}/src/mkcard ${S}/src/x48
+
+ newman ${S}/src/x48.man x48.1
+
+ dodir /usr/lib/X11/app-defaults
+ insinto /usr/lib/X11/app-defaults/
+ newins ${S}/src/X48.ad X48
+
+ dodir /usr/share/hp48
+ insinto /usr/share/hp48
+ doins ${S}/gxrom-r ${S}/sxrom-j
+
+ dodoc ${S}/doc/CARDS.doc ${S}/doc/ROMDump.doc
+ dodoc ${S}/romdump/ROMDump ${S}/romdump/ROMDump.s
+}
+
+pkg_postinst() {
+ einfo "The X48 emulator requires an HP48 ROM Image to run."
+ einfo
+ einfo "If you own an HP-48 calculator, you can use the ROMDump utility"
+ einfo "included with this package to obtain this from your calculator."
+ einfo
+ einfo "Alternatively, HP has provided two ROM images for non-commercial"
+ einfo "use only."
+ einfo
+ einfo "For an HP-48SX type: x48 -rom /usr/share/hp48/sxrom-j"
+ einfo "For an HP-48GX type: x48 -rom /usr/share/hp48/gxrom-r"
+ einfo
+ einfo "(If you're not sure which one you want, go with HP-48GX)"
+ einfo
+ einfo "Note: you only need to use the '-rom' argument once"
+}
diff --git a/app-emulation/x48/x48-0.4.3.ebuild b/app-emulation/x48/x48-0.4.3.ebuild
index 4a58458b55be..be29807bbd45 100644
--- a/app-emulation/x48/x48-0.4.3.ebuild
+++ b/app-emulation/x48/x48-0.4.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.4.3.ebuild,v 1.2 2006/01/26 22:00:18 taviso Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x48/x48-0.4.3.ebuild,v 1.3 2006/01/26 22:25:22 taviso Exp $
inherit eutils
@@ -15,8 +15,8 @@ IUSE=""
RDEPEND="|| ( ( x11-proto/xextproto app-text/rman ) virtual/x11 )"
DEPEND="${RDEPEND}
- || ( ( x11-libs/libXext x11-libs/libX11 x11-misc/imake app-text/rman )
- virtual/x11
+ || ( ( x11-libs/libXext x11-libs/libX11 x11-misc/imake app-text/rman )
+ virtual/x11
)
sys-libs/readline
sys-libs/ncurses