summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLuca Barbato <lu_zero@gentoo.org>2004-08-20 14:12:40 +0000
committerLuca Barbato <lu_zero@gentoo.org>2004-08-20 14:12:40 +0000
commit62fb1687975ec54379b019a19369dca72221a056 (patch)
treefecb51f784cb1ce8c108a703521b2231528adeed /app-emulation/qemu
parentEthernet bridge interface fix, closes bug 59534 (Manifest recommit) (diff)
downloadgentoo-2-62fb1687975ec54379b019a19369dca72221a056.tar.gz
gentoo-2-62fb1687975ec54379b019a19369dca72221a056.tar.bz2
gentoo-2-62fb1687975ec54379b019a19369dca72221a056.zip
Minor fix
Diffstat (limited to 'app-emulation/qemu')
-rw-r--r--app-emulation/qemu/ChangeLog6
-rw-r--r--app-emulation/qemu/files/qemu-0.6.0-sigaction.patch21
-rw-r--r--app-emulation/qemu/qemu-0.6.0.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/app-emulation/qemu/ChangeLog b/app-emulation/qemu/ChangeLog
index 333b9b5b3a61..c62d08b80c64 100644
--- a/app-emulation/qemu/ChangeLog
+++ b/app-emulation/qemu/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-emulation/qemu
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.14 2004/07/13 14:03:12 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/ChangeLog,v 1.15 2004/08/20 14:12:40 lu_zero Exp $
+
+ 20 Aug 2004; Luca Barbato <lu_zero@gentoo.org>
+ +files/qemu-0.6.0-sigaction.patch, qemu-0.6.0.ebuild:
+ Remove ancient glibc workaround
*qemu-0.6.0 (13 Jul 2004)
diff --git a/app-emulation/qemu/files/qemu-0.6.0-sigaction.patch b/app-emulation/qemu/files/qemu-0.6.0-sigaction.patch
new file mode 100644
index 000000000000..4f40e51635ff
--- /dev/null
+++ b/app-emulation/qemu/files/qemu-0.6.0-sigaction.patch
@@ -0,0 +1,21 @@
+diff -ruN qemu-0.6.0.orig/vl.c qemu-0.6.0/vl.c
+--- qemu-0.6.0.orig/vl.c 2004-08-20 15:18:08.238568392 +0200
++++ qemu-0.6.0/vl.c 2004-08-20 15:18:44.294087120 +0200
+@@ -68,17 +68,6 @@
+ #ifdef __APPLE__
+ #include <SDL/SDL.h>
+ #endif
+-#if defined(__linux__)
+-/* SDL use the pthreads and they modify sigaction. We don't
+- want that. */
+-#if (__GLIBC__ > 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 2))
+-extern void __libc_sigaction();
+-#define sigaction(sig, act, oact) __libc_sigaction(sig, act, oact)
+-#else
+-extern void __sigaction();
+-#define sigaction(sig, act, oact) __sigaction(sig, act, oact)
+-#endif
+-#endif /* __linux__ */
+ #endif /* CONFIG_SDL */
+
+ #include "disas.h"
diff --git a/app-emulation/qemu/qemu-0.6.0.ebuild b/app-emulation/qemu/qemu-0.6.0.ebuild
index 797b0218b42c..b9e999e510fa 100644
--- a/app-emulation/qemu/qemu-0.6.0.ebuild
+++ b/app-emulation/qemu/qemu-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.6.0.ebuild,v 1.1 2004/07/13 14:03:12 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/qemu/qemu-0.6.0.ebuild,v 1.2 2004/08/20 14:12:40 lu_zero Exp $
inherit eutils
@@ -30,6 +30,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/${P}-typo.patch
+ epatch ${FILESDIR}/${P}-sigaction.patch
}
src_compile() {