summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-06-24 07:55:07 +0000
committerMike Frysinger <vapier@gentoo.org>2006-06-24 07:55:07 +0000
commitc5513cc454d7332ed0d64bfb7bbc265f4e46b43a (patch)
treee86242f2041f6a63ef0a6b031233908ec6e7d495 /app-emulation/cedega
parentpull in xmessage #137065 by Fabrice Delliaux (diff)
downloadgentoo-2-c5513cc454d7332ed0d64bfb7bbc265f4e46b43a.tar.gz
gentoo-2-c5513cc454d7332ed0d64bfb7bbc265f4e46b43a.tar.bz2
gentoo-2-c5513cc454d7332ed0d64bfb7bbc265f4e46b43a.zip
Version bump #136717 by Rich Gannon.
(Portage version: 2.1.1_pre1-r2)
Diffstat (limited to 'app-emulation/cedega')
-rw-r--r--app-emulation/cedega/ChangeLog7
-rw-r--r--app-emulation/cedega/cedega-5.2.1.ebuild62
-rw-r--r--app-emulation/cedega/files/digest-cedega-5.2.13
3 files changed, 71 insertions, 1 deletions
diff --git a/app-emulation/cedega/ChangeLog b/app-emulation/cedega/ChangeLog
index 875f8e5caff9..fd7777670dfa 100644
--- a/app-emulation/cedega/ChangeLog
+++ b/app-emulation/cedega/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emulation/cedega
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.24 2006/04/27 13:36:49 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/ChangeLog,v 1.25 2006/06/24 07:55:07 vapier Exp $
+
+*cedega-5.2.1 (24 Jun 2006)
+
+ 24 Jun 2006; Mike Frysinger <vapier@gentoo.org> +cedega-5.2.1.ebuild:
+ Version bump #136717 by Rich Gannon.
27 Apr 2006; Marien Zwart <marienz@gentoo.org> ChangeLog:
-m Fix SHA256 digest, Manifest only.
diff --git a/app-emulation/cedega/cedega-5.2.1.ebuild b/app-emulation/cedega/cedega-5.2.1.ebuild
new file mode 100644
index 000000000000..d9128f0f07d6
--- /dev/null
+++ b/app-emulation/cedega/cedega-5.2.1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/cedega/cedega-5.2.1.ebuild,v 1.1 2006/06/24 07:55:07 vapier Exp $
+
+MY_P="cedega-small-${PV}"
+DESCRIPTION="Cedega replaces WineX, a distribution of Wine with enhanced DirectX for gaming"
+HOMEPAGE="http://www.transgaming.com/"
+SRC_URI="${MY_P}.tgz"
+
+LICENSE="Aladdin"
+SLOT="3"
+KEYWORDS="-* amd64 x86"
+IUSE="cups dbus opengl"
+RESTRICT="fetch strip"
+
+RDEPEND="|| ( ( x11-libs/libX11 ) virtual/x11 )
+ opengl? ( virtual/opengl )
+ dbus? ( sys-apps/dbus )
+ >=sys-libs/ncurses-5.2
+ cups? ( net-print/cups )
+ >=media-libs/freetype-2.0.0
+ >=dev-lang/python-2.3
+ >=dev-python/pygtk-2.4
+ !app-emulation/point2play
+ amd64? ( app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs )"
+
+pkg_nofetch() {
+ einfo "Please download the appropriate Cedega archive (${MY_P}.tgz)"
+ einfo "from ${HOMEPAGE} (requires a Transgaming subscription)"
+ einfo
+ einfo "Then put the file in ${DISTDIR}"
+}
+
+src_install() {
+ rm -r "${WORKDIR}"/usr/share/gnome
+ rmdir "${WORKDIR}"/usr/share/* >& /dev/null
+ mv "${WORKDIR}"/usr "${D}"/ || die "mv usr"
+}
+
+pkg_postinst() {
+ einfo "Run /usr/bin/cedega to start cedega as any non-root user."
+ einfo "This is a wrapper-script which will take care of creating"
+ einfo "an initial environment and do everything else."
+ einfo ""
+ einfo "Optionally, if you have binfmt_misc compiled into your kernel,"
+ einfo "you can add the following to /etc/sysctl.conf to allow direct"
+ einfo "excecution of Windows binaries through the cedega wrapper:"
+ einfo ""
+ einfo " fs.binfmt_misc.register = :WINEXE:M::MZ::/usr/bin/cedega:"
+ einfo ""
+ einfo "You will also need to mount the /proc/sys/fs/binfmt_misc"
+ einfo "file system in order for this to work. You can add the following"
+ einfo "line into your /etc/fstab file:"
+ einfo ""
+ einfo " none /proc/sys/fs/binfmt_misc binfmt_misc defaults 0 0"
+ einfo ""
+ einfo "Note: Binaries will still need excecutable permissions to run."
+ einfo "Note: If binfmt_misc is compiled as a module, make sure you"
+ einfo "have it loaded on startup by adding it to"
+ einfo "/etc/modules.autoload.d/<your kernel version>"
+}
diff --git a/app-emulation/cedega/files/digest-cedega-5.2.1 b/app-emulation/cedega/files/digest-cedega-5.2.1
new file mode 100644
index 000000000000..315bd399fa06
--- /dev/null
+++ b/app-emulation/cedega/files/digest-cedega-5.2.1
@@ -0,0 +1,3 @@
+MD5 62d6f1d71c10353100ccd6b858c85d78 cedega-small-5.2.1.tgz 1268678
+RMD160 4b40167afe82c571f2549ffd1b19804e9cdfc7b7 cedega-small-5.2.1.tgz 1268678
+SHA256 3d2cedc1364d42cd056f773601c2d39329bc29796d76ae4053df23a685fdd9e1 cedega-small-5.2.1.tgz 1268678