summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2011-12-23 21:29:51 +0000
committerUlrich Müller <ulm@gentoo.org>2011-12-23 21:29:51 +0000
commit27c2a3ec5b6a508c460f77b4a437dbc1e3538c8e (patch)
treec324e236589fd9bb123fa183d51e4dc55e3a5c3d /app-emacs
parentAdding use_selinux dependency on selinux-slocate (SELinux policy for *locate) (diff)
downloadgentoo-2-27c2a3ec5b6a508c460f77b4a437dbc1e3538c8e.tar.gz
gentoo-2-27c2a3ec5b6a508c460f77b4a437dbc1e3538c8e.tar.bz2
gentoo-2-27c2a3ec5b6a508c460f77b4a437dbc1e3538c8e.zip
Version bump.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'app-emacs')
-rw-r--r--app-emacs/gentoo-syntax/ChangeLog7
-rw-r--r--app-emacs/gentoo-syntax/gentoo-syntax-1.19.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-emacs/gentoo-syntax/ChangeLog b/app-emacs/gentoo-syntax/ChangeLog
index b7a3846690bd..6c49aa369691 100644
--- a/app-emacs/gentoo-syntax/ChangeLog
+++ b/app-emacs/gentoo-syntax/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-emacs/gentoo-syntax
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.75 2011/01/18 18:42:52 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/ChangeLog,v 1.76 2011/12/23 21:29:51 ulm Exp $
+
+*gentoo-syntax-1.19 (23 Dec 2011)
+
+ 23 Dec 2011; Ulrich Mueller <ulm@gentoo.org> +gentoo-syntax-1.19.ebuild:
+ Version bump.
18 Jan 2011; Fabian Groffen <grobian@gentoo.org> gentoo-syntax-1.18.ebuild:
Marked ~ppc-macos, bug #351946
diff --git a/app-emacs/gentoo-syntax/gentoo-syntax-1.19.ebuild b/app-emacs/gentoo-syntax/gentoo-syntax-1.19.ebuild
new file mode 100644
index 000000000000..2daa8fca39c7
--- /dev/null
+++ b/app-emacs/gentoo-syntax/gentoo-syntax-1.19.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/gentoo-syntax/gentoo-syntax-1.19.ebuild,v 1.1 2011/12/23 21:29:51 ulm Exp $
+
+inherit elisp
+
+DESCRIPTION="Emacs modes for editing ebuilds and other Gentoo specific files"
+HOMEPAGE="http://www.gentoo.org/proj/en/lisp/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+DOCS="ChangeLog"
+SITEFILE="50${PN}-gentoo.el"
+
+src_compile() {
+ elisp_src_compile
+ makeinfo gentoo-syntax.texi || die
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc || die
+ sed -e "s:@PORTDIR@:${PORTDIR}:" \
+ "${FILESDIR}/${SITEFILE}" >"${T}/${SITEFILE}" || die
+ elisp-site-file-install "${T}/${SITEFILE}" || die
+ doinfo gentoo-syntax.info || die
+ dodoc ${DOCS} || die
+}
+
+pkg_postinst() {
+ elisp-site-regen
+
+ elog "Some optional features may require installation of additional"
+ elog "packages, like app-portage/gentoolkit-dev for echangelog."
+}