summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-01 02:52:02 +0000
commit08bd106430ca5599005323021f7635b2f1a1f72b (patch)
treed56e46390f1a7838a1a5eecfd8573e5eb47d0c98 /app-emacs/thumbs
parentmasked app-emacs/monk (incomplete for now) (diff)
downloadgentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.gz
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.tar.bz2
gentoo-2-08bd106430ca5599005323021f7635b2f1a1f72b.zip
looks like an app-emacs/ import to me
Diffstat (limited to 'app-emacs/thumbs')
-rw-r--r--app-emacs/thumbs/ChangeLog11
-rw-r--r--app-emacs/thumbs/files/50thumbs-gentoo.el5
-rw-r--r--app-emacs/thumbs/files/digest-thumbs-0.8.11
-rw-r--r--app-emacs/thumbs/thumbs-0.8.1.ebuild39
4 files changed, 56 insertions, 0 deletions
diff --git a/app-emacs/thumbs/ChangeLog b/app-emacs/thumbs/ChangeLog
new file mode 100644
index 000000000000..be8306f8fd61
--- /dev/null
+++ b/app-emacs/thumbs/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for app-emacs/thumbs
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/ChangeLog,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+*thumbs-0.8.1 (31 Oct 2002)
+
+ 31 Oct 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ thumbs-0.8.1.ebuild, files/50thumbs-gentoo.el,
+ files/digest-thumbs-0.8.1 :
+
+ Initial import.
diff --git a/app-emacs/thumbs/files/50thumbs-gentoo.el b/app-emacs/thumbs/files/50thumbs-gentoo.el
new file mode 100644
index 000000000000..694295d20873
--- /dev/null
+++ b/app-emacs/thumbs/files/50thumbs-gentoo.el
@@ -0,0 +1,5 @@
+
+;;; thumbs site-lisp configuration
+
+(setq load-path (cons "@SITELISP@" load-path))
+(require 'thumbs)
diff --git a/app-emacs/thumbs/files/digest-thumbs-0.8.1 b/app-emacs/thumbs/files/digest-thumbs-0.8.1
new file mode 100644
index 000000000000..bcd0c12c7426
--- /dev/null
+++ b/app-emacs/thumbs/files/digest-thumbs-0.8.1
@@ -0,0 +1 @@
+MD5 7db89be13fd95599ead1dd29c5cbaa5e thumbs-0.8.1.tar.bz2 7381
diff --git a/app-emacs/thumbs/thumbs-0.8.1.ebuild b/app-emacs/thumbs/thumbs-0.8.1.ebuild
new file mode 100644
index 000000000000..eeb7a42296a9
--- /dev/null
+++ b/app-emacs/thumbs/thumbs-0.8.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emacs/thumbs/thumbs-0.8.1.ebuild,v 1.1 2002/11/01 02:52:02 mkennedy Exp $
+
+inherit elisp
+
+IUSE=""
+
+DESCRIPTION="Emacs thumbnail previewer for image files"
+HOMEPAGE="http://aroy.net/emacslisp.org/mypackages/thumbs/thumbs.el"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/emacs
+ media-gfx/imagemagick"
+
+S="${WORKDIR}/${P}"
+
+SITEFILE=50thumbs-gentoo.el
+
+src_compile() {
+ emacs --batch -f batch-byte-compile --no-site-file --no-init-file *.el
+}
+
+src_install() {
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install ${FILESDIR}/${SITEFILE}
+}
+
+pkg_postinst() {
+ elisp-site-regen
+ einfo "Please see ${SITELISP}/${PN}/thumbs.el for the complete documentation."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+}