summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2010-10-20 18:45:31 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2010-10-20 18:45:31 +0000
commitfc6d9c7ba598cd1e582b01ba633557bebb638b6a (patch)
treea3dffc70681e9e0f8cdcc943c630a3d302c50817 /app-editors
parentMarking system-config-printer-gnome-1.2.4 ~ppc for bug 336920 (diff)
downloadgentoo-2-fc6d9c7ba598cd1e582b01ba633557bebb638b6a.tar.gz
gentoo-2-fc6d9c7ba598cd1e582b01ba633557bebb638b6a.tar.bz2
gentoo-2-fc6d9c7ba598cd1e582b01ba633557bebb638b6a.zip
Version bump
(Portage version: 2.2_rc98/cvs/Linux x86_64)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/gummi/ChangeLog7
-rw-r--r--app-editors/gummi/gummi-0.5.2.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/app-editors/gummi/ChangeLog b/app-editors/gummi/ChangeLog
index 21347367f185..eeceb063e19d 100644
--- a/app-editors/gummi/ChangeLog
+++ b/app-editors/gummi/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-editors/gummi
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.6 2010/10/12 16:34:26 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/ChangeLog,v 1.7 2010/10/20 18:45:31 hwoarang Exp $
+
+*gummi-0.5.2 (20 Oct 2010)
+
+ 20 Oct 2010; Markos Chandras <hwoarang@gentoo.org> +gummi-0.5.2.ebuild:
+ Version bump
12 Oct 2010; Markos Chandras <hwoarang@gentoo.org> gummi-0.5.1.ebuild:
Move gtkspell and gtksourceview to RDEPEND
diff --git a/app-editors/gummi/gummi-0.5.2.ebuild b/app-editors/gummi/gummi-0.5.2.ebuild
new file mode 100644
index 000000000000..7bf78d0ca6e0
--- /dev/null
+++ b/app-editors/gummi/gummi-0.5.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/gummi/gummi-0.5.2.ebuild,v 1.1 2010/10/20 18:45:31 hwoarang Exp $
+
+EAPI=2
+inherit base eutils
+
+DESCRIPTION="Simple LaTeX editor for GTK+ users"
+HOMEPAGE="http://gummi.midnightcoding.org"
+SRC_URI="http://dev.midnightcoding.org/redmine/attachments/download/88/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+LANGS="ca da de fr el it nl pt_BR ru zh_TW"
+
+for X in ${LANGS} ; do
+ IUSE="${IUSE} linguas_${X}"
+done
+
+RDEPEND="app-text/gtkspell
+ >=dev-libs/glib-2.16:2
+ dev-texlive/texlive-latex
+ dev-texlive/texlive-latexextra
+ >=x11-libs/gtk+-2.16:2
+ x11-libs/gtksourceview"
+DEPEND="${RDEPEND}
+ app-text/poppler[cairo]
+ x11-libs/gtksourceview:2.0
+ x11-libs/pango"
+
+DOCS=( AUTHORS ChangeLog README )
+
+src_prepare() {
+ strip-linguas ${LANGS}
+}
+
+pkg_postinst() {
+ elog "Gummi >=0.4.8 supports spell-checking through gtkspell. Support for"
+ elog "additional languages can be added by installing myspell-** packages"
+ elog "for your language of choice."
+}