summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorUlrich Müller <ulm@gentoo.org>2008-02-01 18:54:09 +0000
committerUlrich Müller <ulm@gentoo.org>2008-02-01 18:54:09 +0000
commitf067d1ef5856a63e10bb1437f49ee1cc4179a8f8 (patch)
treebc0d9cb4394f140fca73a39bbd37a25da5e65e46 /app-editors
parentMarking libgnomeprint-2.18.3 ppc64 stable for bug 208366 (diff)
downloadgentoo-2-f067d1ef5856a63e10bb1437f49ee1cc4179a8f8.tar.gz
gentoo-2-f067d1ef5856a63e10bb1437f49ee1cc4179a8f8.tar.bz2
gentoo-2-f067d1ef5856a63e10bb1437f49ee1cc4179a8f8.zip
Snapshot of CVS trunk. Add libotf USE flag.
(Portage version: 2.1.4.1)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/emacs-cvs/ChangeLog9
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild245
-rw-r--r--app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild12
3 files changed, 261 insertions, 5 deletions
diff --git a/app-editors/emacs-cvs/ChangeLog b/app-editors/emacs-cvs/ChangeLog
index e2b3f39cde3f..31604bbc6140 100644
--- a/app-editors/emacs-cvs/ChangeLog
+++ b/app-editors/emacs-cvs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/emacs-cvs
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.188 2008/02/01 16:50:33 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/ChangeLog,v 1.189 2008/02/01 18:54:09 ulm Exp $
+
+*emacs-cvs-23.0.50_pre20080201 (01 Feb 2008)
+
+ 01 Feb 2008; Ulrich Mueller <ulm@gentoo.org>
+ +emacs-cvs-23.0.50_pre20080201.ebuild, emacs-cvs-23.0.60-r2.ebuild:
+ Snapshot of CVS trunk, tagged "before-merge-unicode-to-trunk". Add libotf
+ local USE flag.
*emacs-cvs-23.0.60-r2 (01 Feb 2008)
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild
new file mode 100644
index 000000000000..5d9b25b4495a
--- /dev/null
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild
@@ -0,0 +1,245 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.50_pre20080201.ebuild,v 1.1 2008/02/01 18:54:09 ulm Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit autotools elisp-common eutils flag-o-matic
+
+DESCRIPTION="The extensible, customizable, self-documenting real-time display editor"
+HOMEPAGE="http://www.gnu.org/software/emacs/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3 FDL-1.2 BSD"
+SLOT="23"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="alsa dbus gif gpm gtk gzip-el hesiod jpeg kerberos motif png spell sound source svg tiff toolkit-scroll-bars X Xaw3d xpm"
+RESTRICT="strip"
+
+RDEPEND="sys-libs/ncurses
+ >=app-admin/eselect-emacs-1.2
+ net-libs/liblockfile
+ hesiod? ( net-dns/hesiod )
+ kerberos? ( virtual/krb5 )
+ spell? ( || ( app-text/ispell app-text/aspell ) )
+ alsa? ( media-libs/alsa-lib )
+ gpm? ( sys-libs/gpm )
+ dbus? ( sys-apps/dbus )
+ X? (
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-misc/xbitmaps
+ x11-misc/emacs-desktop
+ gif? ( media-libs/giflib )
+ jpeg? ( media-libs/jpeg )
+ tiff? ( media-libs/tiff )
+ png? ( media-libs/libpng )
+ svg? ( >=gnome-base/librsvg-2.0 )
+ xpm? ( x11-libs/libXpm )
+ gtk? ( =x11-libs/gtk+-2* )
+ !gtk? (
+ Xaw3d? ( x11-libs/Xaw3d )
+ !Xaw3d? (
+ motif? ( virtual/motif )
+ )
+ )
+ )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ gzip-el? ( app-arch/gzip )"
+
+S="${WORKDIR}/emacs"
+
+# FULL_VERSION keeps the full version number, which is needed in order to
+# determine some path information correctly for copy/move operations later on
+FULL_VERSION="${PV%%_*}"
+EMACS_SUFFIX="emacs-${SLOT}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${PN}-freebsd-sparc.patch"
+
+ sed -i -e "s:/usr/lib/crtbegin.o:$(`tc-getCC` -print-file-name=crtbegin.o):g" \
+ -e "s:/usr/lib/crtend.o:$(`tc-getCC` -print-file-name=crtend.o):g" \
+ "${S}"/src/s/freebsd.h || die "unable to sed freebsd.h settings"
+
+ if ! use alsa; then
+ # ALSA is detected even if not requested by its USE flag.
+ # Suppress it by supplying pkg-config with a wrong library name.
+ sed -i -e "/ALSA_MODULES=/s/alsa/DiSaBlEaLsA/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+ if ! use gzip-el; then
+ # Emacs' build system automatically detects the gzip binary and
+ # compresses el files. We don't want that so confuse it with a
+ # wrong binary name
+ sed -i -e "s/ gzip/ PrEvEnTcOmPrEsSiOn/" configure.in \
+ || die "unable to sed configure.in"
+ fi
+
+ eautoreconf
+}
+
+src_compile() {
+ export SANDBOX_ON=0 # for the unbelievers, see Bug #131505
+ ALLOWED_FLAGS=""
+ strip-flags
+ unset LDFLAGS
+ replace-flags -O[3-9] -O2
+
+ local myconf
+
+ if use alsa && ! use sound; then
+ echo
+ einfo "Although sound USE flag is disabled you chose to have alsa,"
+ einfo "so sound is switched on anyway."
+ echo
+ myconf="${myconf} --with-sound"
+ else
+ myconf="${myconf} $(use_with sound)"
+ fi
+
+ if use X; then
+ myconf="${myconf} --with-x"
+ myconf="${myconf} $(use_with toolkit-scroll-bars)"
+ myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
+ myconf="${myconf} $(use_with gif) $(use_with png)"
+ myconf="${myconf} $(use_with xpm) $(use_with svg rsvg)"
+
+ # GTK+ is the default toolkit if USE=gtk is chosen with other
+ # possibilities. Emacs upstream thinks this should be standard
+ # policy on all distributions
+ if use gtk; then
+ echo
+ einfo "Configuring to build with GTK support, disabling all other toolkits"
+ echo
+ myconf="${myconf} --with-x-toolkit=gtk"
+ elif use Xaw3d; then
+ einfo "Configuring to build with Xaw3d (athena) support"
+ myconf="${myconf} --with-x-toolkit=athena"
+ myconf="${myconf} --without-gtk"
+ elif use motif; then
+ einfo "Configuring to build with motif toolkit support"
+ myconf="${myconf} --with-x-toolkit=motif"
+ myconf="${myconf} --without-gtk"
+ else
+ einfo "Configuring to build with no toolkit"
+ myconf="${myconf} --with-x-toolkit=no"
+ myconf="${myconf} --without-gtk"
+ fi
+ else
+ myconf="${myconf} --without-x"
+ fi
+
+ myconf="${myconf} $(use_with hesiod)"
+ myconf="${myconf} $(use_with kerberos) $(use_with kerberos kerberos5)"
+ myconf="${myconf} $(use_with gpm) $(use_with dbus)"
+
+ econf \
+ --program-suffix=-${EMACS_SUFFIX} \
+ --infodir=/usr/share/info/${EMACS_SUFFIX} \
+ --without-carbon \
+ ${myconf} || die "econf emacs failed"
+
+ emake CC="$(tc-getCC)" bootstrap || die "make bootstrap failed"
+}
+
+src_install () {
+ local i m
+
+ emake install DESTDIR="${D}" || die "make install failed"
+
+ rm "${D}"/usr/bin/emacs-${FULL_VERSION}-${EMACS_SUFFIX} \
+ || die "removing duplicate emacs executable failed"
+ mv "${D}"/usr/bin/emacs-${EMACS_SUFFIX} "${D}"/usr/bin/${EMACS_SUFFIX} \
+ || die "moving Emacs executable failed"
+
+ # move info documentation to the correct place
+ einfo "Fixing info documentation ..."
+ for i in "${D}"/usr/share/info/${EMACS_SUFFIX}/*; do
+ mv "${i}" "${i}.info" || die "mv info failed"
+ done
+
+ # move man pages to the correct place
+ einfo "Fixing manpages ..."
+ for m in "${D}"/usr/share/man/man1/* ; do
+ mv "${m}" "${m%.1}-${EMACS_SUFFIX}.1" || die "mv man failed"
+ done
+
+ # avoid collision between slots, see bug #169033 e.g.
+ rm "${D}"/usr/share/emacs/site-lisp/subdirs.el
+ rm -rf "${D}"/usr/share/{applications,icons}
+ rm "${D}"/var/lib/games/emacs/{snake,tetris}-scores
+ keepdir /var/lib/games/emacs/
+
+ if use source; then
+ insinto /usr/share/emacs/${FULL_VERSION}/src
+ # This is not meant to install all the source -- just the
+ # C source you might find via find-function
+ doins src/*.[ch]
+ sed 's/^X//' >10${PN}-${SLOT}-gentoo.el <<-EOF
+
+ ;;; ${PN}-${SLOT} site-lisp configuration
+
+ (if (string-match "\\\\\`${FULL_VERSION//./\\\\.}\\\\>" emacs-version)
+ X (setq find-function-C-source-directory
+ X "/usr/share/emacs/${FULL_VERSION}/src"))
+ EOF
+ elisp-site-file-install 10${PN}-${SLOT}-gentoo.el
+ fi
+
+ dodoc README BUGS || die "dodoc failed"
+}
+
+emacs-infodir-rebuild() {
+ # Depending on the Portage version, the Info dir file is compressed
+ # or removed. It is only rebuilt by Portage if our directory is in
+ # INFOPATH, which is not guaranteed. So we rebuild it ourselves.
+
+ local infodir=/usr/share/info/${EMACS_SUFFIX} f
+ einfo "Regenerating Info directory index in ${infodir} ..."
+ rm -f "${ROOT}"${infodir}/dir{,.*}
+ for f in "${ROOT}"${infodir}/*.info*; do
+ [[ ${f##*/} == *[0-9].info* ]] \
+ || install-info --info-dir="${ROOT}"${infodir} "${f}" &>/dev/null
+ done
+ echo
+}
+
+pkg_postinst() {
+ test -f "${ROOT}"/usr/share/emacs/site-lisp/subdirs.el ||
+ cp "${ROOT}"/usr/share/emacs{/${FULL_VERSION},}/site-lisp/subdirs.el
+
+ local f
+ for f in "${ROOT}"/var/lib/games/emacs/{snake,tetris}-scores; do
+ test -e "${f}" || touch "${f}"
+ done
+
+ elisp-site-regen
+ emacs-infodir-rebuild
+ eselect emacs update ifunset
+
+ if use X; then
+ elog "You need to install some fonts for Emacs. Under monolithic"
+ elog "XFree86/Xorg you typically had such fonts installed by default."
+ elog "With modular Xorg, you will have to perform this step yourself."
+ elog "Installing media-fonts/font-adobe-{75,100}dpi on the X server's"
+ elog "machine would satisfy basic Emacs requirements under X11."
+ fi
+
+ echo
+ elog "You can set the version to be started by /usr/bin/emacs through"
+ elog "the Emacs eselect module, which also redirects man and info pages."
+ elog "You can therefore test emacs-cvs along with the stable release."
+ elog "\"man emacs.eselect\" for details."
+}
+
+pkg_postrm() {
+ elisp-site-regen
+ emacs-infodir-rebuild
+ eselect emacs update ifunset
+}
diff --git a/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild b/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
index 4eb6310766cb..ad87a88f7c12 100644
--- a/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
+++ b/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild,v 1.1 2008/02/01 16:50:33 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/emacs-cvs/emacs-cvs-23.0.60-r2.ebuild,v 1.2 2008/02/01 18:54:09 ulm Exp $
ECVS_AUTH="pserver"
ECVS_SERVER="cvs.savannah.gnu.org:/sources/emacs"
@@ -21,7 +21,7 @@ LICENSE="GPL-3 FDL-1.2 BSD"
SLOT="23"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="alsa dbus gif gpm gtk gzip-el hesiod jpeg kerberos motif png spell sound source svg tiff toolkit-scroll-bars X Xaw3d xft xpm"
+IUSE="alsa dbus gif gpm gtk gzip-el hesiod jpeg kerberos libotf motif png spell sound source svg tiff toolkit-scroll-bars X Xaw3d xft xpm"
RESTRICT="strip"
RDEPEND="sys-libs/ncurses
@@ -44,7 +44,11 @@ RDEPEND="sys-libs/ncurses
png? ( media-libs/libpng )
svg? ( >=gnome-base/librsvg-2.0 )
xpm? ( x11-libs/libXpm )
- xft? ( media-libs/fontconfig virtual/xft >=dev-libs/libotf-0.9.4 )
+ xft? (
+ media-libs/fontconfig
+ virtual/xft
+ libotf? ( >=dev-libs/libotf-0.9.4 )
+ )
gtk? ( =x11-libs/gtk+-2* )
!gtk? (
Xaw3d? ( x11-libs/Xaw3d )
@@ -126,7 +130,7 @@ src_compile() {
myconf="${myconf} $(use_with toolkit-scroll-bars)"
myconf="${myconf} $(use_enable xft font-backend)"
myconf="${myconf} $(use_with xft freetype)"
- myconf="${myconf} $(use_with xft)"
+ myconf="${myconf} $(use_with xft) $(use_with libotf)"
myconf="${myconf} $(use_with jpeg) $(use_with tiff)"
myconf="${myconf} $(use_with gif) $(use_with png)"
myconf="${myconf} $(use_with xpm) $(use_with svg rsvg)"