summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAli Polatel <hawking@gentoo.org>2007-09-21 21:24:31 +0000
committerAli Polatel <hawking@gentoo.org>2007-09-21 21:24:31 +0000
commit535cb3fd4586cc68c0168743ade4f5478dcd532c (patch)
tree8c04a866884e51a72bdc152e650ca79666e54a54 /app-editors
parentremove duplicate USE=apache2 (diff)
downloadgentoo-2-535cb3fd4586cc68c0168743ade4f5478dcd532c.tar.gz
gentoo-2-535cb3fd4586cc68c0168743ade4f5478dcd532c.tar.bz2
gentoo-2-535cb3fd4586cc68c0168743ade4f5478dcd532c.zip
revbump. add patch to fix symbol collision between elvis and freetype. bug 189271, thanks to Gordon Malm.
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-editors')
-rw-r--r--app-editors/elvis/ChangeLog9
-rw-r--r--app-editors/elvis/elvis-2.2.0-r3.ebuild91
-rw-r--r--app-editors/elvis/files/digest-elvis-2.2.0-r33
-rw-r--r--app-editors/elvis/files/ft2.3-symbol-collision-fix.patch73
4 files changed, 175 insertions, 1 deletions
diff --git a/app-editors/elvis/ChangeLog b/app-editors/elvis/ChangeLog
index 59bcaae49a92..82410147e4e2 100644
--- a/app-editors/elvis/ChangeLog
+++ b/app-editors/elvis/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-editors/elvis
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.32 2007/07/22 08:42:58 omp Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/ChangeLog,v 1.33 2007/09/21 21:24:30 hawking Exp $
+
+*elvis-2.2.0-r3 (21 Sep 2007)
+
+ 21 Sep 2007; Ali Polatel <hawking@gentoo.org>
+ +files/ft2.3-symbol-collision-fix.patch, +elvis-2.2.0-r3.ebuild:
+ revbump. add patch to fix symbol collision between elvis and freetype.
+ bug 189271, thanks to Gordon Malm.
22 Jul 2007; David Shakaryan <omp@gentoo.org> elvis-2.2.0-r1.ebuild,
elvis-2.2.0-r2.ebuild:
diff --git a/app-editors/elvis/elvis-2.2.0-r3.ebuild b/app-editors/elvis/elvis-2.2.0-r3.ebuild
new file mode 100644
index 000000000000..fa6399137288
--- /dev/null
+++ b/app-editors/elvis/elvis-2.2.0-r3.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.2.0-r3.ebuild,v 1.1 2007/09/21 21:24:31 hawking Exp $
+
+inherit eutils versionator
+
+MY_PV="$(replace_version_separator 2 '_')"
+
+DESCRIPTION="A vi/ex clone"
+HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
+SRC_URI="ftp://ftp.cs.pdx.edu/pub/elvis/${PN}-${MY_PV}.tar.gz"
+
+LICENSE="Artistic"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X"
+
+DEPEND=">=sys-libs/ncurses-5.2
+ X? ( >=x11-proto/xproto-7.0.4
+ >=x11-libs/libX11-1.0.0
+ >=x11-libs/libXt-1.0.0
+ >=x11-libs/libXpm-3.5.4.2
+ >=x11-libs/libXft-2.1.8.2 )
+ app-admin/eselect-vi"
+PROVIDE="virtual/editor"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ #epatch "${FILESDIR}/ft2.3-symbol-collision-fix.patch"
+}
+
+src_compile() {
+ ./configure \
+ --prefix=/usr \
+ --bindir=/usr/bin \
+ --datadir=/usr/share/elvis \
+ --docdir=/usr/share/doc/"${PF}" \
+ $(use_with X x) \
+ || die "configure failed"
+
+ # Some Makefile fixups (must happen after configure)
+ # Use our CFLAGS
+ sed -i -e "s:gcc -O2:gcc ${CFLAGS}:" Makefile || die "sed 1 failed"
+
+ # We'll install the man-pages ourselves
+ sed -i -e '/^ sh instman.sh/d' Makefile || die "sed 2 failed"
+
+ # Don't try to write to /etc
+ sed -i -e 's,/etc/elvis,${D}/etc/elvis,g' Makefile || die "sed 3 failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ dodir /usr/share/elvis
+ dodir /usr/share/doc/"${PF}"
+ dodir /etc
+ make install \
+ PREFIX="${D}"/usr \
+ BINDIR="${D}"/usr/bin \
+ DATADIR="${D}"/usr/share/elvis \
+ DOCDIR="${D}"/usr/share/doc/"${PF}" || die 'make install failed'
+
+ # Install the man-pages
+ mv doc/elvis.man doc/elvis.1
+ mv doc/elvtags.man doc/elvtags.1
+ mv doc/ref.man doc/ref.1
+ doman doc/*.1 || die 'doman failed'
+
+ # Fixup some READMEs
+ sed -i -e "s,${D},,g" "${D}"/etc/elvis/README \
+ || die 'sed /etc/elvis/README failed'
+ sed -i -e "s,${D},,g" "${D}"/usr/share/elvis/README \
+ || die 'sed /usr/share/elvis/README failed'
+}
+
+pkg_postinst() {
+ einfo "Setting /usr/bin/vi symlink"
+ eselect vi set "${PN}"
+}
+
+pkg_postrm() {
+ einfo "Updating /usr/bin/vi symlink"
+ eselect vi update
+}
diff --git a/app-editors/elvis/files/digest-elvis-2.2.0-r3 b/app-editors/elvis/files/digest-elvis-2.2.0-r3
new file mode 100644
index 000000000000..2f4cb20be284
--- /dev/null
+++ b/app-editors/elvis/files/digest-elvis-2.2.0-r3
@@ -0,0 +1,3 @@
+MD5 6831b8df3e4a530395e66c2889783752 elvis-2.2_0.tar.gz 1439293
+RMD160 9867a3941a84a3db0bcfe4e36dd14132fbcf5805 elvis-2.2_0.tar.gz 1439293
+SHA256 9a8466b2293798441056bc279736af3a616baaba2f11940396cc60ff71924ea0 elvis-2.2_0.tar.gz 1439293
diff --git a/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch b/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch
new file mode 100644
index 000000000000..aac099e56ef7
--- /dev/null
+++ b/app-editors/elvis/files/ft2.3-symbol-collision-fix.patch
@@ -0,0 +1,73 @@
+diff -ur elvis-2.2_0-orig/guix11/tags elvis-2.2_0/guix11/tags
+--- elvis-2.2_0-orig/guix11/tags 2003-10-20 19:32:26.000000000 -0700
++++ elvis-2.2_0/guix11/tags 2007-08-17 12:56:28.000000000 -0700
+@@ -31,7 +31,7 @@
+ DEFAULT_TOOLFG guix11.c 40;" d ln:40 file:
+ DEFAULT_XENCODING guix11.c 48;" d ln:48 file:
+ FT_DEFAULT xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+-FT_FILE xdialog.h 10;" ln:10 enum:X_FIELDTYPE
++FT_FILEC xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+ FT_LOCKED xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+ FT_NUMBER xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+ FT_ONEOF xdialog.h 10;" ln:10 enum:X_FIELDTYPE
+diff -ur elvis-2.2_0-orig/guix11/xdialog.c elvis-2.2_0/guix11/xdialog.c
+--- elvis-2.2_0-orig/guix11/xdialog.c 2003-10-20 19:32:26.000000000 -0700
++++ elvis-2.2_0/guix11/xdialog.c 2007-08-17 12:56:28.000000000 -0700
+@@ -387,7 +387,7 @@
+ case 'o': ft = FT_ONEOF, limit = scan; break;
+ case 'n': ft = FT_NUMBER, limit = scan; break;
+ case 's': ft = FT_STRING; break;
+- case 'f': ft = FT_FILE; break;
++ case 'f': ft = FT_FILEC; break;
+ case 'l': ft = FT_LOCKED; break;
+ }
+
+@@ -556,7 +556,7 @@
+ break;
+
+ case FT_STRING:
+- case FT_FILE:
++ case FT_FILEC:
+ button = addbutton(dia, "<", 'l', ELVCTRL('L'));
+ button->y = dia->y0 + dia->rowh * i;
+ button->x = dia->x0 + 3;
+@@ -1111,7 +1111,7 @@
+ newvalue = keystring(dia, key);
+ break;
+
+- case FT_FILE:
++ case FT_FILEC:
+ #ifdef FEATURE_COMPLETE
+ if (key == '\t')
+ {
+@@ -1179,7 +1179,7 @@
+ switch (dia->field[row].ft)
+ {
+ case FT_STRING:
+- case FT_FILE:
++ case FT_FILEC:
+ case FT_NUMBER:
+ case FT_LOCKED:
+ drawtext(dia, row);
+@@ -1207,7 +1207,7 @@
+ break;
+
+ case FT_STRING:
+- case FT_FILE:
++ case FT_FILEC:
+ if (button->shape == 'l')
+ if (row == dia->current
+ ? dia->shift > 0
+diff -ur elvis-2.2_0-orig/guix11/xdialog.h elvis-2.2_0/guix11/xdialog.h
+--- elvis-2.2_0-orig/guix11/xdialog.h 2003-10-20 19:32:26.000000000 -0700
++++ elvis-2.2_0/guix11/xdialog.h 2007-08-17 12:56:28.000000000 -0700
+@@ -5,7 +5,7 @@
+ FT_ONEOF, /* one of a preset list; includes boolean */
+ FT_NUMBER, /* numeric field */
+ FT_STRING, /* string field */
+- FT_FILE, /* string field where <Tab> does filename completion */
++ FT_FILEC, /* string field where <Tab> does filename completion */
+ FT_LOCKED /* non-editable field */
+ } X_FIELDTYPE;
+ typedef struct
+