summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDamon Conway <kabau@gentoo.org>2002-07-25 19:12:09 +0000
committerDamon Conway <kabau@gentoo.org>2002-07-25 19:12:09 +0000
commit14735fbc060a951121ae8321d95d6bd2b865f881 (patch)
tree49bfd7f7dfa4f8306bc4c86bbf82b068e2c29611 /app-editors/elvis
parentAdded SLOT, KEYWORDS, and LICENSE. Also fixed spacing and depricated try syn... (diff)
downloadgentoo-2-14735fbc060a951121ae8321d95d6bd2b865f881.tar.gz
gentoo-2-14735fbc060a951121ae8321d95d6bd2b865f881.tar.bz2
gentoo-2-14735fbc060a951121ae8321d95d6bd2b865f881.zip
Added SLOT, KEYWORDS, and LICENSE.
Diffstat (limited to 'app-editors/elvis')
-rw-r--r--app-editors/elvis/elvis-2.1.4-r1.ebuild45
-rw-r--r--app-editors/elvis/elvis-2.1.4.ebuild41
2 files changed, 48 insertions, 38 deletions
diff --git a/app-editors/elvis/elvis-2.1.4-r1.ebuild b/app-editors/elvis/elvis-2.1.4-r1.ebuild
index b414ea067a63..b22f9b65824b 100644
--- a/app-editors/elvis/elvis-2.1.4-r1.ebuild
+++ b/app-editors/elvis/elvis-2.1.4-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.4 2002/07/11 06:30:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4-r1.ebuild,v 1.5 2002/07/25 19:10:26 kabau Exp $
S=${WORKDIR}/elvis-2.1_4
DESCRIPTION="A vi/ex clone"
@@ -8,35 +8,40 @@ SRC_URI="ftp://ftp.cs.pdx.edu/pub/${PN}/${PN}-2.1_4.tar.gz"
HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
+ >=sys-libs/ncurses-5.2
X? ( virtual/x11 )"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86"
src_compile() {
- local myconf
- if [ "`use X`" ]; then
+ local myconf
+ if [ "`use X`" ]; then
myconf="--with-x"
- else
+ else
myconf="--without-x"
- fi
- try ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf}
- cp Makefile Makefile.orig
- sed -e "s:gcc -O2:gcc ${CFLAGS}:" Makefile.orig > Makefile
- cp config.h config.h.orig
- sed -e "s:${D}/usr/share/elvis:/usr/share/elvis:" config.h.orig > config.h
- try make
+ fi
+ ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf} || die
+ cp Makefile Makefile.orig
+ sed -e "s:gcc -O2:gcc ${CFLAGS}:" Makefile.orig > Makefile
+ cp config.h config.h.orig
+ sed -e "s:${D}/usr/share/elvis:/usr/share/elvis:" config.h.orig > config.h
+ make || die
}
src_install () {
- cp instman.sh instman.sh.orig
- cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
- cp insticon.sh insticon.sh.orig
- cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
+ cp instman.sh instman.sh.orig
+ cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
+ cp insticon.sh insticon.sh.orig
+ cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
| sed -e "s:^xlib=.*$:xlib=${D}/usr/lib:" > insticon.sh
- dodir /usr/bin
- dodir /usr/share/man/man1
- try make install
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ make install || die
}
diff --git a/app-editors/elvis/elvis-2.1.4.ebuild b/app-editors/elvis/elvis-2.1.4.ebuild
index f753facb057c..a83ee283117d 100644
--- a/app-editors/elvis/elvis-2.1.4.ebuild
+++ b/app-editors/elvis/elvis-2.1.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.3 2002/07/11 06:30:11 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-editors/elvis/elvis-2.1.4.ebuild,v 1.4 2002/07/25 19:10:26 kabau Exp $
S=${WORKDIR}/elvis-2.1_4
DESCRIPTION="A vi/ex clone"
@@ -8,33 +8,38 @@ SRC_URI="ftp://ftp.cs.pdx.edu/pub/${PN}/${PN}-2.1_4.tar.gz"
HOMEPAGE="ftp://ftp.cs.pdx.edu/pub/elvis/"
DEPEND="virtual/glibc
- >=sys-libs/ncurses-5.2
+ >=sys-libs/ncurses-5.2
X? ( virtual/x11 )"
+RDEPEND=""
+
+SLOT="0"
+LICENSE="Artistic"
+KEYWORDS="x86"
src_compile() {
- local myconf
- if [ "`use X`" ]; then
+ local myconf
+ if [ "`use X`" ]; then
mconf="--with-x"
- else
+ else
mconf="--without-x"
- fi
- try ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf}
- cp Makefile Makefile.orig
- cat Makefile.orig | sed -e "s:gcc -O2:gcc ${CFLAGS}:" > Makefile
- try make
+ fi
+ ./configure --bindir=${D}/usr/bin --datadir=${D}/usr/share/elvis ${myconf} || die
+ cp Makefile Makefile.orig
+ cat Makefile.orig | sed -e "s:gcc -O2:gcc ${CFLAGS}:" > Makefile
+ make || die
}
src_install () {
- cp instman.sh instman.sh.orig
- cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
- cp insticon.sh insticon.sh.orig
- cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
+ cp instman.sh instman.sh.orig
+ cat instman.sh.orig | sed -e "s:/usr/man:${D}/usr/share/man:g" > instman.sh
+ cp insticon.sh insticon.sh.orig
+ cat insticon.sh.orig | sed -e "s:^xinc=.*$:xinc=${D}/usr/include:" \
| sed -e "s:^xlib=.*$:xlib=${D}/usr/lib:" > insticon.sh
- dodir /usr/bin
- dodir /usr/share/man/man1
- try make install
+ dodir /usr/bin
+ dodir /usr/share/man/man1
+ make install || die
}