summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-06-14 05:06:46 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-06-14 05:06:46 +0000
commit5cf2c9b9e6bcc2359bc6a6c6d38ac3d857ed8c0c (patch)
treef7fb36e3026af767ed56a88bfe5ad2d0ea9b856f /app-dicts
parentwhitespace (diff)
downloadgentoo-2-5cf2c9b9e6bcc2359bc6a6c6d38ac3d857ed8c0c.tar.gz
gentoo-2-5cf2c9b9e6bcc2359bc6a6c6d38ac3d857ed8c0c.tar.bz2
gentoo-2-5cf2c9b9e6bcc2359bc6a6c6d38ac3d857ed8c0c.zip
Fixed qt dependency, bug #217164.
Fixed to work with amd64. (Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/vdict/ChangeLog11
-rw-r--r--app-dicts/vdict/files/vdict-1.97-intptr_t.patch60
-rw-r--r--app-dicts/vdict/vdict-1.94.ebuild8
-rw-r--r--app-dicts/vdict/vdict-1.97-r1.ebuild39
-rw-r--r--app-dicts/vdict/vdict-1.97.ebuild27
5 files changed, 112 insertions, 33 deletions
diff --git a/app-dicts/vdict/ChangeLog b/app-dicts/vdict/ChangeLog
index 082fc870fb7d..dd0fe84eb472 100644
--- a/app-dicts/vdict/ChangeLog
+++ b/app-dicts/vdict/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-dicts/vdict
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/vdict/ChangeLog,v 1.4 2007/01/25 04:54:29 genone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/vdict/ChangeLog,v 1.5 2008/06/14 05:06:45 matsuu Exp $
+
+*vdict-1.97-r1 (14 Jun 2008)
+
+ 14 Jun 2008; MATSUU Takuto <matsuu@gentoo.org>
+ +files/vdict-1.97-intptr_t.patch, vdict-1.94.ebuild, -vdict-1.97.ebuild,
+ +vdict-1.97-r1.ebuild:
+ Fixed qt dependency, bug #217164. Fixed to work with amd64.
25 Jan 2007; Marius Mauch <genone@gentoo.org> vdict-1.94.ebuild,
vdict-1.97.ebuild:
diff --git a/app-dicts/vdict/files/vdict-1.97-intptr_t.patch b/app-dicts/vdict/files/vdict-1.97-intptr_t.patch
new file mode 100644
index 000000000000..acdab490ad1e
--- /dev/null
+++ b/app-dicts/vdict/files/vdict-1.97-intptr_t.patch
@@ -0,0 +1,60 @@
+diff -Naur vdict-1.97.orig/fd/fd.cpp vdict-1.97/fd/fd.cpp
+--- vdict-1.97.orig/fd/fd.cpp 2005-10-07 02:55:58.000000000 +0900
++++ vdict-1.97/fd/fd.cpp 2008-06-14 13:37:49.000000000 +0900
+@@ -97,11 +97,11 @@
+ fdMainMenu->insertSeparator();
+ for( uint i=0; i<dictList.count(); i++ ) {
+ cdict = dictList.at(i);
+- fdMainMenu->insertItem( cdict->getDescription(), (int)cdict );
++ fdMainMenu->insertItem( cdict->getDescription(), (intptr_t)cdict );
+ }
+ if( dictList.count()>0 ) {
+ cdict = dictList.at(0);
+- fdMainMenu->setItemChecked( (int)cdict, true );
++ fdMainMenu->setItemChecked( (intptr_t)cdict, true );
+ fdlookup->updateInfo();
+ }
+ fdMainMenu->insertSeparator();
+@@ -247,10 +247,10 @@
+ void FD::updateItem( int t )
+ {
+ VDictDB *d = dictList.at( t );
+- fdMainMenu->insertItem( d->getDescription(), (int)d, t+2 );
++ fdMainMenu->insertItem( d->getDescription(), (intptr_t)d, t+2 );
+ if( !cdict ) {
+ cdict = d;
+- fdMainMenu->setItemChecked( (int)d, true );
++ fdMainMenu->setItemChecked( (intptr_t)d, true );
+ }
+ }
+ /*----------------------------------------------------------------------------*/
+@@ -263,15 +263,15 @@
+ void FD::modifyItem( int t )
+ {
+ VDictDB *d = dictList.at( t );
+- fdMainMenu->changeItem( (int)d, d->getDescription() );
++ fdMainMenu->changeItem( (intptr_t)d, d->getDescription() );
+ }
+ /*----------------------------------------------------------------------------*/
+ void FD::moveItem( int t, int n )
+ {
+ VDictDB *d = dictList.at( n );
+ fdMainMenu->removeItemAt( t + 2 );
+- fdMainMenu->insertItem( d->getDescription(), (int)d, n+2 );
+- if( cdict == d ) fdMainMenu->setItemChecked( (int)d, true );
++ fdMainMenu->insertItem( d->getDescription(), (intptr_t)d, n+2 );
++ if( cdict == d ) fdMainMenu->setItemChecked( (intptr_t)d, true );
+ }
+ /*----------------------------------------------------------------------------*/
+ void FD::fdMainMenuClicked( int id )
+@@ -291,8 +291,8 @@
+ break;
+ default:
+ if( id>=0 && cdict!=(VDictDB *)id ) {
+- fdMainMenu->setItemChecked( (int)cdict, false );
+- fdMainMenu->setItemChecked( (int)(cdict = (VDictDB *)id), true );
++ fdMainMenu->setItemChecked( (intptr_t)cdict, false );
++ fdMainMenu->setItemChecked( (intptr_t)(cdict = (VDictDB *)id), true );
+ }
+ break;
+ }
diff --git a/app-dicts/vdict/vdict-1.94.ebuild b/app-dicts/vdict/vdict-1.94.ebuild
index 6bde6d7b5ea8..806515148481 100644
--- a/app-dicts/vdict/vdict-1.94.ebuild
+++ b/app-dicts/vdict/vdict-1.94.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/vdict/vdict-1.94.ebuild,v 1.4 2007/01/25 04:54:29 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/vdict/vdict-1.94.ebuild,v 1.5 2008/06/14 05:06:45 matsuu Exp $
-inherit eutils
+inherit eutils qt3
SLOT="0"
LICENSE="GPL-2"
@@ -11,7 +11,7 @@ DESCRIPTION="Vdict - Vietnamese Dictionary"
SRC_URI="mirror://sourceforge/xvnkb/${P}.tar.bz2"
HOMEPAGE="http://xvnkb.sourceforge.net/?menu=vdict&lang=en"
IUSE=""
-DEPEND="x11-libs/qt
+DEPEND="$(qt_min_version 3)
sys-libs/gdbm
media-libs/freetype"
diff --git a/app-dicts/vdict/vdict-1.97-r1.ebuild b/app-dicts/vdict/vdict-1.97-r1.ebuild
new file mode 100644
index 000000000000..40415e5c3d03
--- /dev/null
+++ b/app-dicts/vdict/vdict-1.97-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-dicts/vdict/vdict-1.97-r1.ebuild,v 1.1 2008/06/14 05:06:45 matsuu Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="Vdict - Vietnamese Dictionary"
+SRC_URI="http://xvnkb.sourceforge.net/vdict/${P}.tar.bz2"
+HOMEPAGE="http://xvnkb.sourceforge.net/?menu=vdict&lang=en"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="$(qt_min_version 3)
+ sys-libs/gdbm
+ media-libs/freetype"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-intptr_t.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CPP="$(tc-getCC) -E" CXX="$(tc-getCXX)" CXXPP="$(tc-getCC) -E" || die
+}
+
+src_install() {
+ dobin fd/fd vd/vd utils/wd2vd
+
+ dodoc AUTHORS BUGS ChangeLog README TODO
+}
+
+pkg_postinst() {
+ elog "You may want to install app-dicts/vdict-* packages"
+ elog "to have corresponding dictionaries"
+}
diff --git a/app-dicts/vdict/vdict-1.97.ebuild b/app-dicts/vdict/vdict-1.97.ebuild
deleted file mode 100644
index f40aa63c63c5..000000000000
--- a/app-dicts/vdict/vdict-1.97.ebuild
+++ /dev/null
@@ -1,27 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-dicts/vdict/vdict-1.97.ebuild,v 1.2 2007/01/25 04:54:29 genone Exp $
-
-inherit eutils
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~x86"
-DESCRIPTION="Vdict - Vietnamese Dictionary"
-SRC_URI="http://xvnkb.sourceforge.net/vdict/${P}.tar.bz2
- mirror://gentoo/${PN}-patches-${PV}.tar.bz2"
-# http://dev.gentoo.org/~pclouds/${PN}-patches-${PV}.tar.bz2"
-HOMEPAGE="http://xvnkb.sourceforge.net/?menu=vdict&lang=en"
-IUSE=""
-DEPEND="x11-libs/qt
- sys-libs/gdbm
- media-libs/freetype"
-
-src_install() {
- dobin fd/fd vd/vd utils/wd2vd
-}
-
-pkg_postinst() {
- elog "You may want to install app-dicts/vdict-* packages"
- elog "to have corresponding dictionaries"
-}