summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Mende <angelos@gentoo.org>2008-12-30 18:12:29 +0000
committerChristoph Mende <angelos@gentoo.org>2008-12-30 18:12:29 +0000
commitd1c5127c93bb6c0a330bdc4d83e36ea666435eb9 (patch)
treebcac28a18d2922011f759f849fe250a3f3d1129a /app-crypt
parentRespect compiler and cflags as per bug #241062 (diff)
downloadgentoo-2-d1c5127c93bb6c0a330bdc4d83e36ea666435eb9.tar.gz
gentoo-2-d1c5127c93bb6c0a330bdc4d83e36ea666435eb9.tar.bz2
gentoo-2-d1c5127c93bb6c0a330bdc4d83e36ea666435eb9.zip
QA: Respect CFLAGS and AR/CC/RANLIB
(Portage version: 2.2_rc20/cvs/Linux 2.6.28 x86_64)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/keynote/ChangeLog7
-rw-r--r--app-crypt/keynote/keynote-2.3.ebuild20
2 files changed, 20 insertions, 7 deletions
diff --git a/app-crypt/keynote/ChangeLog b/app-crypt/keynote/ChangeLog
index 77dae372c4a0..2f3f25cf1dce 100644
--- a/app-crypt/keynote/ChangeLog
+++ b/app-crypt/keynote/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-crypt/keynote
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.8 2007/05/13 18:05:41 bangert Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/ChangeLog,v 1.9 2008/12/30 18:12:29 angelos Exp $
+
+ 30 Dec 2008; Christoph Mende <angelos@gentoo.org> keynote-2.3.ebuild:
+ QA: Respect CFLAGS and AR/CC/RANLIB
13 May 2007; Thilo Bangert <bangert@gentoo.org> metadata.xml:
add herd
diff --git a/app-crypt/keynote/keynote-2.3.ebuild b/app-crypt/keynote/keynote-2.3.ebuild
index 38bdc2b80a44..0385013603e3 100644
--- a/app-crypt/keynote/keynote-2.3.ebuild
+++ b/app-crypt/keynote/keynote-2.3.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3.ebuild,v 1.8 2005/08/19 04:01:54 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/keynote/keynote-2.3.ebuild,v 1.9 2008/12/30 18:12:29 angelos Exp $
+
+inherit toolchain-funcs
DESCRIPTION="The KeyNote Trust-Management System"
HOMEPAGE="http://www1.cs.columbia.edu/~angelos/keynote.html"
@@ -11,11 +13,19 @@ SLOT="0"
KEYWORDS="~amd64 x86"
IUSE="ssl"
-DEPEND="virtual/libc
- ssl? ( dev-libs/openssl )"
+DEPEND="ssl? ( dev-libs/openssl )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "/^CFLAGS/s/-O2/${CFLAGS}/" \
+ -e "/^AR/d" Makefile.in || "sed failed"
+}
src_compile() {
- econf || die
+ tc-export AR CC RANLIB
+ econf
if use ssl; then
make || die
else