summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2008-06-07 22:08:50 +0000
committerSven Wegener <swegener@gentoo.org>2008-06-07 22:08:50 +0000
commit9c983280a3661d75720f75ad46f65a1d0c14239b (patch)
treefe2cc5effb40465c1b11816b049a8be691786283 /app-crypt
parentold (diff)
downloadgentoo-2-9c983280a3661d75720f75ad46f65a1d0c14239b.tar.gz
gentoo-2-9c983280a3661d75720f75ad46f65a1d0c14239b.tar.bz2
gentoo-2-9c983280a3661d75720f75ad46f65a1d0c14239b.zip
Add patch to fix -c with binary files, bug #182417.
(Portage version: 2.1.5.4)
Diffstat (limited to 'app-crypt')
-rw-r--r--app-crypt/shash/ChangeLog6
-rw-r--r--app-crypt/shash/files/shash-0.2.6-binary-files.patch34
-rw-r--r--app-crypt/shash/shash-0.2.6-r1.ebuild6
3 files changed, 43 insertions, 3 deletions
diff --git a/app-crypt/shash/ChangeLog b/app-crypt/shash/ChangeLog
index 0daadbd83fee..d74c973cc6db 100644
--- a/app-crypt/shash/ChangeLog
+++ b/app-crypt/shash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-crypt/shash
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/ChangeLog,v 1.21 2008/02/04 18:42:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/ChangeLog,v 1.22 2008/06/07 22:08:49 swegener Exp $
+
+ 07 Jun 2008; Sven Wegener <swegener@gentoo.org>
+ +files/shash-0.2.6-binary-files.patch, shash-0.2.6-r1.ebuild:
+ Add patch to fix -c with binary files, bug #182417.
04 Feb 2008; Fabian Groffen <grobian@gentoo.org> shash-0.2.6-r1.ebuild:
Dropped ppc-macos keyword, see you in prefix
diff --git a/app-crypt/shash/files/shash-0.2.6-binary-files.patch b/app-crypt/shash/files/shash-0.2.6-binary-files.patch
new file mode 100644
index 000000000000..1eb0cba17613
--- /dev/null
+++ b/app-crypt/shash/files/shash-0.2.6-binary-files.patch
@@ -0,0 +1,34 @@
+--- shash-0.2.6/src/shash.c
++++ shash-0.2.6/src/shash.c
+@@ -631,11 +631,11 @@
+
+ if (nosalt == FALSE && hmac == 1) {
+ if (sscanf
+- (linebuf, "%s %s %s\n", hexbuffer, buffer,
+- buffer2) < 2) {
++ (linebuf, "%s %s *%s\n", hexbuffer, buffer,
++ buffer2) != 3) {
+ if (sscanf
+- (linebuf, "%s %s *%s\n", hexbuffer,
+- buffer, buffer2) < 2)
++ (linebuf, "%s %s %s\n", hexbuffer,
++ buffer, buffer2) != 3)
+ continue;
+ }
+
+@@ -648,11 +648,11 @@
+ key = pass2key(algorithm, keymode_buffer, &keylen, password, plen);
+
+ } else {
+- if (sscanf(linebuf, "%s %s\n", buffer, buffer2) ==
+- 0) {
++ if (sscanf(linebuf, "%s *%s\n", buffer, buffer2) !=
++ 2) {
+ if (sscanf
+- (linebuf, "%s *%s\n", buffer,
+- buffer2) == 0)
++ (linebuf, "%s %s\n", buffer,
++ buffer2) != 2)
+ continue;
+ }
+
diff --git a/app-crypt/shash/shash-0.2.6-r1.ebuild b/app-crypt/shash/shash-0.2.6-r1.ebuild
index dda5694b11f2..259edb84a120 100644
--- a/app-crypt/shash/shash-0.2.6-r1.ebuild
+++ b/app-crypt/shash/shash-0.2.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/shash-0.2.6-r1.ebuild,v 1.20 2008/02/04 18:42:21 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/shash/shash-0.2.6-r1.ebuild,v 1.21 2008/06/07 22:08:49 swegener Exp $
inherit bash-completion eutils
@@ -19,7 +19,9 @@ RDEPEND="${DEPEND}"
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/0.2.6-manpage-fixes.patch
+
+ epatch "${FILESDIR}"/${PV}-manpage-fixes.patch
+ epatch "${FILESDIR}"/${P}-binary-files.patch
}
src_compile() {