summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKristian Fiskerstrand <k_f@gentoo.org>2014-07-31 10:00:31 +0000
committerKristian Fiskerstrand <k_f@gentoo.org>2014-07-31 10:00:31 +0000
commitf478a4183c88dc5b7601e8507bbccf7384735581 (patch)
tree4c74c0a30795cb8649087e95de301ae7a02911de /app-crypt/gpgme/gpgme-1.4.4.ebuild
parentalpha stable wrt bug #517504 (diff)
downloadgentoo-2-f478a4183c88dc5b7601e8507bbccf7384735581.tar.gz
gentoo-2-f478a4183c88dc5b7601e8507bbccf7384735581.tar.bz2
gentoo-2-f478a4183c88dc5b7601e8507bbccf7384735581.zip
Version bump to 1.4.4 and 1.5.1 due to security bug #518646 (CVE-2014-3564)
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0xFC3B17DE05E136A0!)
Diffstat (limited to 'app-crypt/gpgme/gpgme-1.4.4.ebuild')
-rw-r--r--app-crypt/gpgme/gpgme-1.4.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/app-crypt/gpgme/gpgme-1.4.4.ebuild b/app-crypt/gpgme/gpgme-1.4.4.ebuild
new file mode 100644
index 000000000000..291861afb231
--- /dev/null
+++ b/app-crypt/gpgme/gpgme-1.4.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-crypt/gpgme/gpgme-1.4.4.ebuild,v 1.1 2014/07/31 10:00:31 k_f Exp $
+
+EAPI="5"
+
+inherit eutils libtool
+
+DESCRIPTION="GnuPG Made Easy is a library for making GnuPG easier to use"
+HOMEPAGE="http://www.gnupg.org/related_software/gpgme"
+SRC_URI="mirror://gnupg/gpgme/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="1/11" # subslot = soname major version
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="common-lisp static-libs"
+
+DEPEND="app-crypt/gnupg
+ >=dev-libs/libassuan-2.0.2
+ >=dev-libs/libgpg-error-1.4"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1.8-et_EE.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --includedir="${EPREFIX}/usr/include/gpgme" \
+ --with-gpg="$(readlink -f "${EPREFIX}/usr/bin/gpg")" \
+ --with-gpgsm="${EPREFIX}/usr/bin/gpgsm" \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ prune_libtool_files
+
+ if ! use common-lisp; then
+ rm -fr "${ED}usr/share/common-lisp"
+ fi
+}