summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Savchenko <bircoph@gentoo.org>2015-01-10 06:01:22 +0000
committerAndrew Savchenko <bircoph@gentoo.org>2015-01-10 06:01:22 +0000
commit6aef2c14d82c011c4aea23fd4c8c746524ca6390 (patch)
tree0f4d34f8a95b3521a4b64ecb70561a7789568760 /app-cdr
parentVersion bump. (diff)
downloadgentoo-2-6aef2c14d82c011c4aea23fd4c8c746524ca6390.tar.gz
gentoo-2-6aef2c14d82c011c4aea23fd4c8c746524ca6390.tar.bz2
gentoo-2-6aef2c14d82c011c4aea23fd4c8c746524ca6390.zip
Fix bug 286297
Signed-off-by: Andrew Savchenko <bircoph@gentoo.org> (Portage version: 2.2.15/cvs/Linux i686, signed Manifest commit with key 565953B95372756C)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/xbiso/ChangeLog10
-rw-r--r--app-cdr/xbiso/files/xbiso-0.6.1-libs.patch21
-rw-r--r--app-cdr/xbiso/xbiso-0.6.1-r2.ebuild38
3 files changed, 67 insertions, 2 deletions
diff --git a/app-cdr/xbiso/ChangeLog b/app-cdr/xbiso/ChangeLog
index 6b91f22c0ddb..4b4c42ae3e09 100644
--- a/app-cdr/xbiso/ChangeLog
+++ b/app-cdr/xbiso/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/xbiso
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/xbiso/ChangeLog,v 1.18 2011/12/22 18:30:40 ssuominen Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xbiso/ChangeLog,v 1.19 2015/01/10 06:01:22 bircoph Exp $
+
+*xbiso-0.6.1-r2 (10 Jan 2015)
+
+ 10 Jan 2015; Andrew Savchenko <bircoph@gentoo.org> +xbiso-0.6.1-r2.ebuild,
+ +files/xbiso-0.6.1-libs.patch:
+ Fix bug 286297: unbundle ftplib, set proper dependency.
*xbiso-0.6.1-r1 (22 Dec 2011)
diff --git a/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch b/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
new file mode 100644
index 000000000000..5b48ba674230
--- /dev/null
+++ b/app-cdr/xbiso/files/xbiso-0.6.1-libs.patch
@@ -0,0 +1,21 @@
+--- configure.in.orig 2014-12-02 18:56:23.000000000 +0300
++++ configure.in 2014-12-02 19:09:46.724190436 +0300
+@@ -6,13 +6,13 @@
+
+ dnl Checks for libraries.
+ dnl Replace `main' with a function in -lftp:
+-AC_CHECK_LIB(ftp, main,[LIBS="-DUSE_FTP -lftp"],AC_MSG_WARN([Warning libftp not found ftp features disabled]))
+ AC_CHECK_LIB(m, ceil,[LIBS="$LIBS -lm"],AC_MSG_ERROR([Error mlib is required]))
+-AC_ARG_ENABLE(ftp,
+-[
++AC_ARG_ENABLE([ftp],
++ AS_HELP_STRING([--disable-ftp],[Disables all ftp features and libftp dependencies]))
+
+- --disable-ftp Disables all ftp features and libftp dependencies
+-],[LIBS=""])
++AS_IF([test "x$enable_ftp" != "xno"], [
++ AC_SEARCH_LIBS([FtpInit],[ftp],[CPPFLAGS+="-DUSE_FTP"],AC_MSG_ERROR([libftp not found]))
++])
+
+ dnl Checks for header files.
+ AC_CONFIG_HEADERS([config.h:config.h.in])
diff --git a/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild b/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..8cca0f593471
--- /dev/null
+++ b/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/xbiso/xbiso-0.6.1-r2.ebuild,v 1.1 2015/01/10 06:01:22 bircoph Exp $
+
+EAPI=5
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Xbox xdvdfs ISO extraction utility"
+HOMEPAGE="http://sourceforge.net/projects/xbiso/"
+SRC_URI="mirror://sourceforge/xbiso/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="ftp"
+
+RDEPEND="ftp? ( <net-libs/ftplib-4 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's:C) $(CFLAGS):C) $(LDFLAGS) $(CFLAGS):' Makefile.in || die #337769
+ epatch "${FILESDIR}/${P}-libs.patch"
+ mv configure.in configure.ac || die #426262
+ eautoreconf
+}
+
+src_configure() {
+ # for this package, interix behaves the same as BSD
+ [[ ${CHOST} == *-interix* ]] && append-flags -D_BSD
+
+ econf \
+ $(use_enable ftp)
+}
+
+src_install() {
+ dobin xbiso
+ dodoc CHANGELOG README
+}