summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-12-18 22:40:13 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-12-18 22:40:13 +0000
commit86e73a54cedb37c2e41eebf82ce5b8b12e23e318 (patch)
tree236c7347e1ce085c2ef590f0eefbd489e2fa801f /app-backup
parentgames goes last on the inherit line (diff)
downloadgentoo-2-86e73a54cedb37c2e41eebf82ce5b8b12e23e318.tar.gz
gentoo-2-86e73a54cedb37c2e41eebf82ce5b8b12e23e318.tar.bz2
gentoo-2-86e73a54cedb37c2e41eebf82ce5b8b12e23e318.zip
Fix bug 226867, gcc43 compilation. Punt old. Thanks to mikko.tiihonen@iki.fi for gcc fix.
(Portage version: 2.2_rc17/cvs/Linux 2.6.28-rc6 x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/boxbackup/ChangeLog9
-rw-r--r--app-backup/boxbackup/boxbackup-0.09-r1.ebuild80
-rw-r--r--app-backup/boxbackup/boxbackup-0.10.ebuild3
-rw-r--r--app-backup/boxbackup/files/boxbackup-0.09-darwin.patch11
-rw-r--r--app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch161
-rw-r--r--app-backup/boxbackup/files/boxbackup-0.10-gcc43.patch177
6 files changed, 187 insertions, 254 deletions
diff --git a/app-backup/boxbackup/ChangeLog b/app-backup/boxbackup/ChangeLog
index 0952f32f9450..8f5a7d37afdb 100644
--- a/app-backup/boxbackup/ChangeLog
+++ b/app-backup/boxbackup/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-backup/boxbackup
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/ChangeLog,v 1.15 2008/07/23 21:40:44 cardoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/ChangeLog,v 1.16 2008/12/18 22:40:13 loki_val Exp $
+
+ 18 Dec 2008; Peter Alfredsen <loki_val@gentoo.org>
+ -files/boxbackup-0.09-darwin.patch, -files/boxbackup-0.09-gentoo.patch,
+ +files/boxbackup-0.10-gcc43.patch, -boxbackup-0.09-r1.ebuild,
+ boxbackup-0.10.ebuild:
+ Fix 226867, gcc43 compilation. Punt old. Thanks to mikko.tiihonen@iki.fi
+ for gcc fix.
23 Jul 2008; Doug Goldstein <cardoe@gentoo.org> metadata.xml:
add GLEP 56 USE flag desc from use.local.desc
diff --git a/app-backup/boxbackup/boxbackup-0.09-r1.ebuild b/app-backup/boxbackup/boxbackup-0.09-r1.ebuild
deleted file mode 100644
index b113b02a5239..000000000000
--- a/app-backup/boxbackup/boxbackup-0.09-r1.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/boxbackup-0.09-r1.ebuild,v 1.6 2008/01/25 19:47:13 grobian Exp $
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="A completely automatic on-line backup system"
-HOMEPAGE="http://www.fluffy.co.uk/boxbackup/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tgz
- mirror://gentoo/${P}-solaris.patch.bz2"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="x86"
-IUSE="client-only"
-DEPEND="sys-libs/zlib
- sys-libs/db
- >=dev-libs/openssl-0.9.7
- >=dev-lang/perl-5.6"
-RDEPEND="${DEPEND}
- virtual/mta"
-
-src_unpack() {
- unpack ${A}
-
- epatch "${DISTDIR}/${P}"-solaris.patch.bz2
- epatch "${FILESDIR}/${P}"-darwin.patch
- epatch "${FILESDIR}/${P}"-gentoo.patch
-}
-
-src_compile() {
- # note, we can't use econf here, because configure is a wrapper
- # around a perl script, not the configure you would normally
- # expect!!!
- local myconf=""
- # GCC4 hack, see
- # http://lists.warhead.org.uk/pipermail/boxbackup/2005-August/001625.html
- [ "$(gcc-major-version)" -eq "4" ] && myconf="compile:-DPLATFORM_GCC3"
- ./configure ${myconf} || die
- make || die
-}
-
-src_install() {
- # For the same reason why we can't use econf and emake, we can't do
- # make install here either, because the installation is some lame
- # script.
-
- # create directories the installscript assumes to exist
- mkdir -p ${D}/usr/sbin
- make DESTDIR=${D} install || die "install failed"
- make DESTDIR=${D} install-backup-client || die "client install failed"
- use client-only || \
- make DESTDIR=${D} install-backup-server || die "server install failed"
-
- dodoc *.txt
- newinitd ${FILESDIR}/bbackupd.rc bbackupd
- use client-only || \
- newinitd ${FILESDIR}/bbstored.rc bbstored
-
- keepdir /etc/boxbackup
-}
-
-pkg_preinst() {
- if ! use client-only;
- then
- enewgroup bbstored
- enewuser bbstored -1 -1 -1 bbstored
- fi
-}
-
-pkg_postinst() {
- while read line; do elog "${line}"; done <<EOF
-After configuring the boxbackup client and/or server, you can start
-the boxbackup daemons using the init scripts /etc/init.d/bbackupd
-and /etc/init.d/bbstored.
-More information about configuring the client can be found at
-${HOMEPAGE}client.html,
-and more information about configuring the server can be found at
-${HOMEPAGE}server.html.
-EOF
-}
diff --git a/app-backup/boxbackup/boxbackup-0.10.ebuild b/app-backup/boxbackup/boxbackup-0.10.ebuild
index fd2adf80c826..438ecd0741e9 100644
--- a/app-backup/boxbackup/boxbackup-0.10.ebuild
+++ b/app-backup/boxbackup/boxbackup-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/boxbackup-0.10.ebuild,v 1.10 2008/06/04 16:56:43 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/boxbackup/boxbackup-0.10.ebuild,v 1.11 2008/12/18 22:40:13 loki_val Exp $
inherit eutils autotools
@@ -23,6 +23,7 @@ src_unpack() {
epatch "${FILESDIR}/${P}"-gentoo.patch
epatch "${FILESDIR}/${P}"-gcc41-noll.patch
+ epatch "${FILESDIR}/${P}"-gcc43.patch
cd "${S}"
AT_M4DIR="infrastructure/m4" eautoreconf
diff --git a/app-backup/boxbackup/files/boxbackup-0.09-darwin.patch b/app-backup/boxbackup/files/boxbackup-0.09-darwin.patch
deleted file mode 100644
index c9232e85f62c..000000000000
--- a/app-backup/boxbackup/files/boxbackup-0.09-darwin.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Naur boxbackup-0.09-orig/lib/common/BoxPlatform.h boxbackup-0.09/lib/common/BoxPlatform.h
---- boxbackup-0.09-orig/lib/common/BoxPlatform.h 2005-08-09 19:51:44.000000000 +0200
-+++ boxbackup-0.09/lib/common/BoxPlatform.h 2005-08-09 19:51:57.000000000 +0200
-@@ -117,7 +117,6 @@
- #include <sys/types.h>
-
- // types 'missing'
-- typedef int socklen_t;
- typedef u_int8_t uint8_t;
- typedef signed char int8_t;
- typedef u_int64_t uint64_t;
diff --git a/app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch b/app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch
deleted file mode 100644
index 04c9b2f468c5..000000000000
--- a/app-backup/boxbackup/files/boxbackup-0.09-gentoo.patch
+++ /dev/null
@@ -1,161 +0,0 @@
-diff -ruN boxbackup-0.09.orig/bin/bbackupd/bbackupd-config boxbackup-0.09/bin/bbackupd/bbackupd-config
---- boxbackup-0.09.orig/bin/bbackupd/bbackupd-config 2005-04-18 15:11:17.603115864 +0600
-+++ boxbackup-0.09/bin/bbackupd/bbackupd-config 2005-04-18 17:39:43.795168872 +0600
-@@ -56,7 +56,7 @@
- Usage:
- bbackupd-config config-dir backup-mode account-num server-hostname working-dir backup-dir [more backup directories]
-
--config-dir usually /etc/box
-+config-dir usually /etc/boxbackup
- backup-mode is lazy or snapshot
- lazy mode runs continously, uploading files over a specified age
- snapshot mode uploads a snapshot of the filesystem when instructed explicitly
-@@ -92,7 +92,7 @@
- }
-
- # default locations
--my $default_config_location = '/etc/box/bbackupd.conf';
-+my $default_config_location = '/etc/boxbackup/bbackupd.conf';
-
- # command line parameters
- my ($config_dir,$backup_mode,$account_num,$server,$working_dir,@tobackup) = @ARGV;
-@@ -540,7 +540,7 @@
- more files will be backed up. You want to know about this.
-
- 6) Start the backup daemon with the command
-- /usr/local/bin/bbackupd$daemon_args
-+ /usr/sbin/bbackupd$daemon_args
- in /etc/rc.local, or your local equivalent.
- Note that bbackupd must run as root.
- __E
-@@ -550,7 +550,7 @@
-
- 7) Set up a cron job to run whenever you want a snapshot of the
- file system to be taken. Run the command
-- /usr/local/bin/bbackupctl -q$ctl_daemon_args sync
-+ /usr/sbin/bbackupctl -q$ctl_daemon_args sync
- __E
- }
- print <<__E;
-diff -ruN boxbackup-0.09.orig/bin/bbstored/bbstored-config boxbackup-0.09/bin/bbstored/bbstored-config
---- boxbackup-0.09.orig/bin/bbstored/bbstored-config 2005-04-18 15:11:17.600116320 +0600
-+++ boxbackup-0.09/bin/bbstored/bbstored-config 2005-04-18 17:40:00.205674096 +0600
-@@ -57,7 +57,7 @@
- Usage:
- bbstored-config config-dir server-hostname username [raidfile-config]
-
--config-dir usually /etc/box
-+config-dir usually /etc/boxbackup
- server-hostname is the hostname used by clients to connect to this server
- username is the user to run the server under
- raidfile-config is optional. Use if you have a non-standard raidfile.conf file.
-@@ -83,7 +83,7 @@
- }
-
- # default locations
--my $default_config_location = '/etc/box/bbstored.conf';
-+my $default_config_location = '/etc/boxbackup/bbstored.conf';
-
- # command line parameters
- my ($config_dir,$server,$username,$raidfile_config) = @ARGV;
-@@ -270,7 +270,7 @@
- 4) Create accounts with bbstoreaccounts
-
- 5) Start the backup store daemon with the command
-- /usr/local/bin/bbstored$daemon_args
-+ /usr/sbin/bbstored$daemon_args
- in /etc/rc.local, or your local equivalent.
-
- ===================================================================
-diff -ruN boxbackup-0.09.orig/infrastructure/BoxPlatform.pm boxbackup-0.09/infrastructure/BoxPlatform.pm
---- boxbackup-0.09.orig/infrastructure/BoxPlatform.pm 2005-04-18 15:11:17.581119208 +0600
-+++ boxbackup-0.09/infrastructure/BoxPlatform.pm 2005-04-18 16:35:27.793370248 +0600
-@@ -78,7 +78,7 @@
- close VERSION;
-
- # where to put the files
-- $install_into_dir = '/usr/local/bin';
-+ $install_into_dir = '$1/usr/sbin';
-
- # if it's Darwin,
- if($build_os eq 'Darwin')
-diff -ruN boxbackup-0.09.orig/infrastructure/makeparcels.pl boxbackup-0.09/infrastructure/makeparcels.pl
---- boxbackup-0.09.orig/infrastructure/makeparcels.pl 2005-04-18 15:11:17.581119208 +0600
-+++ boxbackup-0.09/infrastructure/makeparcels.pl 2005-04-18 17:52:15.451899680 +0600
-@@ -139,11 +139,11 @@
- {
- my $exeext = ($build_os eq 'CYGWIN')?'.exe':'';
- print MAKE "\t(cd bin/$name; $make_command $release_flag)\n";
-- print MAKE "\tcp release/bin/$name/$name$exeext $dir\n";
-+ print MAKE "\tcp -R release/bin/$name/$name$exeext $dir/\n";
- }
- elsif ($type eq 'script')
- {
-- print MAKE "\tcp $name $dir\n";
-+ print MAKE "\tcp $name $dir/\n";
- # remove path from script name
- $name =~ m~/([^/]+)\Z~;
- $name = $1;
-@@ -157,13 +157,13 @@
- chmod 0755,"parcels/scripts/install-$parcel";
-
- my $root = parcel_root($parcel);
-- print MAKE "\tcp parcels/scripts/install-$parcel $dir\n";
-+ print MAKE "\tcp parcels/scripts/install-$parcel $dir/\n";
- print MAKE "\t(cd parcels; tar cf - $root | gzip -9 - > $root.tgz )\n";
-
- print MAKE "\n";
-
- print MAKE "install-$parcel:\n";
-- print MAKE "\t(cd $dir; ./install-$parcel)\n\n";
-+ print MAKE "\t(cd $dir; ./install-$parcel \$(DESTDIR) )\n\n";
- }
-
- print MAKE <<__E;
-diff -ruN boxbackup-0.09.orig/lib/common/BoxPortsAndFiles.h boxbackup-0.09/lib/common/BoxPortsAndFiles.h
---- boxbackup-0.09.orig/lib/common/BoxPortsAndFiles.h 2005-04-18 15:11:17.345155080 +0600
-+++ boxbackup-0.09/lib/common/BoxPortsAndFiles.h 2005-04-18 17:40:43.200137944 +0600
-@@ -54,16 +54,16 @@
-
- // Backup store daemon
- #define BOX_PORT_BBSTORED (BOX_PORT_BASE+1)
--#define BOX_FILE_BBSTORED_DEFAULT_CONFIG "/etc/box/bbstored.conf"
-+#define BOX_FILE_BBSTORED_DEFAULT_CONFIG "/etc/boxbackup/bbstored.conf"
- // directory within the RAIDFILE root for the backup store daemon
- #define BOX_RAIDFILE_ROOT_BBSTORED "backup"
-
- // Backup client daemon
--#define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "/etc/box/bbackupd.conf"
-+#define BOX_FILE_BBACKUPD_DEFAULT_CONFIG "/etc/boxbackup/bbackupd.conf"
-
-
- // RaidFile conf location efault
--#define BOX_FILE_RAIDFILE_DEFAULT_CONFIG "/etc/box/raidfile.conf"
-+#define BOX_FILE_RAIDFILE_DEFAULT_CONFIG "/etc/boxbackup/raidfile.conf"
-
-
- #endif // BOXPORTSANDFILES__H
-diff -ruN boxbackup-0.09.orig/lib/raidfile/raidfile-config boxbackup-0.09/lib/raidfile/raidfile-config
---- boxbackup-0.09.orig/lib/raidfile/raidfile-config 2005-04-18 15:11:17.450139120 +0600
-+++ boxbackup-0.09/lib/raidfile/raidfile-config 2005-04-18 17:40:30.723034752 +0600
-@@ -57,7 +57,7 @@
- Usage:
- raidfile-config config-dir block-size dir0 [dir1 dir2]
-
--config-dir usually /etc/box
-+config-dir usually /etc/boxbackup
- block-size must be a power of two, and usually the block or fragment size of your filing system
- dir0, dir1, dir2 are the directories used as the root of the raid file system
-
-diff -ruN boxbackup-0.09.orig/lib/raidfile/RaidFileController.h boxbackup-0.09/lib/raidfile/RaidFileController.h
---- boxbackup-0.09.orig/lib/raidfile/RaidFileController.h 2005-04-18 15:11:17.435141400 +0600
-+++ boxbackup-0.09/lib/raidfile/RaidFileController.h 2005-04-18 17:40:20.070654160 +0600
-@@ -120,7 +120,7 @@
- ~RaidFileController();
-
- public:
-- void Initialise(const char *ConfigFilename = "/etc/box/raidfile.conf");
-+ void Initialise(const char *ConfigFilename = "/etc/boxbackup/raidfile.conf");
- int GetNumDiscSets() {return mSetList.size();}
-
- // --------------------------------------------------------------------------
diff --git a/app-backup/boxbackup/files/boxbackup-0.10-gcc43.patch b/app-backup/boxbackup/files/boxbackup-0.10-gcc43.patch
new file mode 100644
index 000000000000..3b4566434ee8
--- /dev/null
+++ b/app-backup/boxbackup/files/boxbackup-0.10-gcc43.patch
@@ -0,0 +1,177 @@
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/bin/bbackupctl/bbackupctl.cpp boxbackup-0.10/bin/bbackupctl/bbackupctl.cpp
+--- boxbackup-0.10,bak/bin/bbackupctl/bbackupctl.cpp 2006-02-23 22:47:38.000000000 +0200
++++ boxbackup-0.10/bin/bbackupctl/bbackupctl.cpp 2008-07-20 18:59:40.000000000 +0300
+@@ -48,6 +48,7 @@
+ #include "Box.h"
+
+ #include <stdio.h>
++#include <stdlib.h>
+
+ #ifdef HAVE_UNISTD_H
+ #include <unistd.h>
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/bin/bbackupquery/bbackupquery.cpp boxbackup-0.10/bin/bbackupquery/bbackupquery.cpp
+--- boxbackup-0.10,bak/bin/bbackupquery/bbackupquery.cpp 2006-02-23 22:47:38.000000000 +0200
++++ boxbackup-0.10/bin/bbackupquery/bbackupquery.cpp 2008-07-20 18:59:12.000000000 +0300
+@@ -51,6 +51,7 @@
+ #include <unistd.h>
+ #endif
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <sys/types.h>
+ #ifdef HAVE_LIBREADLINE
+ #ifdef HAVE_READLINE_READLINE_H
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/bin/bbstoreaccounts/bbstoreaccounts.cpp boxbackup-0.10/bin/bbstoreaccounts/bbstoreaccounts.cpp
+--- boxbackup-0.10,bak/bin/bbstoreaccounts/bbstoreaccounts.cpp 2006-02-23 22:47:37.000000000 +0200
++++ boxbackup-0.10/bin/bbstoreaccounts/bbstoreaccounts.cpp 2008-07-20 19:01:21.000000000 +0300
+@@ -51,6 +51,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+ #include <limits.h>
++#include <string.h>
+ #include <vector>
+ #include <algorithm>
+
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/backupclient/BackupClientFileAttributes.cpp boxbackup-0.10/lib/backupclient/BackupClientFileAttributes.cpp
+--- boxbackup-0.10,bak/lib/backupclient/BackupClientFileAttributes.cpp 2006-02-23 22:47:37.000000000 +0200
++++ boxbackup-0.10/lib/backupclient/BackupClientFileAttributes.cpp 2008-07-20 18:58:27.000000000 +0300
+@@ -481,7 +481,7 @@
+ char* buffer = static_cast<char*>(outputBlock.GetBuffer());
+
+ // Add the path name for the symbolic link, and add 0 termination
+- std::memcpy(buffer+oldSize, linkedTo, linkedToSize);
++ ::memcpy(buffer+oldSize, linkedTo, linkedToSize);
+ buffer[oldSize+linkedToSize] = '\0';
+ }
+ #endif
+@@ -549,9 +549,9 @@
+
+ // Store length and text for attibute name
+ u_int16_t keyLength = htons(attrKey.size()+1);
+- std::memcpy(buffer+xattrSize, &keyLength, sizeof(u_int16_t));
++ ::memcpy(buffer+xattrSize, &keyLength, sizeof(u_int16_t));
+ xattrSize += sizeof(u_int16_t);
+- std::memcpy(buffer+xattrSize, attrKey.c_str(), attrKey.size()+1);
++ ::memcpy(buffer+xattrSize, attrKey.c_str(), attrKey.size()+1);
+ xattrSize += attrKey.size()+1;
+
+ // Leave space for value size
+@@ -584,12 +584,12 @@
+
+ // Fill in value size
+ u_int32_t valueLength = htonl(valueSize);
+- std::memcpy(buffer+valueSizeOffset, &valueLength, sizeof(u_int32_t));
++ ::memcpy(buffer+valueSizeOffset, &valueLength, sizeof(u_int32_t));
+ }
+
+ // Fill in attribute block size
+ u_int32_t xattrBlockLength = htonl(xattrSize-xattrBlockSizeOffset-sizeof(u_int32_t));
+- std::memcpy(buffer+xattrBlockSizeOffset, &xattrBlockLength, sizeof(u_int32_t));
++ ::memcpy(buffer+xattrBlockSizeOffset, &xattrBlockLength, sizeof(u_int32_t));
+
+ outputBlock.ResizeBlock(xattrSize);
+ }
+@@ -676,7 +676,7 @@
+ }
+ #endif
+
+- xattrOffset += std::strlen(reinterpret_cast<char*>(pattr+1))+1;
++ xattrOffset += ::strlen(reinterpret_cast<char*>(pattr+1))+1;
+ }
+
+ // If working as root, set user IDs
+@@ -817,7 +817,7 @@
+ const char* buffer = static_cast<char*>(mpClearAttributes->GetBuffer());
+
+ u_int32_t xattrBlockLength = 0;
+- std::memcpy(&xattrBlockLength, buffer+xattrOffset, sizeof(u_int32_t));
++ ::memcpy(&xattrBlockLength, buffer+xattrOffset, sizeof(u_int32_t));
+ int xattrBlockSize = ntohl(xattrBlockLength);
+ xattrOffset += sizeof(u_int32_t);
+
+@@ -831,7 +831,7 @@
+ while(xattrOffset<xattrEnd)
+ {
+ u_int16_t keyLength = 0;
+- std::memcpy(&keyLength, buffer+xattrOffset, sizeof(u_int16_t));
++ ::memcpy(&keyLength, buffer+xattrOffset, sizeof(u_int16_t));
+ int keySize = ntohs(keyLength);
+ xattrOffset += sizeof(u_int16_t);
+
+@@ -839,7 +839,7 @@
+ xattrOffset += keySize;
+
+ u_int32_t valueLength = 0;
+- std::memcpy(&valueLength, buffer+xattrOffset, sizeof(u_int32_t));
++ ::memcpy(&valueLength, buffer+xattrOffset, sizeof(u_int32_t));
+ int valueSize = ntohl(valueLength);
+ xattrOffset += sizeof(u_int32_t);
+
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/backupclient/BackupStoreFileDiff.cpp boxbackup-0.10/lib/backupclient/BackupStoreFileDiff.cpp
+--- boxbackup-0.10,bak/lib/backupclient/BackupStoreFileDiff.cpp 2006-02-23 22:47:37.000000000 +0200
++++ boxbackup-0.10/lib/backupclient/BackupStoreFileDiff.cpp 2008-07-20 18:55:18.000000000 +0300
+@@ -70,6 +70,8 @@
+
+ #include "MemLeakFindOn.h"
+
++#include <string.h>
++
+ using namespace BackupStoreFileCryptVar;
+ using namespace BackupStoreFileCreation;
+
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/backupclient/BackupStoreFileEncodeStream.cpp boxbackup-0.10/lib/backupclient/BackupStoreFileEncodeStream.cpp
+--- boxbackup-0.10,bak/lib/backupclient/BackupStoreFileEncodeStream.cpp 2006-02-23 22:47:37.000000000 +0200
++++ boxbackup-0.10/lib/backupclient/BackupStoreFileEncodeStream.cpp 2008-07-20 18:54:21.000000000 +0300
+@@ -62,6 +62,8 @@
+
+ #include "MemLeakFindOn.h"
+
++#include <string.h>
++
+ using namespace BackupStoreFileCryptVar;
+
+
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/backupclient/BackupStoreFile.h boxbackup-0.10/lib/backupclient/BackupStoreFile.h
+--- boxbackup-0.10,bak/lib/backupclient/BackupStoreFile.h 2006-02-23 22:47:37.000000000 +0200
++++ boxbackup-0.10/lib/backupclient/BackupStoreFile.h 2008-07-20 18:51:08.000000000 +0300
+@@ -53,6 +53,7 @@
+ #include "BackupStoreFilename.h"
+
+ #include <memory>
++#include <malloc.h>
+
+ typedef struct
+ {
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/common/Configuration.cpp boxbackup-0.10/lib/common/Configuration.cpp
+--- boxbackup-0.10,bak/lib/common/Configuration.cpp 2006-02-23 22:47:35.000000000 +0200
++++ boxbackup-0.10/lib/common/Configuration.cpp 2008-07-20 18:52:37.000000000 +0300
+@@ -57,6 +57,8 @@
+
+ #include "MemLeakFindOn.h"
+
++#include <string.h>
++
+ // utility whitespace function
+ inline bool iw(int c)
+ {
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/common/WaitForEvent.cpp boxbackup-0.10/lib/common/WaitForEvent.cpp
+--- boxbackup-0.10,bak/lib/common/WaitForEvent.cpp 2006-02-23 22:47:35.000000000 +0200
++++ boxbackup-0.10/lib/common/WaitForEvent.cpp 2008-07-20 18:53:33.000000000 +0300
+@@ -53,6 +53,7 @@
+
+ #include <errno.h>
+ #include <string.h>
++#include <malloc.h>
+
+ #include "WaitForEvent.h"
+
+diff -ur --exclude '*.o' --exclude '*.a' --exclude '*~' boxbackup-0.10,bak/lib/raidfile/RaidFileRead.cpp boxbackup-0.10/lib/raidfile/RaidFileRead.cpp
+--- boxbackup-0.10,bak/lib/raidfile/RaidFileRead.cpp 2006-02-23 22:47:37.000000000 +0200
++++ boxbackup-0.10/lib/raidfile/RaidFileRead.cpp 2008-07-20 19:00:48.000000000 +0300
+@@ -59,6 +59,7 @@
+
+ #include <stdio.h>
+ #include <string.h>
++#include <malloc.h>
+ #include <memory>
+ #include <map>
+