summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-06-25 23:51:31 +0000
committerMike Frysinger <vapier@gentoo.org>2004-06-25 23:51:31 +0000
commit2bc0c2407f1a4c175633ddeb6a69df851cda311d (patch)
tree352c19c19fc24ec8f2559212b59417659fa12600 /app-arch/freeze
parentstable on amd64 (Manifest recommit) (diff)
downloadgentoo-2-2bc0c2407f1a4c175633ddeb6a69df851cda311d.tar.gz
gentoo-2-2bc0c2407f1a4c175633ddeb6a69df851cda311d.tar.bz2
gentoo-2-2bc0c2407f1a4c175633ddeb6a69df851cda311d.zip
touch the libc
Diffstat (limited to 'app-arch/freeze')
-rw-r--r--app-arch/freeze/freeze-2.5.0.ebuild22
1 files changed, 12 insertions, 10 deletions
diff --git a/app-arch/freeze/freeze-2.5.0.ebuild b/app-arch/freeze/freeze-2.5.0.ebuild
index 00fe7e69b759..c8b5a85737fc 100644
--- a/app-arch/freeze/freeze-2.5.0.ebuild
+++ b/app-arch/freeze/freeze-2.5.0.ebuild
@@ -1,31 +1,33 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/freeze/freeze-2.5.0.ebuild,v 1.5 2004/06/24 21:30:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/freeze/freeze-2.5.0.ebuild,v 1.6 2004/06/25 23:50:07 vapier Exp $
-DESCRIPTION="Freeze/unfreeze compression program."
-SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/utils/compress/${P}.tar.gz"
+DESCRIPTION="Freeze/unfreeze compression program"
HOMEPAGE="http://www.ibiblio.org/pub/Linux/utils/compress/"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/utils/compress/${P}.tar.gz"
LICENSE="as-is"
SLOT="0"
KEYWORDS="x86 ~ppc"
IUSE=""
-RDEPEND="virtual/glibc"
+RDEPEND="virtual/libc"
DEPEND="${RDEPEND}
>=sys-apps/sed-4"
src_unpack() {
- unpack ${A} && cd "${S}"
+ unpack ${A}
+ cd ${S}
# Hard links confuse prepman and these links are absolute.
sed -e "s:ln -f:ln -sf:g" -i Makefile.in || die "sed failed"
}
src_compile() {
- econf
+ econf || die
- emake OPTIONS="-DDEFFILE=\\\"/etc/freeze.cnf\\\"" \
+ emake \
+ OPTIONS="-DDEFFILE=\\\"/etc/freeze.cnf\\\"" \
|| die "compile problem"
}
@@ -33,8 +35,8 @@ src_install() {
dodir /usr/bin /usr/share/man/man1
make install \
DEST="${D}/usr/bin" \
- MANDEST="${D}/usr/share/man/man1"
-
- dobin showhuf
+ MANDEST="${D}/usr/share/man/man1" \
+ || die
+ dobin showhuf || die
dodoc README *.lsm
}