summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaweł Hajdan <phajdan.jr@gentoo.org>2009-12-20 10:05:09 +0000
committerPaweł Hajdan <phajdan.jr@gentoo.org>2009-12-20 10:05:09 +0000
commitc26a1cf28d83469bb68e57b782ae1084fdcadc08 (patch)
treef71e53b46c52d3079a6320bb9aa4128f114815b2 /app-admin
parentHOMEPAGE updated. (diff)
downloadgentoo-2-c26a1cf28d83469bb68e57b782ae1084fdcadc08.tar.gz
gentoo-2-c26a1cf28d83469bb68e57b782ae1084fdcadc08.tar.bz2
gentoo-2-c26a1cf28d83469bb68e57b782ae1084fdcadc08.zip
New ebuild for app-admin/logcheck. Implemented suggestions by Fritella
Laurento <mrfree@infinito.it>. Bug #105816. (Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logcheck/ChangeLog12
-rw-r--r--app-admin/logcheck/files/logcheck-makefile.patch11
-rw-r--r--app-admin/logcheck/files/logcheck.cron5
-rw-r--r--app-admin/logcheck/logcheck-1.3.4.ebuild54
-rw-r--r--app-admin/logcheck/metadata.xml9
5 files changed, 91 insertions, 0 deletions
diff --git a/app-admin/logcheck/ChangeLog b/app-admin/logcheck/ChangeLog
new file mode 100644
index 000000000000..fe456b119af3
--- /dev/null
+++ b/app-admin/logcheck/ChangeLog
@@ -0,0 +1,12 @@
+# ChangeLog for app-admin/logcheck
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/ChangeLog,v 1.1 2009/12/20 10:05:08 phajdan.jr Exp $
+
+*logcheck-1.3.4 (20 Dec 2009)
+
+ 20 Dec 2009; Pawel Hajdan jr <phajdan.jr@gentoo.org>
+ +logcheck-1.3.4.ebuild, +files/logcheck.cron,
+ +files/logcheck-makefile.patch, +metadata.xml:
+ New ebuild for app-admin/logcheck. Implemented suggestions by Fritella
+ Laurento <mrfree@infinito.it>. Bug #105816.
+
diff --git a/app-admin/logcheck/files/logcheck-makefile.patch b/app-admin/logcheck/files/logcheck-makefile.patch
new file mode 100644
index 000000000000..2e2037f3e526
--- /dev/null
+++ b/app-admin/logcheck/files/logcheck-makefile.patch
@@ -0,0 +1,11 @@
+--- Makefile.orig 2009-12-19 19:56:23.000000000 +0100
++++ Makefile 2009-12-19 19:56:32.000000000 +0100
+@@ -4,6 +4,8 @@
+ BINDIR = usr/sbin
+ SHAREDIR = usr/share/logtail/detectrotate
+
++all:
++
+ install:
+ # Create the directories
+ install -m 750 -d $(DESTDIR)/$(CONFDIR)
diff --git a/app-admin/logcheck/files/logcheck.cron b/app-admin/logcheck/files/logcheck.cron
new file mode 100644
index 000000000000..992eb7178920
--- /dev/null
+++ b/app-admin/logcheck/files/logcheck.cron
@@ -0,0 +1,5 @@
+#!/bin/bash
+#
+# Please uncomment the following if you want logcheck to run hourly.
+
+#su -s /bin/bash -c /usr/sbin/logcheck logcheck
diff --git a/app-admin/logcheck/logcheck-1.3.4.ebuild b/app-admin/logcheck/logcheck-1.3.4.ebuild
new file mode 100644
index 000000000000..c04f0260f697
--- /dev/null
+++ b/app-admin/logcheck/logcheck-1.3.4.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logcheck/logcheck-1.3.4.ebuild,v 1.1 2009/12/20 10:05:08 phajdan.jr Exp $
+
+EAPI=2
+
+inherit eutils
+
+DESCRIPTION="Mails anomalies in the system logfiles to the administrator."
+HOMEPAGE="http://packages.debian.org/sid/logcheck"
+SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND="!app-admin/logsentry
+ app-misc/lockfile-progs
+ dev-lang/perl
+ virtual/mailx
+ ${DEPEND}"
+
+pkg_setup() {
+ enewgroup logcheck
+ enewuser logcheck -1 -1 -1 logcheck
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-makefile.patch"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ keepdir /var/{lib,lock}/logcheck
+ dodoc AUTHORS CHANGES CREDITS TODO docs/README.* || die "dodoc failed"
+ doman docs/logtail.8 docs/logtail2.8 || die "doman failed"
+
+ exeinto /etc/cron.hourly
+ doexe "${FILESDIR}/${PN}.cron" || die "doexe failed"
+}
+
+pkg_postinst() {
+ chown -R logcheck:logcheck /etc/logcheck /var/{lib,lock}/logcheck \
+ || die "chown failed"
+
+ elog "The configuration files are located in /etc/logcheck. The most"
+ elog "important files are /etc/logcheck/logcheck.conf"
+ elog "and /etc/logcheck/logcheck.logfiles. Also, make sure that"
+ elog "the logcheck user has access to your log files."
+ elog "Finally, uncomment the logcheck line"
+ elog "/etc/cron.hourly/logcheck.cron to enable periodic log checks."
+}
diff --git a/app-admin/logcheck/metadata.xml b/app-admin/logcheck/metadata.xml
new file mode 100644
index 000000000000..9ca372f9b46f
--- /dev/null
+++ b/app-admin/logcheck/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>no-herd</herd>
+ <maintainer>
+ <email>phajdan.jr@gentoo.org</email>
+ <name>Pawel Hajdan jr</name>
+ </maintainer>
+</pkgmetadata>