summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-03-15 22:11:12 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-03-15 22:11:12 +0000
commit2114eaa62ef2701dfe5dd7e2a54e5a20d9e93b20 (patch)
treec0c29c62bd8db001cb51338ad7b1c902c21c22eb /app-admin/gamin
parentmoved links to www-client (diff)
downloadgentoo-2-2114eaa62ef2701dfe5dd7e2a54e5a20d9e93b20.tar.gz
gentoo-2-2114eaa62ef2701dfe5dd7e2a54e5a20d9e93b20.tar.bz2
gentoo-2-2114eaa62ef2701dfe5dd7e2a54e5a20d9e93b20.zip
Update version.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-admin/gamin')
-rw-r--r--app-admin/gamin/Manifest15
-rw-r--r--app-admin/gamin/files/digest-gamin-0.0.261
-rw-r--r--app-admin/gamin/gamin-0.0.26.ebuild52
3 files changed, 61 insertions, 7 deletions
diff --git a/app-admin/gamin/Manifest b/app-admin/gamin/Manifest
index 9aea36c2debd..00ecf0eb3af1 100644
--- a/app-admin/gamin/Manifest
+++ b/app-admin/gamin/Manifest
@@ -1,12 +1,13 @@
-MD5 e14b51caa6ba40b1982f36284c19f75b gamin-0.0.19.ebuild 833
-MD5 d56aae268087693c5b5fe3fc58cdae4c gamin-0.0.25.ebuild 1185
-MD5 1a12b6356c49807d6a034d775c96575f gamin-0.0.20.ebuild 828
-MD5 2695c38fbf4b4e11fe5d9c4d6f080ffc gamin-0.0.18.ebuild 889
-MD5 4a2712e1b9b26018460ffe60be8f0613 ChangeLog 3462
MD5 875135e8740bafa4dab79ee592cf9744 metadata.xml 279
+MD5 1a12b6356c49807d6a034d775c96575f gamin-0.0.20.ebuild 828
+MD5 d56aae268087693c5b5fe3fc58cdae4c gamin-0.0.26.ebuild 1185
MD5 39ade60322eb86b40eca5ba38fd6d522 gamin-0.0.15.ebuild 842
+MD5 2695c38fbf4b4e11fe5d9c4d6f080ffc gamin-0.0.18.ebuild 889
+MD5 e14b51caa6ba40b1982f36284c19f75b gamin-0.0.19.ebuild 833
+MD5 d56aae268087693c5b5fe3fc58cdae4c gamin-0.0.25.ebuild 1185
+MD5 04ae13b77ce72f4c93d0460b1bbcfd57 files/digest-gamin-0.0.20 64
+MD5 caf15e7329c9675dff66e7f65b424e79 files/digest-gamin-0.0.26 64
+MD5 a6ae9d25c124ec87523b00e860cc0d2f files/digest-gamin-0.0.25 64
MD5 c576a2ec43ce151b5bc78b77e0f58c9a files/digest-gamin-0.0.15 64
MD5 b183176dcfe9a0ad1609767f11cafc12 files/digest-gamin-0.0.18 64
MD5 35d7d4d3208d674f62e4f2d7ef7d383f files/digest-gamin-0.0.19 64
-MD5 04ae13b77ce72f4c93d0460b1bbcfd57 files/digest-gamin-0.0.20 64
-MD5 a6ae9d25c124ec87523b00e860cc0d2f files/digest-gamin-0.0.25 64
diff --git a/app-admin/gamin/files/digest-gamin-0.0.26 b/app-admin/gamin/files/digest-gamin-0.0.26
new file mode 100644
index 000000000000..804bee05dd70
--- /dev/null
+++ b/app-admin/gamin/files/digest-gamin-0.0.26
@@ -0,0 +1 @@
+MD5 3d716b6533466f9ca69df13c58009981 gamin-0.0.26.tar.gz 484070
diff --git a/app-admin/gamin/gamin-0.0.26.ebuild b/app-admin/gamin/gamin-0.0.26.ebuild
new file mode 100644
index 000000000000..8215d8970267
--- /dev/null
+++ b/app-admin/gamin/gamin-0.0.26.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.0.26.ebuild,v 1.1 2005/03/15 22:11:12 azarah Exp $
+
+DESCRIPTION="Library providing the FAM File Alteration Monitor API"
+HOMEPAGE="http://www.gnome.org/~veillard/gamin/"
+SRC_URI="http://www.gnome.org/~veillard/gamin/sources/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64 ~arm ~hppa ~ia64 ~ppc ~s390"
+IUSE="debug doc"
+
+RDEPEND="virtual/libc
+ >=dev-libs/glib-2
+ !app-admin/fam"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+PROVIDE="virtual/fam"
+
+src_compile() {
+
+ econf \
+ --enable-inotify \
+ `use_enable debug` \
+ `use_enable debug debug-api` \
+ || die
+
+ emake || die "emake failed"
+
+}
+
+src_install() {
+
+ make DESTDIR="${D}" install || die
+
+ dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
+
+ use doc && dohtml doc/*
+
+}
+
+pkg_postinst() {
+
+ einfo "It is strongly suggested you use Gamin with an inotify enabled"
+ einfo "kernel for best performance. For this release of gamin you need"
+ einfo "at least an inotify 0.19 patched kernel, gentoo-dev-sources-2.6.11"
+ einfo "provides this patch for example."
+
+}