summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-10 18:44:05 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-10 18:44:05 +0000
commitfca13dee3747cafc9bce87b197c2503b8888fa95 (patch)
tree8a58fc09c8a5a205b45b0203b5b110b8da8c373c
parentppc stable #318195 (diff)
downloadgentoo-2-fca13dee3747cafc9bce87b197c2503b8888fa95.tar.gz
gentoo-2-fca13dee3747cafc9bce87b197c2503b8888fa95.tar.bz2
gentoo-2-fca13dee3747cafc9bce87b197c2503b8888fa95.zip
Use is-flagq() instead of is-flag().
(Portage version: HEAD/cvs/Linux x86_64)
-rw-r--r--dev-lang/python/python-2.4.6.ebuild6
-rw-r--r--dev-lang/python/python-2.5.4-r4.ebuild6
-rw-r--r--dev-lang/python/python-2.6.5-r2.ebuild6
-rw-r--r--dev-lang/python/python-3.1.2-r3.ebuild6
4 files changed, 12 insertions, 12 deletions
diff --git a/dev-lang/python/python-2.4.6.ebuild b/dev-lang/python/python-2.4.6.ebuild
index 9be5e3e99efe..ef9482797902 100644
--- a/dev-lang/python/python-2.4.6.ebuild
+++ b/dev-lang/python/python-2.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.34 2010/05/10 18:42:16 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4.6.ebuild,v 1.35 2010/05/10 18:44:05 arfrever Exp $
EAPI="1"
@@ -135,8 +135,8 @@ src_configure() {
[[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
# https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flag -O3; then
- is-flag -fstack-protector-all && replace-flags -O3 -O2
+ if is-flagq -O3; then
+ is-flagq -fstack-protector-all && replace-flags -O3 -O2
use hardened && replace-flags -O3 -O2
fi
diff --git a/dev-lang/python/python-2.5.4-r4.ebuild b/dev-lang/python/python-2.5.4-r4.ebuild
index ea4a54796dd6..9539e96fdc46 100644
--- a/dev-lang/python/python-2.5.4-r4.ebuild
+++ b/dev-lang/python/python-2.5.4-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.16 2010/05/02 16:41:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.5.4-r4.ebuild,v 1.17 2010/05/10 18:44:05 arfrever Exp $
EAPI="1"
@@ -146,8 +146,8 @@ src_configure() {
[[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
# https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flag -O3; then
- is-flag -fstack-protector-all && replace-flags -O3 -O2
+ if is-flagq -O3; then
+ is-flagq -fstack-protector-all && replace-flags -O3 -O2
use hardened && replace-flags -O3 -O2
fi
diff --git a/dev-lang/python/python-2.6.5-r2.ebuild b/dev-lang/python/python-2.6.5-r2.ebuild
index 5edb345f2cd0..31ac27395d73 100644
--- a/dev-lang/python/python-2.6.5-r2.ebuild
+++ b/dev-lang/python/python-2.6.5-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.3 2010/05/02 16:41:19 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.5-r2.ebuild,v 1.4 2010/05/10 18:44:05 arfrever Exp $
EAPI="2"
@@ -142,8 +142,8 @@ src_configure() {
[[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
# https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flag -O3; then
- is-flag -fstack-protector-all && replace-flags -O3 -O2
+ if is-flagq -O3; then
+ is-flagq -fstack-protector-all && replace-flags -O3 -O2
use hardened && replace-flags -O3 -O2
fi
diff --git a/dev-lang/python/python-3.1.2-r3.ebuild b/dev-lang/python/python-3.1.2-r3.ebuild
index 7e220966ade8..cdf0e4f9ed2f 100644
--- a/dev-lang/python/python-3.1.2-r3.ebuild
+++ b/dev-lang/python/python-3.1.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.3 2010/05/02 16:39:55 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-3.1.2-r3.ebuild,v 1.4 2010/05/10 18:44:05 arfrever Exp $
EAPI="3"
@@ -120,8 +120,8 @@ src_configure() {
[[ "${ARCH}" == "alpha" ]] && append-flags -fPIC
# https://bugs.gentoo.org/show_bug.cgi?id=50309
- if is-flag -O3; then
- is-flag -fstack-protector-all && replace-flags -O3 -O2
+ if is-flagq -O3; then
+ is-flagq -fstack-protector-all && replace-flags -O3 -O2
use hardened && replace-flags -O3 -O2
fi