summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-01-08 06:40:09 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-01-08 06:40:09 +0000
commitf202dbb419a94ae157c5d994396f926d560e59da (patch)
tree2cb095ee8511f003da7e98edd769172b51c18842
parentunmasked (diff)
downloadgentoo-2-f202dbb419a94ae157c5d994396f926d560e59da.tar.gz
gentoo-2-f202dbb419a94ae157c5d994396f926d560e59da.tar.bz2
gentoo-2-f202dbb419a94ae157c5d994396f926d560e59da.zip
einfo change only
-rw-r--r--sys-devel/perl/ChangeLog6
-rw-r--r--sys-devel/perl/perl-5.8.0-r8.ebuild16
2 files changed, 17 insertions, 5 deletions
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 4c9550cc549e..7ece72ab1785 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-devel/perl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.38 2003/01/06 14:54:04 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.39 2003/01/08 06:40:09 lostlogic Exp $
* perl-5.8.0-r8 (06 Jan 2003)
+ 08 Jan 2003; Brandon Low <lostlogic@gentoo.org> perl-5.8.0-r8:
+ Updated ewarn at the top so that it makes sense (was telling a user
+ they could use threads when they already were)
+
06 Jan 2003; Michael Cummings <mcummings@gentoo.org> perl-5.8.0-r8:
Updated einfo, added libperl ebuild. I've placed the libperl rebuilder
in the filesdir and added a note about it to the pkg_postinstall. Thanks
diff --git a/sys-devel/perl/perl-5.8.0-r8.ebuild b/sys-devel/perl/perl-5.8.0-r8.ebuild
index 84f13a3683df..89bae9195db5 100644
--- a/sys-devel/perl/perl-5.8.0-r8.ebuild
+++ b/sys-devel/perl/perl-5.8.0-r8.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r8.ebuild,v 1.1 2003/01/06 14:53:39 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r8.ebuild,v 1.2 2003/01/08 06:40:09 lostlogic Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -107,14 +107,22 @@ pkg_setup() {
if [ -n "`use threads`" ]
then
ewarn ""
- ewarn "PLEASE NOTE: If you wish to compile perl-5.8 with "
- ewarn "threading enabled, you must restart this emerge "
+ ewarn "PLEASE NOTE: You are compiling perl-5.8 with"
+ ewarn "threading enabled."
+ ewarn "Threading is not supported by all applications "
+ ewarn "that compile against perl. You use threading at "
+ ewarn "your own discretion. "
+ ewarn ""
+ sleep 10
+ else
+ ewarn ""
+ ewarn "PLEASE NOTE: If you want to compile perl-5.8 with"
+ ewarn "threading enabled , you must restart this emerge"
ewarn "with USE=threads emerge...."
ewarn "Threading is not supported by all applications "
ewarn "that compile against perl. You use threading at "
ewarn "your own discretion. "
ewarn ""
- sleep 15
fi
if [ "${PN}" = "perl" -a ! -f /usr/lib/${LIBPERL} ]