summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2014-04-30 18:40:31 +0000
committerTim Harder <radhermit@gentoo.org>2014-04-30 18:40:31 +0000
commitee6bb45d48558a44c5c58290629f03c751fb0c66 (patch)
tree78dd08b90421d023f3824056a0b34f81a8e539fd
parentBump to 0.3.9, thanks to Nikoli. (diff)
downloadgentoo-2-ee6bb45d48558a44c5c58290629f03c751fb0c66.tar.gz
gentoo-2-ee6bb45d48558a44c5c58290629f03c751fb0c66.tar.bz2
gentoo-2-ee6bb45d48558a44c5c58290629f03c751fb0c66.zip
Version bump, move to python-r1 (bug #460044, patch by mgorny).
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
-rw-r--r--sys-libs/libcap-ng/ChangeLog7
-rw-r--r--sys-libs/libcap-ng/libcap-ng-0.7.4.ebuild92
2 files changed, 98 insertions, 1 deletions
diff --git a/sys-libs/libcap-ng/ChangeLog b/sys-libs/libcap-ng/ChangeLog
index 8ac347db7a7a..7ee357735b8b 100644
--- a/sys-libs/libcap-ng/ChangeLog
+++ b/sys-libs/libcap-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-libs/libcap-ng
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.66 2014/01/19 20:11:39 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/ChangeLog,v 1.67 2014/04/30 18:40:31 radhermit Exp $
+
+*libcap-ng-0.7.4 (30 Apr 2014)
+
+ 30 Apr 2014; Tim Harder <radhermit@gentoo.org> +libcap-ng-0.7.4.ebuild:
+ Version bump, move to python-r1 (bug #460044, patch by mgorny).
19 Jan 2014; Mike Frysinger <vapier@gentoo.org> libcap-ng-0.7.3.ebuild:
Add arm64 love.
diff --git a/sys-libs/libcap-ng/libcap-ng-0.7.4.ebuild b/sys-libs/libcap-ng/libcap-ng-0.7.4.ebuild
new file mode 100644
index 000000000000..dd3bbbd4d27b
--- /dev/null
+++ b/sys-libs/libcap-ng/libcap-ng-0.7.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/libcap-ng/libcap-ng-0.7.4.ebuild,v 1.1 2014/04/30 18:40:31 radhermit Exp $
+
+EAPI=5
+
+AUTOTOOLS_AUTORECONF=1
+AUTOTOOLS_PRUNE_LIBTOOL_FILES=all
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
+
+inherit autotools-utils flag-o-matic python-r1
+
+DESCRIPTION="POSIX 1003.1e capabilities"
+HOMEPAGE="http://people.redhat.com/sgrubb/libcap-ng/"
+SRC_URI="http://people.redhat.com/sgrubb/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~arm-linux ~x86-linux"
+IUSE="python static-libs"
+
+RDEPEND="python? ( ${PYTHON_DEPS} )"
+DEPEND="${RDEPEND}
+ sys-kernel/linux-headers
+ python? ( >=dev-lang/swig-2 )"
+
+src_prepare() {
+ sed -i -e 's:AM_CONFIG_HEADER:AC_CONFIG_HEADERS:' configure.ac || die
+
+ autotools-utils_src_prepare
+
+ use sparc && replace-flags -O? -O0
+}
+
+src_configure() {
+ local myeconfargs=(
+ --without-python
+ )
+
+ # set up the library build
+ autotools-utils_src_configure
+
+ if use python; then
+ python_parallel_foreach_impl \
+ autotools-utils_src_configure --with-python
+ fi
+}
+
+src_compile() {
+ autotools-utils_src_compile
+
+ if use python; then
+ python_compile() {
+ local CFLAGS=${CFLAGS}
+
+ python_is_python3 || CFLAGS+=" -fno-strict-aliasing"
+
+ emake "${@}" \
+ -C "${BUILD_DIR}"/bindings/python
+ }
+
+ # help build system find the right objects
+ python_foreach_impl python_compile \
+ VPATH="${BUILD_DIR}"/bindings/python \
+ LIBS="${BUILD_DIR}"/src/libcap-ng.la
+ fi
+}
+
+src_test() {
+ if [[ "${EUID}" -eq 0 ]]; then
+ ewarn "Skipping tests due to root permissions."
+ return
+ fi
+
+ autotools-utils_src_test
+
+ if use python; then
+ python_foreach_impl \
+ autotools-utils_src_compile -C bindings/python check \
+ VPATH="${BUILD_DIR}"/bindings/python:"${S}"/bindings/python/test
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use python; then
+ python_foreach_impl \
+ autotools-utils_src_install -C bindings/python \
+ VPATH="${BUILD_DIR}"/bindings/python
+ fi
+}