summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-09-23 16:33:23 +0000
committerJeroen Roovers <jer@gentoo.org>2009-09-23 16:33:23 +0000
commitd027af48a6575e2ca4f7a0bdfe28ec9f91a229a5 (patch)
tree3d0295832ed34295fcbf3d0bb598fdd574260f63
parentRemove virtual/libc (diff)
downloadgentoo-2-d027af48a6575e2ca4f7a0bdfe28ec9f91a229a5.tar.gz
gentoo-2-d027af48a6575e2ca4f7a0bdfe28ec9f91a229a5.tar.bz2
gentoo-2-d027af48a6575e2ca4f7a0bdfe28ec9f91a229a5.zip
Version bump. Remove old.
(Portage version: 2.2_rc41/cvs/Linux i686)
-rw-r--r--x11-wm/ratpoison/ChangeLog8
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.5.ebuild (renamed from x11-wm/ratpoison/ratpoison-1.4.3.ebuild)25
2 files changed, 24 insertions, 9 deletions
diff --git a/x11-wm/ratpoison/ChangeLog b/x11-wm/ratpoison/ChangeLog
index 8a0cdd0f1027..74bfd0fe001a 100644
--- a/x11-wm/ratpoison/ChangeLog
+++ b/x11-wm/ratpoison/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-wm/ratpoison
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.74 2009/08/01 23:49:03 vostorga Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ChangeLog,v 1.75 2009/09/23 16:33:23 jer Exp $
+
+*ratpoison-1.4.5 (23 Sep 2009)
+
+ 23 Sep 2009; Jeroen Roovers <jer@gentoo.org> -ratpoison-1.4.3.ebuild,
+ +ratpoison-1.4.5.ebuild:
+ Version bump. Remove old.
01 Aug 2009; Víctor Ostorga <vostorga@gentoo.org> ratpoison-1.4.4-r1.ebuild,
+files/ratpoison-1.4.4-glibc210.patch:
diff --git a/x11-wm/ratpoison/ratpoison-1.4.3.ebuild b/x11-wm/ratpoison/ratpoison-1.4.5.ebuild
index dabca720b766..5a8214798ce1 100644
--- a/x11-wm/ratpoison/ratpoison-1.4.3.ebuild
+++ b/x11-wm/ratpoison/ratpoison-1.4.5.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.3.ebuild,v 1.8 2009/07/19 17:32:59 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/ratpoison/ratpoison-1.4.5.ebuild,v 1.1 2009/09/23 16:33:23 jer Exp $
+
+EAPI=2
inherit elisp-common eutils autotools
@@ -10,29 +12,36 @@ SRC_URI="http://savannah.nongnu.org/download/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="amd64 hppa ppc sparc x86 ~x86-fbsd"
-IUSE="emacs"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="debug emacs +history +xft"
DEPEND="x11-libs/libXinerama
x11-libs/libXtst
virtual/perl-PodParser
- emacs? ( virtual/emacs )"
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline )
+ xft? ( x11-libs/libXft )"
RDEPEND="${DEPEND}"
SITEFILE=50ratpoison-gentoo.el
-src_unpack() {
- unpack ${A}
-
+src_prepare() {
cd "${S}/contrib"
epatch "${FILESDIR}/ratpoison.el-gentoo.patch"
cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.4.4-glibc210.patch"
+
eautoreconf
}
+src_configure() {
+ local myconf
+ use history || myconf="--disable-history"
+ econf ${myconf} $(use_with xft) $(use_enable debug) || die "econf failed"
+}
+
src_compile() {
- econf || die "econf failed"
emake CFLAGS="${CFLAGS}" || die "emake failed"
if use emacs; then
elisp-compile contrib/ratpoison.el || die "elisp-compile failed"