summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCiaran McCreesh <ciaranm@gentoo.org>2004-09-05 01:46:16 +0000
committerCiaran McCreesh <ciaranm@gentoo.org>2004-09-05 01:46:16 +0000
commitb2dc16dba20dcbe876023280f3f41284b774f24a (patch)
treef46c02a54166d45ab4c18ae6424944efcaf6895f
parentAdded help text, bug #62559 (Manifest recommit) (diff)
downloadgentoo-2-b2dc16dba20dcbe876023280f3f41284b774f24a.tar.gz
gentoo-2-b2dc16dba20dcbe876023280f3f41284b774f24a.tar.bz2
gentoo-2-b2dc16dba20dcbe876023280f3f41284b774f24a.zip
Generate help text from the .vim file automatically. Added help text, bug #62559
-rw-r--r--app-vim/minibufexpl/ChangeLog9
-rw-r--r--app-vim/minibufexpl/Manifest12
-rw-r--r--app-vim/minibufexpl/files/digest-minibufexpl-6.3.1-r11
-rw-r--r--app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild26
4 files changed, 37 insertions, 11 deletions
diff --git a/app-vim/minibufexpl/ChangeLog b/app-vim/minibufexpl/ChangeLog
index 94cc66a40ac3..e94db4259f57 100644
--- a/app-vim/minibufexpl/ChangeLog
+++ b/app-vim/minibufexpl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-vim/minibufexpl
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/ChangeLog,v 1.9 2004/08/25 16:18:14 ciaranm Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/ChangeLog,v 1.10 2004/09/05 01:46:16 ciaranm Exp $
+
+*minibufexpl-6.3.1-r1 (05 Sep 2004)
+
+ 05 Sep 2004; Ciaran McCreesh <ciaranm@gentoo.org>
+ +minibufexpl-6.3.1-r1.ebuild:
+ Generate help text from the .vim file automatically. Added help text, bug
+ #62559
25 Aug 2004; Ciaran McCreesh <ciaranm@gentoo.org> minibufexpl-6.2.6.ebuild,
minibufexpl-6.3.1.ebuild:
diff --git a/app-vim/minibufexpl/Manifest b/app-vim/minibufexpl/Manifest
index 8ad6b2a91082..d10e374bf0fc 100644
--- a/app-vim/minibufexpl/Manifest
+++ b/app-vim/minibufexpl/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 b11b64dab4db49c0c30bbce8d8b151b7 minibufexpl-6.3.1-r1.ebuild 907
MD5 4b847e5f4a84c33a5ae2bc35cce89322 minibufexpl-6.2.6.ebuild 440
MD5 7d4afed58f9a6e633e6aa0c3e67be56b ChangeLog 1195
MD5 9771ca4ff90b56dddc4acfadc6f6a01e metadata.xml 250
MD5 2e598b8749063f7727180020458d5e24 minibufexpl-6.3.1.ebuild 445
+MD5 32c61863835ac319af932bbe475680cb files/digest-minibufexpl-6.3.1-r1 69
MD5 c91c0f5625dd939dc121c5a068c0fa74 files/digest-minibufexpl-6.2.6 69
MD5 32c61863835ac319af932bbe475680cb files/digest-minibufexpl-6.3.1 69
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.2.4 (GNU/Linux)
-
-iD8DBQFBLLscLLFUmVNQ7rkRAg3sAJ9bIPr8QUMUh4zJutez/NiH99SeRwCguRsc
-aiVOBvEdVvys1uodc7DsswE=
-=wCdO
------END PGP SIGNATURE-----
diff --git a/app-vim/minibufexpl/files/digest-minibufexpl-6.3.1-r1 b/app-vim/minibufexpl/files/digest-minibufexpl-6.3.1-r1
new file mode 100644
index 000000000000..a0b2e6fe876f
--- /dev/null
+++ b/app-vim/minibufexpl/files/digest-minibufexpl-6.3.1-r1
@@ -0,0 +1 @@
+MD5 2c7a822d81d78ac02bd5d69afafaa58b minibufexpl-6.3.1.tar.bz2 15351
diff --git a/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild b/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild
new file mode 100644
index 000000000000..b7fa15c4c9ff
--- /dev/null
+++ b/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-vim/minibufexpl/minibufexpl-6.3.1-r1.ebuild,v 1.1 2004/09/05 01:46:16 ciaranm Exp $
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: easily switch between buffers"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=159"
+LICENSE="as-is"
+KEYWORDS="~sparc ~x86 ~alpha ~ia64 ~mips ~ppc ~amd64"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="minibufexpl.txt"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # There's good documentation included with the script, but it's not
+ # in a helpfile. Since there's rather too much information to include
+ # in a VIM_PLUGIN_HELPTEXT, we'll sed ourselves a help doc.
+ mkdir ${S}/doc
+ sed -e '1,/"=\+$/d' -e '/"=\+$/,9999d' -e 's/^" \?//' \
+ -e 's/\(Name Of File: \)\([^.]\+\)\.vim/\1*\2.txt*/' \
+ plugin/minibufexpl.vim \
+ > doc/minibufexpl.txt
+}