summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2011-09-24 09:09:42 +0000
committerHans de Graaff <graaff@gentoo.org>2011-09-24 09:09:42 +0000
commit9de5f18381e4abd400ec3c6a48b237a5b21b649e (patch)
treed7fe046dcd007d6d5fe367808784c41c6b81ebf2
parentRefactor dependency variables and introduce pkgconfig dependency (diff)
downloadgentoo-2-9de5f18381e4abd400ec3c6a48b237a5b21b649e.tar.gz
gentoo-2-9de5f18381e4abd400ec3c6a48b237a5b21b649e.tar.bz2
gentoo-2-9de5f18381e4abd400ec3c6a48b237a5b21b649e.zip
Version bump.
(Portage version: 2.1.10.11/cvs/Linux x86_64)
-rw-r--r--dev-db/mysql-workbench/ChangeLog8
-rw-r--r--dev-db/mysql-workbench/mysql-workbench-5.2.35.ebuild85
2 files changed, 92 insertions, 1 deletions
diff --git a/dev-db/mysql-workbench/ChangeLog b/dev-db/mysql-workbench/ChangeLog
index 5c615fbb9e5a..d999b747c487 100644
--- a/dev-db/mysql-workbench/ChangeLog
+++ b/dev-db/mysql-workbench/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-db/mysql-workbench
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/ChangeLog,v 1.42 2011/09/10 08:51:16 graaff Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/ChangeLog,v 1.43 2011/09/24 09:09:42 graaff Exp $
+
+*mysql-workbench-5.2.35 (24 Sep 2011)
+
+ 24 Sep 2011; Hans de Graaff <graaff@gentoo.org>
+ +mysql-workbench-5.2.35.ebuild:
+ Version bump.
10 Sep 2011; Hans de Graaff <graaff@gentoo.org>
mysql-workbench-5.2.34.ebuild:
diff --git a/dev-db/mysql-workbench/mysql-workbench-5.2.35.ebuild b/dev-db/mysql-workbench/mysql-workbench-5.2.35.ebuild
new file mode 100644
index 000000000000..4bf5c8cdc4b3
--- /dev/null
+++ b/dev-db/mysql-workbench/mysql-workbench-5.2.35.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/mysql-workbench/mysql-workbench-5.2.35.ebuild,v 1.1 2011/09/24 09:09:42 graaff Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+PYTHON_DEPEND=2
+
+inherit gnome2 eutils flag-o-matic python autotools
+
+MY_P="${PN}-gpl-${PV}-src"
+
+DESCRIPTION="MySQL Workbench"
+HOMEPAGE="http://dev.mysql.com/workbench/"
+SRC_URI="mirror://mysql/Downloads/MySQLGUITools/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug doc nls readline static-libs"
+
+CDEPEND="dev-db/sqlite:3
+ >=x11-libs/gtk+-2.6:2
+ dev-libs/glib:2
+ gnome-base/libglade:2.0
+ dev-libs/libsigc++:2
+ dev-libs/boost
+ >=dev-cpp/ctemplate-0.95
+ >=dev-libs/libxml2-2.6.2:2
+ >=dev-cpp/glibmm-2.14:2
+ >=dev-cpp/gtkmm-2.14:2.4
+ dev-libs/libzip
+ >=virtual/mysql-5.1
+ dev-libs/libpcre
+ virtual/opengl
+ >=dev-lang/lua-5.1[deprecated]
+ x11-libs/pango
+ || ( sys-libs/e2fsprogs-libs
+ dev-libs/ossp-uuid )
+ >=x11-libs/cairo-1.5.12[svg]
+ dev-python/pexpect
+ dev-python/paramiko
+ doc? ( dev-python/pysqlite:2 )
+ nls? ( sys-devel/gettext )
+ readline? ( sys-libs/readline )"
+RDEPEND="${CDEPEND}
+ app-admin/sudo
+ sys-apps/net-tools"
+DEPEND="${CDEPEND}
+ dev-util/pkgconfig"
+
+S="${WORKDIR}"/"${MY_P}"
+
+pkg_setup() {
+ # Make sure we use Python 2 since the code is not compatible with 3.
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # ifconfig isn't in the normal path
+ sed -i -e 's:ifconfig:/sbin/ifconfig:' plugins/wb.admin/backend/wb_server_control.py || die
+
+ epatch "${FILESDIR}/${PN}-5.2.31-python-libs.patch"
+ eautoreconf
+
+ # Remove bundled ctemplate version to make sure we use the system
+ # version, but leave a directory to avoid confusing configure, bug
+ # 357539.
+ rm -rf ext/ctemplate || die
+ mkdir -p ext/ctemplate/ctemplate-src || die
+}
+
+src_configure() {
+ econf \
+ $(use_enable nls i18n) \
+ $(use_enable readline readline) \
+ $(use_enable debug) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${ED}" -name '*.la' -delete || die
+}