summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Kislyuk <weaver@gentoo.org>2009-12-07 21:03:03 +0000
committerAndrey Kislyuk <weaver@gentoo.org>2009-12-07 21:03:03 +0000
commit968f1a91ade4db9a3b0bdf19056cce03fd29e621 (patch)
treec375405c308f969d52066d8df4f76314b8885e2a
parentInitial commit. Many thanks go to Jean-Michel Petit the upstream author for p... (diff)
downloadgentoo-2-968f1a91ade4db9a3b0bdf19056cce03fd29e621.tar.gz
gentoo-2-968f1a91ade4db9a3b0bdf19056cce03fd29e621.tar.bz2
gentoo-2-968f1a91ade4db9a3b0bdf19056cce03fd29e621.zip
Fix x86 compile issue. Thanks to Fabian Groffen.
(Portage version: 2.2_rc30/cvs/Linux x86_64)
-rw-r--r--sci-biology/tophat/ChangeLog5
-rw-r--r--sci-biology/tophat/tophat-1.0.12.ebuild10
2 files changed, 10 insertions, 5 deletions
diff --git a/sci-biology/tophat/ChangeLog b/sci-biology/tophat/ChangeLog
index 22bb55cca671..de94fe14956a 100644
--- a/sci-biology/tophat/ChangeLog
+++ b/sci-biology/tophat/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-biology/tophat
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.1 2009/12/07 15:50:08 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/ChangeLog,v 1.2 2009/12/07 21:03:03 weaver Exp $
+
+ 07 Dec 2009; Andrey Kislyuk <weaver@gentoo.org> tophat-1.0.12.ebuild:
+ Fix x86 compile issue. Thanks to Fabian Groffen.
*tophat-1.0.12 (07 Dec 2009)
diff --git a/sci-biology/tophat/tophat-1.0.12.ebuild b/sci-biology/tophat/tophat-1.0.12.ebuild
index e691698188d7..0082942fbc0a 100644
--- a/sci-biology/tophat/tophat-1.0.12.ebuild
+++ b/sci-biology/tophat/tophat-1.0.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.0.12.ebuild,v 1.1 2009/12/07 15:50:08 weaver Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-biology/tophat/tophat-1.0.12.ebuild,v 1.2 2009/12/07 21:03:03 weaver Exp $
EAPI="2"
@@ -13,16 +13,18 @@ SRC_URI="http://tophat.cbcb.umd.edu/downloads/${P}.tar.gz"
LICENSE="Artistic"
SLOT="0"
IUSE=""
-KEYWORDS="~amd64"
+KEYWORDS="~amd64 ~x86"
-DEPEND="sci-biology/bowtie"
-RDEPEND="${DEPEND}"
+DEPEND=""
+RDEPEND="sci-biology/bowtie"
src_prepare() {
# fix gcc-4.4 missing include
sed -i '/#include <string>/ a #include <stdio.h>' "${S}/src/gff_juncs.cpp" || die
# fix parallel make race
sed -i -e 's/\$(top_builddir)\/src\///g' src/Makefile.am || die
+ # remove broken arch-dependent CFLAGS setting
+ perl -i -ne 'print unless /case "\${host_cpu}-\${host_os}" in/../^esac/' configure.ac || die
eautoreconf || die
}