summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-12-06 07:41:20 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-12-06 07:41:20 +0000
commit95b9442d8ba23e130a5df806588ba50c5636c52d (patch)
treecf801795e067fdcf3b1cf3831618a81f4b0efe1f
parentBump (diff)
downloadgentoo-2-95b9442d8ba23e130a5df806588ba50c5636c52d.tar.gz
gentoo-2-95b9442d8ba23e130a5df806588ba50c5636c52d.tar.bz2
gentoo-2-95b9442d8ba23e130a5df806588ba50c5636c52d.zip
Bump
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
-rw-r--r--dev-db/postgresql-docs/ChangeLog14
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-8.4.19.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.0.15.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.1.11.ebuild51
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.2.6.ebuild59
-rw-r--r--dev-db/postgresql-docs/postgresql-docs-9.3.2.ebuild59
6 files changed, 284 insertions, 1 deletions
diff --git a/dev-db/postgresql-docs/ChangeLog b/dev-db/postgresql-docs/ChangeLog
index 919c6b3e4566..ec82c339eecd 100644
--- a/dev-db/postgresql-docs/ChangeLog
+++ b/dev-db/postgresql-docs/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-db/postgresql-docs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.213 2013/10/11 08:58:21 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/ChangeLog,v 1.214 2013/12/06 07:41:20 patrick Exp $
+
+*postgresql-docs-9.0.15 (06 Dec 2013)
+*postgresql-docs-9.1.11 (06 Dec 2013)
+*postgresql-docs-9.3.2 (06 Dec 2013)
+*postgresql-docs-8.4.19 (06 Dec 2013)
+*postgresql-docs-9.2.6 (06 Dec 2013)
+
+ 06 Dec 2013; Patrick Lauer <patrick@gentoo.org>
+ +postgresql-docs-8.4.19.ebuild, +postgresql-docs-9.0.15.ebuild,
+ +postgresql-docs-9.1.11.ebuild, +postgresql-docs-9.2.6.ebuild,
+ +postgresql-docs-9.3.2.ebuild:
+ Bump
*postgresql-docs-9.1.10 (11 Oct 2013)
*postgresql-docs-9.0.14 (11 Oct 2013)
diff --git a/dev-db/postgresql-docs/postgresql-docs-8.4.19.ebuild b/dev-db/postgresql-docs/postgresql-docs-8.4.19.ebuild
new file mode 100644
index 000000000000..43b096585f67
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-8.4.19.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-8.4.19.ebuild,v 1.1 2013/12/06 07:41:20 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ dodir ${mypath}/html
+ tar -zxf "postgres.tar.gz" -C "${ED}${mypath}/html" || die
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.0.15.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.0.15.ebuild
new file mode 100644
index 000000000000..ac8fe29c44a1
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.0.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.0.15.ebuild,v 1.1 2013/12/06 07:41:20 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+S=${WORKDIR}/postgresql-${PV}
+SLOT="$(get_version_component_range 1-2)"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.1.11.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.1.11.ebuild
new file mode 100644
index 000000000000..b12659824102
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.1.11.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.1.11.ebuild,v 1.1 2013/12/06 07:41:20 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+SLOT="$(get_version_component_range 1-2)"
+S="${WORKDIR}/postgresql-${PV}"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+LICENSE="POSTGRESQL"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.2.6.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.2.6.ebuild
new file mode 100644
index 000000000000..205366539235
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.2.6.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.2.6.ebuild,v 1.1 2013/12/06 07:41:20 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+#MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
+#SRC_URI="mirror://postgresql/source/v${MY_FILE_PV}/postgresql-${MY_FILE_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+S="${WORKDIR}/postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}
diff --git a/dev-db/postgresql-docs/postgresql-docs-9.3.2.ebuild b/dev-db/postgresql-docs/postgresql-docs-9.3.2.ebuild
new file mode 100644
index 000000000000..adc93b974949
--- /dev/null
+++ b/dev-db/postgresql-docs/postgresql-docs-9.3.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-db/postgresql-docs/postgresql-docs-9.3.2.ebuild,v 1.1 2013/12/06 07:41:20 patrick Exp $
+
+EAPI="4"
+
+inherit versionator
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~ppc-macos ~x86-solaris"
+
+RESTRICT="test"
+
+DESCRIPTION="PostgreSQL documentation"
+HOMEPAGE="http://www.postgresql.org/"
+LICENSE="POSTGRESQL"
+
+SLOT="$(get_version_component_range 1-2)"
+
+# Comment the following four lines when not a beta or rc.
+#MY_PV="${PV//_}"
+#MY_FILE_PV="${SLOT}$(get_version_component_range 4)"
+#S="${WORKDIR}/postgresql-${MY_FILE_PV}"
+#SRC_URI="mirror://postgresql/source/v${MY_FILE_PV}/postgresql-${MY_FILE_PV}.tar.bz2"
+
+# Comment the following two lines when a beta or rc.
+S="${WORKDIR}/postgresql-${PV}"
+SRC_URI="mirror://postgresql/source/v${PV}/postgresql-${PV}.tar.bz2"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_unpack() {
+ tar xjf "${DISTDIR}/${A}" -C "${WORKDIR}" "${A%.tar.bz2}/doc"
+}
+
+src_install() {
+ # Don't use ${PF} here as three packages
+ # (dev-db/postgresql-{docs,base,server}) have the same set of docs.
+ local mypath=/usr/share/doc/postgresql-${SLOT}
+
+ cd "${S}/doc"
+
+ insinto ${mypath}/html
+ doins src/sgml/html/*
+
+ insinto ${mypath}/sgml
+ doins src/sgml/*.{sgml,dsl}
+
+ insinto ${mypath}/sgml/ref
+ doins src/sgml/ref/*.sgml
+
+ fowners root:0 -R ${mypath}
+
+ dodir /etc/eselect/postgresql/slots/${SLOT}
+ echo "postgres_ebuilds=\"\${postgres_ebuilds} ${PF}\"" > \
+ "${ED}/etc/eselect/postgresql/slots/${SLOT}/docs"
+}