summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoseph Jezak <josejx@gentoo.org>2007-06-28 14:23:19 +0000
committerJoseph Jezak <josejx@gentoo.org>2007-06-28 14:23:19 +0000
commit8c335657805e6b96caad1e9d1cd646ccc4ef7412 (patch)
tree6b7ed98ecf55309fd4361c666139f95f9a15cf42
parentapply fixes in pyme-0.6.0 to pyme-0.7.0 (diff)
downloadgentoo-2-8c335657805e6b96caad1e9d1cd646ccc4ef7412.tar.gz
gentoo-2-8c335657805e6b96caad1e9d1cd646ccc4ef7412.tar.bz2
gentoo-2-8c335657805e6b96caad1e9d1cd646ccc4ef7412.zip
Added ppc endian patch from Albert Zeyer, fixes bug #181288. Marked ~ppc.
(Portage version: 2.1.3_rc5)
-rw-r--r--media-sound/lastfmplayer/ChangeLog8
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-1.1.3-mp3transcode.patch24
-rw-r--r--media-sound/lastfmplayer/files/lastfmplayer-1.3.0.58-mp3transcode.patch24
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild7
-rw-r--r--media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild5
5 files changed, 63 insertions, 5 deletions
diff --git a/media-sound/lastfmplayer/ChangeLog b/media-sound/lastfmplayer/ChangeLog
index 952eb9f9d15a..3a477f4ef578 100644
--- a/media-sound/lastfmplayer/ChangeLog
+++ b/media-sound/lastfmplayer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/lastfmplayer
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.18 2007/06/27 21:28:28 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/ChangeLog,v 1.19 2007/06/28 14:23:19 josejx Exp $
+
+ 28 Jun 2007; Joseph Jezak <josejx@gentoo.org>
+ +files/lastfmplayer-1.1.3-mp3transcode.patch,
+ +files/lastfmplayer-1.3.0.58-mp3transcode.patch,
+ lastfmplayer-1.1.3-r2.ebuild, lastfmplayer-1.3.0.58.ebuild:
+ Added ppc endian patch from Albert Zeyer, fixes bug #181288. Marked ~ppc.
*lastfmplayer-1.3.0.58 (27 Jun 2007)
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-1.1.3-mp3transcode.patch b/media-sound/lastfmplayer/files/lastfmplayer-1.1.3-mp3transcode.patch
new file mode 100644
index 000000000000..ef6f2dd5a0a5
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-1.1.3-mp3transcode.patch
@@ -0,0 +1,24 @@
+--- src/mp3transcode/mp3transcode.cpp.old 2007-06-08 11:20:49.000000000 +0200
++++ src/mp3transcode/mp3transcode.cpp 2007-06-08 11:58:05.000000000 +0200
+@@ -19,6 +19,7 @@
+ * 51 Franklin Steet, Fifth Floor, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <qconfig.h> // for Q_BYTE_ORDER
+ #include <QtGui>
+
+ #include "mp3transcode.h"
+@@ -64,8 +65,13 @@
+ {
+ for ( int i = 0; i < ( size / 2 ); i++ )
+ {
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ outputBuffer.append( tempBuffer[i * 2] );
+ outputBuffer.append( tempBuffer[i * 2 + 1] );
++#else // Q_BIG_ENDIAN
++ outputBuffer.append( tempBuffer[i * 2 + 1] );
++ outputBuffer.append( tempBuffer[i * 2] );
++#endif // Q_BYTE_ORDER
+ }
+
+ result = decodeMP3( &mpeg, NULL, 0, tempBuffer, sizeof( tempBuffer ), &size );
diff --git a/media-sound/lastfmplayer/files/lastfmplayer-1.3.0.58-mp3transcode.patch b/media-sound/lastfmplayer/files/lastfmplayer-1.3.0.58-mp3transcode.patch
new file mode 100644
index 000000000000..c4f19c13cccb
--- /dev/null
+++ b/media-sound/lastfmplayer/files/lastfmplayer-1.3.0.58-mp3transcode.patch
@@ -0,0 +1,24 @@
+--- src/mp3transcode/mp3transcode.cpp.orig 2007-06-22 14:21:53.000000000 -0400
++++ src/mp3transcode/mp3transcode.cpp 2007-06-28 09:37:19.000000000 -0400
+@@ -19,6 +19,7 @@
+ * 51 Franklin Steet, Fifth Floor, Boston, MA 02111-1307, USA. *
+ ***************************************************************************/
+
++#include <qconfig.h> // for Q_BYTE_ORDER
+ #include <QtGui>
+
+ #include "mp3transcode.h"
+@@ -116,8 +117,13 @@
+ {
+ for ( int i = 0; i < ( size / 2 ); i++ )
+ {
++#if Q_BYTE_ORDER == Q_LITTLE_ENDIAN
+ m_decodedBuffer.append( tempBuffer[i * 2] );
+ m_decodedBuffer.append( tempBuffer[i * 2 + 1] );
++#else /* Q_BIG_ENDIAN */
++ m_decodedBuffer.append( tempBuffer[i * 2 + 1] );
++ m_decodedBuffer.append( tempBuffer[i * 2] );
++#endif /* Q_BYTE_ORDER */
+ }
+
+ result = decodeMP3( &mpeg, NULL, 0, tempBuffer, sizeof( tempBuffer ), &size );
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild
index ef8dc8984f1f..3f9172c7a673 100644
--- a/media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild
+++ b/media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild,v 1.1 2007/05/22 19:58:35 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.1.3-r2.ebuild,v 1.2 2007/06/28 14:23:19 josejx Exp $
inherit eutils versionator
@@ -11,7 +11,7 @@ SRC_URI="http://static.last.fm/client/Linux/${MY_P}.src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
RESTRICT="nomirror"
S="${WORKDIR}/${MY_P}"
@@ -21,8 +21,11 @@ DEPEND=">=x11-libs/qt-4.2
src_unpack() {
unpack ${A}
+ cd ${S}
+
epatch ${FILESDIR}/13_alsa-r1.diff
epatch ${FILESDIR}/qt4.patch
+ epatch ${FILESDIR}/${P}-mp3transcode.patch
}
src_compile() {
diff --git a/media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild b/media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild
index 0e251e310cd9..611fd0cfb5a4 100644
--- a/media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild
+++ b/media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild,v 1.1 2007/06/27 21:28:28 genstef Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfmplayer/lastfmplayer-1.3.0.58.ebuild,v 1.2 2007/06/28 14:23:19 josejx Exp $
inherit eutils versionator
@@ -11,7 +11,7 @@ SRC_URI="http://static.last.fm/client/Linux/${MY_P}.src.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="~x86 ~ppc ~amd64"
IUSE=""
RESTRICT="nomirror"
S="${WORKDIR}/${MY_P}"
@@ -23,6 +23,7 @@ src_unpack() {
unpack ${A}
cd ${S}
epatch ${FILESDIR}/qt4.patch
+ epatch ${FILESDIR}/${P}-mp3transcode.patch
}
src_compile() {