summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Yamin <plasmaroo@gentoo.org>2004-07-04 19:10:32 +0000
committerTim Yamin <plasmaroo@gentoo.org>2004-07-04 19:10:32 +0000
commit889458da278d361ca71f9f748eb9da885506401e (patch)
tree3e2fc33a86a7e2c23a56d81b2698915af55dd756
parentUpdate from 3_3-rhl branch. Add PIE support back. (diff)
downloadgentoo-2-889458da278d361ca71f9f748eb9da885506401e.tar.gz
gentoo-2-889458da278d361ca71f9f748eb9da885506401e.tar.bz2
gentoo-2-889458da278d361ca71f9f748eb9da885506401e.zip
Version bump for the 2.6 IPTables RDoS vulnerability; bug #55694.
-rw-r--r--sys-kernel/xbox-sources/ChangeLog8
-rw-r--r--sys-kernel/xbox-sources/files/digest-xbox-sources-2.6.7-r1 (renamed from sys-kernel/xbox-sources/files/digest-xbox-sources-2.6.7)0
-rw-r--r--sys-kernel/xbox-sources/files/xbox-sources.IPTables-RDoS.patch11
-rw-r--r--sys-kernel/xbox-sources/xbox-sources-2.6.7-r1.ebuild (renamed from sys-kernel/xbox-sources/xbox-sources-2.6.7.ebuild)4
4 files changed, 20 insertions, 3 deletions
diff --git a/sys-kernel/xbox-sources/ChangeLog b/sys-kernel/xbox-sources/ChangeLog
index 817c93c3cf97..d11a7563bee3 100644
--- a/sys-kernel/xbox-sources/ChangeLog
+++ b/sys-kernel/xbox-sources/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-kernel/xbox-sources
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/ChangeLog,v 1.1 2004/06/30 01:26:07 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/ChangeLog,v 1.2 2004/07/04 19:10:32 plasmaroo Exp $
+
+*xbox-sources-2.6.7-r1 (30 Jun 2004)
+
+ 04 Jul 2004; <plasmaroo@gentoo.org>:
+ Version bump for the 2.6 IPTables RDoS vulnerability; bug #55694. Old
+ version removed.
*xbox-sources-2.6.7 (30 Jun 2004)
diff --git a/sys-kernel/xbox-sources/files/digest-xbox-sources-2.6.7 b/sys-kernel/xbox-sources/files/digest-xbox-sources-2.6.7-r1
index 44de8f6c9172..44de8f6c9172 100644
--- a/sys-kernel/xbox-sources/files/digest-xbox-sources-2.6.7
+++ b/sys-kernel/xbox-sources/files/digest-xbox-sources-2.6.7-r1
diff --git a/sys-kernel/xbox-sources/files/xbox-sources.IPTables-RDoS.patch b/sys-kernel/xbox-sources/files/xbox-sources.IPTables-RDoS.patch
new file mode 100644
index 000000000000..8f89d1605c9a
--- /dev/null
+++ b/sys-kernel/xbox-sources/files/xbox-sources.IPTables-RDoS.patch
@@ -0,0 +1,11 @@
+--- net/ipv4/netfilter/ip_tables.c.orig 2004-04-04 05:36:47.000000000 +0200
++++ net/ipv4/netfilter/ip_tables.c 2004-06-24 21:24:26.000000000 +0200
+@@ -1461,7 +1461,7 @@
+ int *hotdrop)
+ {
+ /* tcp.doff is only 4 bits, ie. max 15 * 4 bytes */
+- char opt[60 - sizeof(struct tcphdr)];
++ u_int8_t opt[60 - sizeof(struct tcphdr)];
+ unsigned int i;
+
+ duprintf("tcp_match: finding option\n");
diff --git a/sys-kernel/xbox-sources/xbox-sources-2.6.7.ebuild b/sys-kernel/xbox-sources/xbox-sources-2.6.7-r1.ebuild
index e0ede5ed0ea0..c562545d713d 100644
--- a/sys-kernel/xbox-sources/xbox-sources-2.6.7.ebuild
+++ b/sys-kernel/xbox-sources/xbox-sources-2.6.7-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/xbox-sources-2.6.7.ebuild,v 1.1 2004/06/30 01:26:07 chrb Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-kernel/xbox-sources/xbox-sources-2.6.7-r1.ebuild,v 1.1 2004/07/04 19:09:31 plasmaroo Exp $
ETYPE="sources"
inherit kernel-2
@@ -12,7 +12,7 @@ XBOX_PATCHES=xboxpatches-${KV_MAJOR}.${KV_MINOR}-${XPV}.tar.bz2
K_NOSETEXTRAVERSION="don't_set_it"
KEYWORDS="~x86 -*"
-UNIPATCH_LIST="${DISTDIR}/${XBOX_PATCHES}"
+UNIPATCH_LIST="${DISTDIR}/${XBOX_PATCHES} ${FILESDIR}/${PN}.IPTables-RDoS.patch"
DESCRIPTION="Full sources for the Xbox Linux kernel"
SRC_URI="${KERNEL_URI}
mirror://gentoo/${XBOX_PATCHES}"