summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2008-05-11 21:17:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2008-05-11 21:17:50 +0000
commit7622a9f53441c5e9327a84ab4ff375bebeef4a91 (patch)
treea1cbeaed09726a37364bfc37851f0bb0441fa9ce
parentport pic fix to this release too, bug #218267 (diff)
downloadgentoo-2-7622a9f53441c5e9327a84ab4ff375bebeef4a91.tar.gz
gentoo-2-7622a9f53441c5e9327a84ab4ff375bebeef4a91.tar.bz2
gentoo-2-7622a9f53441c5e9327a84ab4ff375bebeef4a91.zip
version bump, thanks Pavel
(Portage version: 2.1.5_rc10)
-rw-r--r--app-office/lyx/ChangeLog7
-rw-r--r--app-office/lyx/lyx-1.5.5.ebuild149
2 files changed, 155 insertions, 1 deletions
diff --git a/app-office/lyx/ChangeLog b/app-office/lyx/ChangeLog
index bb5b74d38956..7b70328a6275 100644
--- a/app-office/lyx/ChangeLog
+++ b/app-office/lyx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-office/lyx
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.130 2008/05/11 19:44:21 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/ChangeLog,v 1.131 2008/05/11 21:17:50 aballier Exp $
+
+*lyx-1.5.5 (11 May 2008)
+
+ 11 May 2008; Alexis Ballier <aballier@gentoo.org> +lyx-1.5.5.ebuild:
+ version bump, thanks Pavel
11 May 2008; Alexis Ballier <aballier@gentoo.org>
-files/lyx-1.4.2-gentoo.patch, -lyx-1.4.2.ebuild, -lyx-1.5.3.ebuild:
diff --git a/app-office/lyx/lyx-1.5.5.ebuild b/app-office/lyx/lyx-1.5.5.ebuild
new file mode 100644
index 000000000000..e918b65623eb
--- /dev/null
+++ b/app-office/lyx/lyx-1.5.5.ebuild
@@ -0,0 +1,149 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-office/lyx/lyx-1.5.5.ebuild,v 1.1 2008/05/11 21:17:50 aballier Exp $
+
+EAPI=1
+
+inherit qt4 eutils flag-o-matic font toolchain-funcs
+
+MY_P="${P/_}"
+S="${WORKDIR}/${MY_P}"
+FONT_P="latex-xft-fonts-0.1"
+FONT_S="${WORKDIR}/${FONT_P}"
+DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
+HOMEPAGE="http://www.lyx.org/"
+SRC_URI="ftp://ftp.lyx.org/pub/lyx/stable/${P}.tar.bz2
+ ftp://ftp.lyx.org/pub/lyx/contrib/${FONT_P}.tar.gz
+ linguas_he? (
+ http://cs.haifa.ac.il/~dekelts/lyx/files/hebrew.bind
+ http://cs.haifa.ac.il/~dekelts/lyx/files/preferences
+ )"
+
+LICENSE="GPL-2"
+SLOT="0"
+#KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86" # dev-tex/ivritex
+IUSE="cups debug nls linguas_he latex"
+RESTRICT="test"
+
+RDEPEND="|| ( ( x11-libs/qt-gui x11-libs/qt-core ) >=x11-libs/qt-4.1.1:4 )
+ x11-libs/libXrandr
+ x11-libs/libXcursor
+ x11-libs/libXrender
+ x11-libs/libXfixes
+ x11-libs/libXext
+ x11-libs/libSM
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXdmcp
+ media-gfx/imagemagick
+ media-libs/libpng
+ media-libs/fontconfig
+ media-libs/freetype
+ dev-libs/libxml2
+ app-text/aiksaurus
+ app-text/sgmltools-lite
+ virtual/aspell-dict
+ >=dev-lang/python-2.3.4
+ cups? ( virtual/lpr )
+ latex? (
+ virtual/latex-base
+ virtual/ghostscript
+ app-text/noweb
+ dev-tex/dvipost
+ dev-tex/chktex
+ || (
+ dev-tex/latex2html
+ dev-tex/tth
+ dev-tex/hevea
+ dev-tex/tex4ht
+ )
+ )
+ linguas_he? ( dev-tex/ivritex )"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ # bug #125309
+ epatch "${FILESDIR}"/${PN}-1.5.0-gentoo.patch || die
+}
+
+src_compile() {
+ append-flags "$(test-flags -fno-stack-protector -fno-stack-protector-all)"
+ replace-flags "-Os" "-O2"
+ tc-export CXX
+
+ unset LINGUAS
+ econf \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ --with-aspell || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ local mylinguas="${LINGUAS}"
+
+ unset LINGUAS
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ LINGUAS="${mylinguas}"
+
+ dodoc ANNOUNCE ChangeLog NEWS README RELEASE-NOTES UPGRADING
+
+ if use linguas_he ; then
+ insinto /usr/share/lyx/bind
+ doins "${DISTDIR}"/hebrew.bind
+ dodoc "${DISTDIR}"/preferences
+ fi
+
+ domenu "${FILESDIR}"/lyx.desktop
+
+ # install the latex-xft fonts, which should fix
+ # the problems outlined in bug #15629
+ # <obz@gentoo.org>
+ cd "${WORKDIR}"/${FONT_P}
+ emake DESTDIR="${D}" install || die "Font installation failed"
+
+ font_src_install
+
+ # fix for bug 91108
+ if use latex ; then
+ dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx
+ fi
+}
+
+pkg_postinst() {
+ font_pkg_postinst
+
+ # fix for bug 91108
+ if use latex ; then
+ texhash
+ fi
+
+ if use linguas_he ; then
+ elog
+ elog "How to use Hebrew in LyX:"
+ elog "bunzip2 /usr/share/doc/${PF}/preferences.bz2 into ~/.lyx/preferences"
+ elog "or, read http://cs.haifa.ac.il/~dekelts/lyx/instructions2.html"
+ elog "for instructions on using lyx's own preferences dialog to equal effect."
+ elog
+ fi
+
+ elog
+ elog "There are known issues in the case of 1.4->1.5 config files transition."
+ elog "In case your File->Export list is incomplete try reconfiguring or even"
+ elog "remove the old configuration files in ~/.lyx ."
+ elog
+}
+
+pkg_postrm() {
+ if use latex ; then
+ texhash
+ fi
+}