summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-17 15:24:27 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2012-08-17 15:24:27 +0000
commit6b3e544da1a2c06d7f7a75bfed25621754a86a2f (patch)
treeddd282122aedd6efc9d0fb7c35e7d6c99acef543
parentFix Changelog. (diff)
downloadgentoo-2-6b3e544da1a2c06d7f7a75bfed25621754a86a2f.tar.gz
gentoo-2-6b3e544da1a2c06d7f7a75bfed25621754a86a2f.tar.bz2
gentoo-2-6b3e544da1a2c06d7f7a75bfed25621754a86a2f.zip
Improvement related to node autoconfiguration: depend on netcat if java is enabled (required for JMX's autoconfiguration); drop munin_stats if not installing master; update patches to fix autoconf for more plugins.
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
-rw-r--r--net-analyzer/munin/ChangeLog10
-rw-r--r--net-analyzer/munin/munin-2.0.5-r1.ebuild (renamed from net-analyzer/munin/munin-2.0.5.ebuild)18
2 files changed, 22 insertions, 6 deletions
diff --git a/net-analyzer/munin/ChangeLog b/net-analyzer/munin/ChangeLog
index 49a273dede46..40b10543d8cc 100644
--- a/net-analyzer/munin/ChangeLog
+++ b/net-analyzer/munin/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-analyzer/munin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.92 2012/08/14 21:45:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/ChangeLog,v 1.93 2012/08/17 15:24:27 flameeyes Exp $
+
+*munin-2.0.5-r1 (17 Aug 2012)
+
+ 17 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> +munin-2.0.5-r1.ebuild,
+ -munin-2.0.5.ebuild:
+ Improvement related to node autoconfiguration: depend on netcat if java is
+ enabled (required for JMX's autoconfiguration); drop munin_stats if not
+ installing master; update patches to fix autoconf for more plugins.
14 Aug 2012; Diego E. Pettenò <flameeyes@gentoo.org> -munin-2.0.4-r2.ebuild,
munin-2.0.5.ebuild:
diff --git a/net-analyzer/munin/munin-2.0.5.ebuild b/net-analyzer/munin/munin-2.0.5-r1.ebuild
index 966399dede25..151f543ad35f 100644
--- a/net-analyzer/munin/munin-2.0.5.ebuild
+++ b/net-analyzer/munin/munin-2.0.5-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.5.ebuild,v 1.2 2012/08/14 21:45:35 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/munin/munin-2.0.5-r1.ebuild,v 1.1 2012/08/17 15:24:27 flameeyes Exp $
EAPI=4
-PATCHSET=1
+PATCHSET=2
inherit eutils user java-pkg-opt-2
@@ -75,7 +75,10 @@ DEPEND="${DEPEND_COM}
dev-perl/IO-Socket-INET6
)"
RDEPEND="${DEPEND_COM}
- java? ( >=virtual/jre-1.5 )
+ java? (
+ >=virtual/jre-1.5
+ || ( net-analyzer/netcat6 net-analyzer/netcat )
+ )
!minimal? (
virtual/cron
media-fonts/dejavu
@@ -130,11 +133,12 @@ src_install() {
/etc/munin/plugins/"
keepdir ${dirs}
fowners munin:munin ${dirs}
- use minimal || dirs+=" /etc/munin/munin-conf.d/"
local install_targets="install-common-prime install-node-prime install-plugins-prime"
use java && install_targets+=" install-plugins-java"
+
use minimal || install_targets=install
+ use minimal || dirs+=" /etc/munin/munin-conf.d/"
# parallel install doesn't work and it's also pointless to have this
# run in parallel for now (because it uses internal loops).
@@ -164,7 +168,11 @@ src_install() {
"${D}"/etc/munin/munin-node.conf || die
fi
- if ! use minimal; then
+ if use minimal; then
+ # This requires the presence of munin-update, which is part of
+ # the non-minimal install...
+ rm "${D}"/usr/libexec/munin/plugins/munin_stats
+ else
exeinto /etc/local.d/
newexe "${FILESDIR}"/localstart-munin 50munin.start