summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTheo Chatzimichos <tampakrap@gentoo.org>2011-02-07 10:05:34 +0000
committerTheo Chatzimichos <tampakrap@gentoo.org>2011-02-07 10:05:34 +0000
commit68b1bcf15263801f82e025eaca70cd4a11501e88 (patch)
treea44b4c0447f70cc8576931a53541b58163a6f3ee
parentRevision bump, improved patches, fix tests, bug 315217, ebuild and patches by... (diff)
downloadgentoo-2-68b1bcf15263801f82e025eaca70cd4a11501e88.tar.gz
gentoo-2-68b1bcf15263801f82e025eaca70cd4a11501e88.tar.bz2
gentoo-2-68b1bcf15263801f82e025eaca70cd4a11501e88.zip
Revision bump, improved patches, ebuild and patches by Dennis Schridde
(Portage version: 2.2.0_alpha20/cvs/Linux x86_64)
-rw-r--r--dev-libs/libindicate/ChangeLog14
-rw-r--r--dev-libs/libindicate/files/libindicate-0.4.4-mono-parallel-make.patch12
-rw-r--r--dev-libs/libindicate/files/libindicate-0.4.4-optional-doc.patch37
-rw-r--r--dev-libs/libindicate/files/libindicate-0.4.4-optional-gtk.patch52
-rw-r--r--dev-libs/libindicate/files/libindicate-0.4.91-fix-python-version.patch26
-rw-r--r--dev-libs/libindicate/files/libindicate-0.4.91-optional-mono.patch43
-rw-r--r--dev-libs/libindicate/files/libindicate-0.4.91-optional-python.patch51
-rw-r--r--dev-libs/libindicate/libindicate-0.4.4-r2.ebuild83
8 files changed, 278 insertions, 40 deletions
diff --git a/dev-libs/libindicate/ChangeLog b/dev-libs/libindicate/ChangeLog
index fee04d931cab..adf2f9b72293 100644
--- a/dev-libs/libindicate/ChangeLog
+++ b/dev-libs/libindicate/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for dev-libs/libindicate
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.11 2011/01/29 16:09:34 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/ChangeLog,v 1.12 2011/02/07 10:05:34 tampakrap Exp $
+
+*libindicate-0.4.4-r2 (07 Feb 2011)
+
+ 07 Feb 2011; Theo Chatzimichos <tampakrap@gentoo.org>
+ +libindicate-0.4.4-r2.ebuild,
+ +files/libindicate-0.4.4-mono-parallel-make.patch,
+ files/libindicate-0.4.4-optional-doc.patch,
+ files/libindicate-0.4.4-optional-gtk.patch,
+ +files/libindicate-0.4.91-fix-python-version.patch,
+ +files/libindicate-0.4.91-optional-mono.patch,
+ +files/libindicate-0.4.91-optional-python.patch:
+ Revision bump, improved patches, ebuild and patches by Dennis Schridde
*libindicate-0.4.4-r1 (29 Jan 2011)
diff --git a/dev-libs/libindicate/files/libindicate-0.4.4-mono-parallel-make.patch b/dev-libs/libindicate/files/libindicate-0.4.4-mono-parallel-make.patch
new file mode 100644
index 000000000000..1554b4c14bb8
--- /dev/null
+++ b/dev-libs/libindicate/files/libindicate-0.4.4-mono-parallel-make.patch
@@ -0,0 +1,12 @@
+--- bindings/mono/indicate/Makefile.am.orig 2011-01-30 00:14:17.670042664 +0100
++++ bindings/mono/indicate/Makefile.am 2011-01-30 00:14:40.204346425 +0100
+@@ -61,7 +61,8 @@
+ -e "s|PROP_MENU|menu|" \
+ -e "s|PROP_DESKTOP|Desktop|" \
+ -e "s|PROP_DESKTOP|desktop|" \
+- $< > $@
++ $< > $@.tmp
++ mv $@.tmp $@
+
+ api_includes = $(GTK_SHARP_CFLAGS)
+
diff --git a/dev-libs/libindicate/files/libindicate-0.4.4-optional-doc.patch b/dev-libs/libindicate/files/libindicate-0.4.4-optional-doc.patch
index b4f6d6f9dbbc..13c09f90fc86 100644
--- a/dev-libs/libindicate/files/libindicate-0.4.4-optional-doc.patch
+++ b/dev-libs/libindicate/files/libindicate-0.4.4-optional-doc.patch
@@ -6,31 +6,40 @@
+AC_ARG_ENABLE([doc],
+ AC_HELP_STRING([--disable-doc], [Disable doc generation]),
-+ [enable_doc=$enableval], enable_doc=auto)
++ [enable_doc=$enableval], [enable_doc=auto])
+AM_CONDITIONAL([WANT_DOC], [test "x$enable_doc" != "xno"])
+
GTK_DOC_CHECK([1.4])
-+if test "x$enable_doc" != "xno" ; then
++AS_IF([test "x$enable_doc" != "xno"],[
GNOME_DOC_INIT
-+else
++],[
+# The initialisation is still needed for certain conditionals to be defined, just make it not output any error
+GNOME_DOC_INIT(,,[:])
-+fi
++])
GNOME_COMPILE_WARNINGS
##############################
+@@ -271,2 +281,7 @@
+- GObject Introspection: $enable_introspection
+-])
++ GObject Introspection: $enable_introspection
++])
++
++AM_COND_IF([HAVE_GNOME_DOC_UTILS],
++ [AC_MSG_NOTICE([ Documentation: yes])],
++ [AC_MSG_NOTICE([ Documentation: no])]
++)
--- Makefile.am.orig 2010-09-20 23:12:10.442903362 +0200
+++ Makefile.am 2010-09-20 23:27:12.557785756 +0200
-@@ -5,7 +5,10 @@
- bindings \
- examples \
-- tests \
-- docs
-+ tests
-+
+@@ -1,2 +1,6 @@
+
+if WANT_DOC
-+SUBDIRS += docs
++DOC_SUBDIR = docs
+endif
++
+ SUBDIRS = \
+@@ -8,3 +12,3 @@
+ tests \
+- docs
++ $(DOC_SUBDIR)
- EXTRA_DIST = \
- COPYING.LGPL.2.1 \
diff --git a/dev-libs/libindicate/files/libindicate-0.4.4-optional-gtk.patch b/dev-libs/libindicate/files/libindicate-0.4.4-optional-gtk.patch
index 6376b46d7089..2c5b2592a3b0 100644
--- a/dev-libs/libindicate/files/libindicate-0.4.4-optional-gtk.patch
+++ b/dev-libs/libindicate/files/libindicate-0.4.4-optional-gtk.patch
@@ -1,42 +1,44 @@
--- configure.ac.orig 2010-09-20 23:15:36.692289201 +0200
+++ configure.ac 2010-09-20 23:17:50.380918143 +0200
-@@ -66,12 +66,20 @@
-
- GDK_PIXBUF_REQUIRED_VERSION=2.12
+@@ -66,3 +66,9 @@
+AC_ARG_ENABLE([gtk],
+ AC_HELP_STRING([--disable-gtk], [Disable libindicate-gtk library]),
-+ [enable_gtk=$enableval], enable_gtk=auto)
++ [enable_gtk=$enableval], [enable_gtk=auto])
+AM_CONDITIONAL([WANT_LIBINDICATEGTK], [test "x$enable_gtk" != "xno"])
+
-+if test "x$enable_gtk" != "xno" ; then
- PKG_CHECK_MODULES(LIBINDICATEGTK, glib-2.0 >= $GLIB_REQUIRED_VERSION
- gio-2.0 >= $GIO_REQUIRED_VERSION
- gdk-pixbuf-2.0 >= $GDK_PIXBUF_REQUIRED_VERSION
- gtk+-2.0 >= $GTK_REQUIRED_VERSION
- dbusmenu-glib >= $DBUSMENU_REQUIRED_VERSION
- dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
-+fi
-+
++AS_IF([test "x$enable_gtk" != "xno"],[
+ GDK_PIXBUF_REQUIRED_VERSION=2.12
+
+@@ -74,4 +80,7 @@
+- dbus-glib-1 >= $DBUS_REQUIRED_VERSION)
++ dbus-glib-1 >= $DBUS_REQUIRED_VERSION,
++ [have_gtk=yes]
++)
AC_SUBST(LIBINDICATEGTK_CFLAGS)
AC_SUBST(LIBINDICATEGTK_LIBS)
++])
+@@ -271,2 +280,7 @@
+- GObject Introspection: $enable_introspection
+-])
++ GObject Introspection: $enable_introspection
++])
++
++AS_IF([test "x$have_gtk" = "xyes"],
++ [AC_MSG_NOTICE([ Gtk: yes])],
++ [AC_MSG_NOTICE([ Gtk: no])]
++)
--- Makefile.am.orig 2010-09-20 23:12:10.442903362 +0200
+++ Makefile.am 2010-09-20 23:17:35.141406450 +0200
-@@ -1,12 +1,15 @@
+@@ -1,5 +1,9 @@
++if WANT_LIBINDICATEGTK
++LIBINDICATEGTK_SUBDIR = libindicate-gtk
++endif
++
SUBDIRS = \
libindicate \
- libindicate-gtk \
++ $(LIBINDICATEGTK_SUBDIR) \
bindings \
- examples \
- tests \
- docs
-
-+if WANT_LIBINDICATEGTK
-+SUBDIRS += libindicate-gtk
-+endif
-+
- EXTRA_DIST = \
- COPYING.LGPL.2.1 \
- gtk-doc.make \
diff --git a/dev-libs/libindicate/files/libindicate-0.4.91-fix-python-version.patch b/dev-libs/libindicate/files/libindicate-0.4.91-fix-python-version.patch
new file mode 100644
index 000000000000..c08f982ac7a9
--- /dev/null
+++ b/dev-libs/libindicate/files/libindicate-0.4.91-fix-python-version.patch
@@ -0,0 +1,26 @@
+--- configure.ac.orig 2011-01-29 21:38:44.667942630 +0100
++++ configure.ac 2011-01-29 21:42:03.892863493 +0100
+@@ -153,15 +153,16 @@
+-AM_PATH_PYTHON(2.3.5)
+-AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
+-
++PYTHON_REQUIRED=2.3.5
+ PYGTK_REQUIRED=2.14.0
+ PYGOBJECT_REQUIRED=0.22
+
+-PKG_CHECK_MODULES(INDICATE_PYTHON, [pygtk-2.0 >= $PYGTK_REQUIRED
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED],
+- [have_python=yes]
++AM_PATH_PYTHON([$PYTHON_REQUIRED])
++AM_CHECK_PYTHON_HEADERS(,[AC_MSG_ERROR(could not find Python headers)])
++
++PKG_CHECK_MODULES([INDICATE_PYTHON], [python-$PYTHON_VERSION >= $PYTHON_REQUIRED
++ pygtk-2.0 >= $PYGTK_REQUIRED
++ pygobject-2.0 >= $PYGOBJECT_REQUIRED],
++ [have_python=yes]
+ )
+
+-INDICATE_PYTHON_LIBS+=$(python$PYTHON_VERSION-config --libs)
+ # libpyglib-2.0-python* doesn't have a pkgconfig unfortunately
+ INDICATE_PYTHON_LIBS+=" -lpyglib-2.0-python$PYTHON_VERSION"
+
diff --git a/dev-libs/libindicate/files/libindicate-0.4.91-optional-mono.patch b/dev-libs/libindicate/files/libindicate-0.4.91-optional-mono.patch
new file mode 100644
index 000000000000..d663389db9bb
--- /dev/null
+++ b/dev-libs/libindicate/files/libindicate-0.4.91-optional-mono.patch
@@ -0,0 +1,43 @@
+--- configure.ac.orig 2011-01-29 21:02:19.646030407 +0100
++++ configure.ac 2011-01-29 21:12:00.156516831 +0100
+@@ -91,6 +91,12 @@
+ # Check for Mono support
+ ###########################
+
++AC_ARG_ENABLE([mono],
++ AC_HELP_STRING([--disable-mono], [Disable Mono bindings generation]),
++ [enable_mono=$enableval], [enable_mono=auto])
++AM_CONDITIONAL([WANT_MONO], [test "x$enable_mono" != "xno"])
++
++AS_IF([test "x$enable_mono" != "xno"],[
+ MONO_REQUIRED_VERSION=1.0
+ PKG_CHECK_MODULES(MONO_DEPENDENCY, mono >= $MONO_REQUIRED_VERSION, has_mono=true, has_mono=false)
+
+@@ -141,6 +147,7 @@
+ AC_SUBST(GAPI_CODEGEN)
+ AC_PATH_PROG(GAPI_FIXUP, gapi2-fixup, no)
+ AC_SUBST(GAPI_FIXUP)
++])
+
+ ###########################
+ # Check for Python support
+@@ -273,2 +280,7 @@
+- GObject Introspection: $enable_introspection
+-])
++ GObject Introspection: $enable_introspection
++])
++
++AS_IF([test "x$has_mono" = "xtrue"],
++ [AC_MSG_NOTICE([ Mono bindings: yes])],
++ [AC_MSG_NOTICE([ Mono bindings: no])]
++)
+--- bindings/Makefile.am.orig 2011-01-29 21:10:05.095991987 +0100
++++ bindings/Makefile.am 2011-01-29 21:11:06.349142195 +0100
+@@ -1,2 +1,6 @@
++if WANT_MONO
++MONO_SUBDIR = mono
++endif
++
+-SUBDIRS = mono python
++SUBDIRS = $(MONO_SUBDIR) python
+
diff --git a/dev-libs/libindicate/files/libindicate-0.4.91-optional-python.patch b/dev-libs/libindicate/files/libindicate-0.4.91-optional-python.patch
new file mode 100644
index 000000000000..43d42fbd22fb
--- /dev/null
+++ b/dev-libs/libindicate/files/libindicate-0.4.91-optional-python.patch
@@ -0,0 +1,51 @@
+--- configure.ac.orig 2011-01-29 21:51:17.724952231 +0100
++++ configure.ac 2011-01-29 21:52:29.969745013 +0100
+@@ -146,4 +146,14 @@
+ # Check for Python support
+ ###########################
+
++AC_ARG_ENABLE([python],
++ AC_HELP_STRING([--disable-python], [Disable Python bindings generation]),
++ [enable_python=$enableval], [enable_python=auto])
++AM_CONDITIONAL([WANT_PYTHON], [test "x$enable_python" != "xno"])
++
++AS_IF([test "x$enable_python" != "xno"],[
++ AS_IF([test "x$have_gtk" != "xyes"],[
++ AC_MSG_ERROR([Python bindings require GTK support, please --enable-gtk])
++ ])
++
+ AM_PATH_PYTHON(2.3.5)
+@@ -156,2 +166,4 @@
+- pygobject-2.0 >= $PYGOBJECT_REQUIRED])
++ pygobject-2.0 >= $PYGOBJECT_REQUIRED],
++ [have_python=yes]
++)
+
+@@ -171,6 +183,7 @@
+ PYGTK_CODEGEN="$PYTHON `$PKG_CONFIG --variable=codegendir pygtk-2.0`/codegen.py"
+ AC_SUBST(PYGTK_CODEGEN)
+ AC_MSG_RESULT($PYGTK_CODEGEN)
++])
+
+ ###########################
+ # GTK Doc
+@@ -271,2 +284,7 @@
+- GObject Introspection: $enable_introspection
+-])
++ GObject Introspection: $enable_introspection
++])
++
++AS_IF([test "x$have_python" = "xyes"],
++ [AC_MSG_NOTICE([ Python bindings: yes])],
++ [AC_MSG_NOTICE([ Python bindings: no])]
++)
+--- bindings/Makefile.am.orig 2011-01-29 21:53:17.826282713 +0100
++++ bindings/Makefile.am 2011-01-29 21:53:52.951209371 +0100
+@@ -1,2 +1,6 @@
++if WANT_PYTHON
++PYTHON_SUBDIR = python
++endif
++
+-SUBDIRS = mono python
++SUBDIRS = mono $(PYTHON_SUBDIR)
+
diff --git a/dev-libs/libindicate/libindicate-0.4.4-r2.ebuild b/dev-libs/libindicate/libindicate-0.4.4-r2.ebuild
new file mode 100644
index 000000000000..17156b214e3b
--- /dev/null
+++ b/dev-libs/libindicate/libindicate-0.4.4-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/libindicate/libindicate-0.4.4-r2.ebuild,v 1.1 2011/02/07 10:05:34 tampakrap Exp $
+
+EAPI=2
+
+inherit autotools eutils versionator
+
+DESCRIPTION="Library to raise flags on DBus for other components of the desktop to pick up and visualize"
+HOMEPAGE="https://launchpad.net/libindicate/"
+SRC_URI="http://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +introspection"
+
+RESTRICT="test"
+
+# For the dependency on dev-libs/libdbusmenu see launchpad-bug #552667
+RDEPEND="dev-libs/glib:2[introspection=]
+ dev-libs/dbus-glib
+ <dev-libs/libdbusmenu-0.3.50[introspection=]
+ dev-libs/libxml2:2
+ x11-libs/gtk+:2
+ dev-python/pygtk
+ dev-dotnet/gtk-sharp
+ dev-dotnet/gtk-sharp-gapi"
+DEPEND="${RDEPEND}
+ doc? ( dev-util/gtk-doc )
+ introspection? ( >=dev-libs/gobject-introspection-0.6.3 )
+ dev-util/gtk-doc-am
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # Without patches:
+ # Make python optional, launchpad-bug #643921
+ # Make mono optional, launchpad-bug #643922
+
+ # Incomplete patches:
+ # Make gtk optional, needs optional-python or code modifications, launchpad-bug #431311
+ #epatch "${FILESDIR}/${P}-optional-gtk.patch"
+
+ # Make doc optional, launchpad-bug #643911
+ epatch "${FILESDIR}/${P}-optional-doc.patch"
+ # Do not compile mono-example by default, launchpad-bug #643912
+ epatch "${FILESDIR}/${P}-optional-mono-example.patch"
+ # Do not compile examples by default, launchpad-bug #643917
+ epatch "${FILESDIR}/${P}-optional-examples.patch"
+ # Fix trouble with autoreconf and m4 directory, launchpad-bug #683552
+ epatch "${FILESDIR}/${P}-fix-aclocal.patch"
+ # Fixup undeclared HAVE_INTROSPECTION, launchpad-bug #552537
+ epatch "${FILESDIR}/${P}-fix-introspection.patch"
+ # Fix out-of-source builds, launchpad-bug #643913
+ epatch "${FILESDIR}/${P}-fix-out-of-source-build.patch"
+ # Fix compilation for python != 2.6, launchpad-bug #594992
+ epatch "${FILESDIR}/${P}-fix-python-version.patch"
+ # Fix parallel-make for mono bindings, launchpad-bug #709954
+ epatch "${FILESDIR}/${P}-mono-parallel-make.patch"
+ # Drop -Werror in a release
+ sed -e 's:-Werror::g' -i libindicate/Makefile.am libindicate-gtk/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_configure() {
+ # gobject-instrospection is a nightmare in this package, it's fixable for libindicate
+ # and not for libindicate-gtk, disable it until its fixed on upstream
+ econf \
+ --disable-dependency-tracking \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable doc) \
+ $(use_enable introspection) \
+ || die "configure failed"
+}
+
+src_test() {
+ emake check || die "testsuite failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS || die "dodoc failed"
+}