summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-12-02 12:15:04 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-12-02 12:15:04 +0000
commit5f794e7ee74e5adc5d765b12fa61b97c8c9bb1e0 (patch)
tree7ea032e2aeb56c50770e10e3c14b83a9d12ef82b
parentCall udevadm with the hwdb target only if it's supported. (diff)
downloadgentoo-2-5f794e7ee74e5adc5d765b12fa61b97c8c9bb1e0.tar.gz
gentoo-2-5f794e7ee74e5adc5d765b12fa61b97c8c9bb1e0.tar.bz2
gentoo-2-5f794e7ee74e5adc5d765b12fa61b97c8c9bb1e0.zip
Prevent calling ext helper grep by sticking to bash-only. Thanks to Arfrever.
(Portage version: 2.2.0_alpha144/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
-rw-r--r--sys-apps/hwids/hwids-20121202.2.ebuild4
-rw-r--r--sys-apps/hwids/hwids-99999999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sys-apps/hwids/hwids-20121202.2.ebuild b/sys-apps/hwids/hwids-20121202.2.ebuild
index 4319939e19b4..614c8d057c55 100644
--- a/sys-apps/hwids/hwids-20121202.2.ebuild
+++ b/sys-apps/hwids/hwids-20121202.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121202.2.ebuild,v 1.5 2012/12/02 12:03:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-20121202.2.ebuild,v 1.6 2012/12/02 12:15:04 ssuominen Exp $
EAPI=5
inherit udev
@@ -52,7 +52,7 @@ src_install() {
}
pkg_postinst() {
- if use udev && udevadm 2>&1 | grep -qs hwdb; then
+ if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
udevadm hwdb --update
fi
}
diff --git a/sys-apps/hwids/hwids-99999999.ebuild b/sys-apps/hwids/hwids-99999999.ebuild
index 83bf373ab2c7..69e52f437c8b 100644
--- a/sys-apps/hwids/hwids-99999999.ebuild
+++ b/sys-apps/hwids/hwids-99999999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.8 2012/12/02 12:03:42 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/hwids/hwids-99999999.ebuild,v 1.9 2012/12/02 12:15:04 ssuominen Exp $
EAPI=5
inherit udev
@@ -48,7 +48,7 @@ src_install() {
}
pkg_postinst() {
- if use udev && udevadm 2>&1 | grep -qs hwdb; then
+ if use udev && [[ $(udevadm --help 2>&1) == *hwdb* ]]; then
udevadm hwdb --update
fi
}